summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2003-03-20 14:18:58 +0000
committerDan Armak <danarmak@gentoo.org>2003-03-20 14:18:58 +0000
commitd8930a285004a902da4e7ffc1d81bc111f26652a (patch)
treee25e114ea20771016a411b5ab85bddf044eaf518 /kde-base/kdelibs
parentChanged ~hppa to hppa in KEYWORDS. (diff)
downloadhistorical-d8930a285004a902da4e7ffc1d81bc111f26652a.tar.gz
historical-d8930a285004a902da4e7ffc1d81bc111f26652a.tar.bz2
historical-d8930a285004a902da4e7ffc1d81bc111f26652a.zip
new revisions that adds a patch to fix kde bug #55571 as posted on kde-packager - fixes https authentication through proxy
Diffstat (limited to 'kde-base/kdelibs')
-rw-r--r--kde-base/kdelibs/ChangeLog8
-rw-r--r--kde-base/kdelibs/files/digest-kdelibs-3.1.1-r11
-rw-r--r--kde-base/kdelibs/files/kdelibs-3.1.1-kio_http.diff160
-rw-r--r--kde-base/kdelibs/kdelibs-3.1.1-r1.ebuild78
4 files changed, 246 insertions, 1 deletions
diff --git a/kde-base/kdelibs/ChangeLog b/kde-base/kdelibs/ChangeLog
index 39249ff80dfa..974d3aa65eac 100644
--- a/kde-base/kdelibs/ChangeLog
+++ b/kde-base/kdelibs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kdelibs
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdelibs/ChangeLog,v 1.67 2003/03/19 15:43:31 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdelibs/ChangeLog,v 1.68 2003/03/20 14:18:58 danarmak Exp $
+
+*kdelibs-3.1.1-r1 (20 Mar 2003)
+
+ 20 Mar 2003; Dan Armak <danarmak@gentoo.org> kdelibs-3.1.1-r1.ebuild:
+
+ Add patch that fixes kde bug #55571 (https authentication through proxy).
14 Mar 2003; Dan Armak <danarmak@gentoo.org> kdelibs-3.0.5a-r1.ebuild:
diff --git a/kde-base/kdelibs/files/digest-kdelibs-3.1.1-r1 b/kde-base/kdelibs/files/digest-kdelibs-3.1.1-r1
new file mode 100644
index 000000000000..bc63cdc312e6
--- /dev/null
+++ b/kde-base/kdelibs/files/digest-kdelibs-3.1.1-r1
@@ -0,0 +1 @@
+MD5 15eb9412c589126844b277b9e80cfffc kdelibs-3.1.1.tar.bz2 10313173
diff --git a/kde-base/kdelibs/files/kdelibs-3.1.1-kio_http.diff b/kde-base/kdelibs/files/kdelibs-3.1.1-kio_http.diff
new file mode 100644
index 000000000000..dc8beb0ddca9
--- /dev/null
+++ b/kde-base/kdelibs/files/kdelibs-3.1.1-kio_http.diff
@@ -0,0 +1,160 @@
+cvs -f log -N -r1.551.2.9 http.cc
+
+RCS file: /home/kde/kdelibs/kioslave/http/http.cc,v
+Working file: http.cc
+head: 1.565
+branch:
+locks: strict
+access list:
+keyword substitution: kv
+total revisions: 632; selected revisions: 1
+description:
+----------------------------
+revision 1.551.2.9
+date: 2003/03/17 14:20:31; author: waba; state: Exp; lines: +112 -112
+CCMAIL: 55571-done@bugs.kde.org
+Fix Bug 55571: https authentication through proxy fails
+
+(This patch basically reverts r1.546 and r1.544)
+m_bNeedTunnel was incorrectly used to check whether we were busy connecting
+to a proxy or sending the actual request. Moved some code around so that it
+only gets executed when sending the actual request so that it isn't necassery
+any more to abuse m_bNeedTunnel for this.
+
+The resetting of m_bNeedTunnel caused bug 55571, it isn't necassery to reset
+it, the resetting was a poor attempt to let m_bNeedTunnel serve as a status
+indicator for something it wasn't intended to indicate.
+=============================================================================
+cvs -f diff -kk -bp -u -r1.551.2.8 -r1.551.2.9 http.cc
+Index: http.cc
+===================================================================
+RCS file: /home/kde/kdelibs/kioslave/http/http.cc,v
+retrieving revision 1.551.2.8
+retrieving revision 1.551.2.9
+diff -b -p -u -r1.551.2.8 -r1.551.2.9
+--- kioslave/http/http.cc 14 Feb 2003 19:50:53 -0000 1.551.2.8
++++ kioslave/http/http.cc 17 Mar 2003 14:20:31 -0000 1.551.2.9
+@@ -438,7 +438,6 @@ bool HTTPProtocol::retrieveHeader( bool
+ kdDebug(7113) << "(" << m_pid << ") Unset tunneling flag!" << endl;
+ setEnableSSLTunnel( false );
+ m_bIsTunneled = true;
+- m_bNeedTunnel = false;
+ // Reset the CONNECT response code...
+ m_responseCode = m_prevResponseCode;
+ continue;
+@@ -1936,7 +1935,42 @@ bool HTTPProtocol::httpOpen()
+ // Check the validity of the current connection, if one exists.
+ httpCheckConnection();
+
+- // Determine if this is a POST or GET method
++
++ if ( !m_bIsTunneled && m_bNeedTunnel )
++ {
++ setEnableSSLTunnel( true );
++ // We send a HTTP 1.0 header since some proxies refuse HTTP 1.1 and we don't
++ // need any HTTP 1.1 capabilities for CONNECT - Waba
++ header = QString("CONNECT %1:%2 HTTP/1.0"
++ "\r\n").arg( m_request.hostname).arg(m_request.port);
++
++ // Identify who you are to the proxy server!
++ if (!m_request.userAgent.isEmpty())
++ header += "User-Agent: " + m_request.userAgent + "\r\n";
++
++ /* Add hostname information */
++ header += "Host: ";
++ if (m_state.hostname.find(':') != -1)
++ {
++ // This is an IPv6 (not hostname)
++ header += '[';
++ header += m_state.hostname;
++ header += ']';
++ }
++ else
++ {
++ header += m_state.hostname;
++ }
++
++ if (m_state.port != m_iDefaultPort)
++ header += QString(":%1").arg(m_state.port);
++ header += "\r\n";
++
++ header += proxyAuthenticationHeader();
++ }
++ else
++ {
++ // Determine the kind of method we are handling...
+ switch (m_request.method)
+ {
+ case HTTP_GET:
+@@ -1944,12 +1978,12 @@ bool HTTPProtocol::httpOpen()
+ break;
+ case HTTP_PUT:
+ header = "PUT ";
+- moreData = !m_bNeedTunnel;
++ moreData = true;
+ m_request.bCachedWrite = false; // Do not put any result in the cache
+ break;
+ case HTTP_POST:
+ header = "POST ";
+- moreData = !m_bNeedTunnel;
++ moreData = true;
+ m_request.bCachedWrite = false; // Do not put any result in the cache
+ break;
+ case HTTP_HEAD:
+@@ -2033,40 +2067,6 @@ bool HTTPProtocol::httpOpen()
+ return false;
+ }
+
+- if ( !m_bIsTunneled && m_bNeedTunnel )
+- {
+- setEnableSSLTunnel( true );
+- // We send a HTTP 1.0 header since some proxies refuse HTTP 1.1 and we don't
+- // need any HTTP 1.1 capabilities for CONNECT - Waba
+- header = QString("CONNECT %1:%2 HTTP/1.0"
+- "\r\n").arg( m_request.hostname).arg(m_request.port);
+-
+- // Identify who you are to the proxy server!
+- if (!m_request.userAgent.isEmpty())
+- header += "User-Agent: " + m_request.userAgent + "\r\n";
+-
+- /* Add hostname information */
+- header += "Host: ";
+- if (m_state.hostname.find(':') != -1)
+- {
+- // This is an IPv6 (not hostname)
+- header += '[';
+- header += m_state.hostname;
+- header += ']';
+- }
+- else
+- {
+- header += m_state.hostname;
+- }
+-
+- if (m_state.port != m_iDefaultPort)
+- header += QString(":%1").arg(m_state.port);
+- header += "\r\n";
+-
+- header += proxyAuthenticationHeader();
+- }
+- else
+- {
+ // format the URI
+ if (m_state.doProxy && !m_bIsTunneled)
+ {
+@@ -2271,7 +2271,6 @@ bool HTTPProtocol::httpOpen()
+ // Do we need to authorize to the proxy server ?
+ if ( m_state.doProxy && !m_bIsTunneled )
+ header += proxyAuthenticationHeader();
+- }
+
+ if ( m_protocol == "webdav" || m_protocol == "webdavs" )
+ {
+@@ -2289,6 +2288,7 @@ bool HTTPProtocol::httpOpen()
+ // add extra header elements for WebDAV
+ if ( !davHeader.isNull() )
+ header += davHeader;
++ }
+ }
+
+ kdDebug(7103) << "(" << m_pid << ") ============ Sending Header:" << endl;
diff --git a/kde-base/kdelibs/kdelibs-3.1.1-r1.ebuild b/kde-base/kdelibs/kdelibs-3.1.1-r1.ebuild
new file mode 100644
index 000000000000..380a491fab2e
--- /dev/null
+++ b/kde-base/kdelibs/kdelibs-3.1.1-r1.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdelibs/kdelibs-3.1.1-r1.ebuild,v 1.1 2003/03/20 14:18:58 danarmak Exp $
+inherit kde kde.org
+#don't inherit kde-base or kde-dist! it calls need-kde which adds kdelibs to depend!
+
+IUSE="alsa cups ipv6 ssl"
+DESCRIPTION="KDE libraries needed by all kde programs"
+KEYWORDS="x86 ~ppc ~sparc ~alpha"
+HOMEPAGE="http//www.kde.org/"
+SLOT="3.1"
+LICENSE="GPL-2 LGPL-2"
+
+PATCHES="${FILESDIR}/${P}-zip.diff"
+
+# kde.eclass has kdelibs in DEPEND, and we can't have that in here.
+# so we recreate the entire DEPEND from scratch.
+DEPEND=""
+RDEPEND=""
+newdepend "dev-lang/perl
+ >=media-libs/audiofile-0.1.9
+ >=sys-apps/bzip2-1.0.1
+ >=dev-libs/libxslt-1.0.7
+ >=dev-libs/libpcre-3.5
+ >=dev-libs/libxml2-2.4.10
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ alsa? ( >=media-libs/alsa-lib-0.5.9 >=media-sound/alsa-driver-0.5.9 )
+ cups? ( >=net-print/cups-1.1.14 )
+ >=media-libs/tiff-3.5.5
+ app-admin/fam-oss
+ app-text/ghostscript
+ ~kde-base/arts-1.1.1" # this arts rev is part of the same fix
+
+newdepend "/c"
+newdepend "/autotools"
+
+RDEPEND="$RDEPEND
+ app-text/sgml-common
+ cups? ( net-print/cups )
+ dev-lang/python
+ >=sys-apps/portage-2.0.36" # for #7359
+
+myconf="$myconf --with-distribution=Gentoo --enable-libfam --enable-dnotify"
+use ipv6 || myconf="$myconf --with-ipv6-lookup=no"
+use ssl && myconf="$myconf --with-ssl-dir=/usr" || myconf="$myconf --without-ssl"
+use alsa && myconf="$myconf --with-alsa" || myconf="$myconf --without-alsa"
+use cups && myconf="$myconf --enable-cups" || myconf="$myconf --disable-cups"
+
+use x86 && myconf="$myconf --enable-fast-malloc=full"
+
+qtver-from-kdever ${PV}
+need-qt $selected_version
+
+set-kdedir $PV
+
+# patch posted on kde-packager, fixes kde bug #55571
+PATCHES="$FILESDIR/$P-kio_http.diff"
+
+src_unpack() {
+ kde_src_unpack
+ kde_sandbox_patch ${S}/kio/misc/kpac
+ use alpha && cd ${S} && epatch ${FILESDIR}/${P}-kjs-alphaev6-gcc3-workaround.patch
+}
+
+src_install() {
+ kde_src_install
+ dohtml *.html
+
+ # kdelibs-apidocs is provided by kdelibs-apidocs ebuild, kdelibs ebuild
+ # shouldn't install anything into kdelibs-apidocs (bug #15102)
+ rm -r ${D}/$KDEDIR/share/doc/HTML/en/kdelibs-apidocs
+}
+
+pkg_postinst() {
+ einfo "If you have kde 3.0.x installed, please upgrade to kdeils-3.0.5a-r2 and kdebase-3.0.5a-r1.
+ If they don't have your arch's keywords, edit /etc/env.d/65kdelibs-3.0.*, remove the KDEDIRS=
+ line and env-update."
+}