summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2009-06-04 13:56:48 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2009-06-04 13:56:48 +0000
commit5a13ccd21de0abab5282365a5070ba7229e9b098 (patch)
tree0793ec455fa77a823da333d1bf4faf15ecd53b10 /kde-base/kate
parentFix variable test. Thx to salnx per forums for the fix. (diff)
downloadhistorical-5a13ccd21de0abab5282365a5070ba7229e9b098.tar.gz
historical-5a13ccd21de0abab5282365a5070ba7229e9b098.tar.bz2
historical-5a13ccd21de0abab5282365a5070ba7229e9b098.zip
Version bump KDE 4.2.4
Package-Manager: portage-2.2_rc33/cvs/Linux x86_64 RepoMan-Options: --force
Diffstat (limited to 'kde-base/kate')
-rw-r--r--kde-base/kate/ChangeLog7
-rw-r--r--kde-base/kate/kate-4.2.4.ebuild41
2 files changed, 47 insertions, 1 deletions
diff --git a/kde-base/kate/ChangeLog b/kde-base/kate/ChangeLog
index e82c0c8d39a3..7ca9501ea790 100644
--- a/kde-base/kate/ChangeLog
+++ b/kde-base/kate/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kate
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kate/ChangeLog,v 1.135 2009/06/03 14:52:11 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kate/ChangeLog,v 1.136 2009/06/04 11:19:16 alexxy Exp $
+
+*kate-4.2.4 (04 Jun 2009)
+
+ 04 Jun 2009; Alexey Shvetsov <alexxy@gentoo.org> +kate-4.2.4.ebuild:
+ Version bump
03 Jun 2009; Alexey Shvetsov <alexxy@gentoo.org> -kate-4.2.2.ebuild:
Drop KDE 4.2.2
diff --git a/kde-base/kate/kate-4.2.4.ebuild b/kde-base/kate/kate-4.2.4.ebuild
new file mode 100644
index 000000000000..a486d4183ac4
--- /dev/null
+++ b/kde-base/kate/kate-4.2.4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kate/kate-4.2.4.ebuild,v 1.1 2009/06/04 11:19:16 alexxy Exp $
+
+EAPI="2"
+
+KMNAME="kdesdk"
+inherit kde4-meta
+
+DESCRIPTION="Kate is an MDI texteditor."
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug +handbook +plasma"
+
+DEPEND="
+ dev-libs/libxml2
+ dev-libs/libxslt
+"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ if use handbook; then
+ KMEXTRA="doc/kate-plugins"
+ fi
+
+ kde4-meta_src_unpack
+}
+
+src_prepare() {
+ # Disable hardcoded kdepimlibs check - only 4.2 branch is affected
+ sed -i -e 's/find_package(KdepimLibs REQUIRED)/macro_optional_find_package(KdepimLibs)/' \
+ CMakeLists.txt || die "failed to disable kdepimlibs hardcoded check"
+
+ kde4-meta_src_prepare
+}
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with plasma Plasma)"
+
+ kde4-meta_src_configure
+}