summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWulf Krueger <philantrop@gentoo.org>2008-02-20 23:36:47 +0000
committerWulf Krueger <philantrop@gentoo.org>2008-02-20 23:36:47 +0000
commit86166760b8aa7e1c789581787e2f7bd3d159df87 (patch)
tree3c1095c1c98ae9f6510c9d93134aa0062970a3bd /kde-base/kalyptus
parentEnabled support for openmpi and mpich2 (see bug #210639). (diff)
downloadhistorical-86166760b8aa7e1c789581787e2f7bd3d159df87.tar.gz
historical-86166760b8aa7e1c789581787e2f7bd3d159df87.tar.bz2
historical-86166760b8aa7e1c789581787e2f7bd3d159df87.zip
Version bump to KDE 3.5.9.
Package-Manager: portage-2.1.4.4
Diffstat (limited to 'kde-base/kalyptus')
-rw-r--r--kde-base/kalyptus/ChangeLog8
-rw-r--r--kde-base/kalyptus/files/kalyptus-3.5.9-fix_makefile.patch14
-rw-r--r--kde-base/kalyptus/kalyptus-3.5.9.ebuild34
3 files changed, 55 insertions, 1 deletions
diff --git a/kde-base/kalyptus/ChangeLog b/kde-base/kalyptus/ChangeLog
index 1046b6e64fc2..13169b46e8e3 100644
--- a/kde-base/kalyptus/ChangeLog
+++ b/kde-base/kalyptus/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kalyptus
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kalyptus/ChangeLog,v 1.55 2008/02/17 02:50:33 ingmar Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kalyptus/ChangeLog,v 1.56 2008/02/20 22:34:30 philantrop Exp $
+
+*kalyptus-3.5.9 (20 Feb 2008)
+
+ 20 Feb 2008; Wulf C. Krueger <philantrop@gentoo.org>
+ +files/kalyptus-3.5.9-fix_makefile.patch, +kalyptus-3.5.9.ebuild:
+ Version bump to KDE 3.5.9.
16 Feb 2008; Ingmar Vanhassel <ingmar@gentoo.org> -kalyptus-3.5.4.ebuild:
Spring cleaning
diff --git a/kde-base/kalyptus/files/kalyptus-3.5.9-fix_makefile.patch b/kde-base/kalyptus/files/kalyptus-3.5.9-fix_makefile.patch
new file mode 100644
index 000000000000..6e977bf88c46
--- /dev/null
+++ b/kde-base/kalyptus/files/kalyptus-3.5.9-fix_makefile.patch
@@ -0,0 +1,14 @@
+diff -Naur kalyptus-3.5.9.orig/kalyptus/Makefile.in kalyptus-3.5.9/kalyptus/Makefile.in
+--- kalyptus-3.5.9.orig/kalyptus/Makefile.in 2005-09-10 10:16:39.000000000 +0200
++++ kalyptus-3.5.9/kalyptus/Makefile.in 2008-02-16 22:18:59.000000000 +0100
+@@ -4,8 +4,8 @@
+ install = @INSTALL@
+ bin = kalyptus
+ pm = kdocUtil.pm kdocAstUtil.pm kdocParseDoc.pm kdocLib.pm \
+- Ast.pm kalyptusDataDict.pm kalyptusCxxToC.pm \
+- kalyptusCxxToObjc.pm kalyptusCxxToJava.pm \
++ Ast.pm kalyptusDataDict.pm \
++ kalyptusCxxToJava.pm \
+ kalyptusCxxToSmoke.pm kalyptusCxxToCSharp.pm \
+ Iter.pm
+ pmextra =
diff --git a/kde-base/kalyptus/kalyptus-3.5.9.ebuild b/kde-base/kalyptus/kalyptus-3.5.9.ebuild
new file mode 100644
index 000000000000..94e79a20bca0
--- /dev/null
+++ b/kde-base/kalyptus/kalyptus-3.5.9.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kalyptus/kalyptus-3.5.9.ebuild,v 1.1 2008/02/20 22:34:30 philantrop Exp $
+
+KMNAME=kdebindings
+KM_MAKEFILESREV=1
+EAPI="1"
+inherit kde-meta
+
+DESCRIPTION="KDE bindings generator for multiple languages."
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+DEPEND="dev-lang/perl"
+
+PATCHES="${FILESDIR}/${P}-fix_makefile.patch"
+
+MY_S="${WORKDIR}/${P}/${PN}"
+
+# Weird build system, weirder errors.
+# You're welcome to fix this in a better way --danarmak
+# Still weird, but changed. :)
+src_compile () {
+ S="${MY_S}"
+ cd "${S}"
+ emake -f Makefile.cvs
+ ./configure --prefix=$(kde-config --prefix)
+ emake
+}
+
+src_install() {
+ S="${MY_S}"
+ cd "${S}"
+ emake install DESTDIR="$D"
+}