summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2010-10-13 15:16:41 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2010-10-13 15:16:41 +0000
commit20ec56ccadd6ae6b9a6a5d07b71bd466f3f32e8f (patch)
tree4a72c2c3aa05d68cb8f1a4461f81cda73419e57d /gnustep-base
parentOnly convert files that are mentioned in the patchs and only do it for _p ebu... (diff)
downloadhistorical-20ec56ccadd6ae6b9a6a5d07b71bd466f3f32e8f.tar.gz
historical-20ec56ccadd6ae6b9a6a5d07b71bd466f3f32e8f.tar.bz2
historical-20ec56ccadd6ae6b9a6a5d07b71bd466f3f32e8f.zip
Initial commit, use temporary gnustep-make so real gnustep-make can depend on this one day
Package-Manager: portage-2.2_rc94/cvs/Linux x86_64
Diffstat (limited to 'gnustep-base')
-rw-r--r--gnustep-base/libobjc2/ChangeLog11
-rw-r--r--gnustep-base/libobjc2/Manifest5
-rw-r--r--gnustep-base/libobjc2/libobjc2-1.0.ebuild49
-rw-r--r--gnustep-base/libobjc2/metadata.xml27
4 files changed, 92 insertions, 0 deletions
diff --git a/gnustep-base/libobjc2/ChangeLog b/gnustep-base/libobjc2/ChangeLog
new file mode 100644
index 000000000000..014977044cf8
--- /dev/null
+++ b/gnustep-base/libobjc2/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for gnustep-base/libobjc2
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/gnustep-base/libobjc2/ChangeLog,v 1.1 2010/10/13 15:16:41 voyageur Exp $
+
+*libobjc2-1.0 (13 Oct 2010)
+
+ 13 Oct 2010; Bernard Cafarelli <voyageur@gentoo.org> +libobjc2-1.0.ebuild,
+ +metadata.xml:
+ Initial commit, use temporary gnustep-make so real gnustep-make can depend
+ on this one day
+
diff --git a/gnustep-base/libobjc2/Manifest b/gnustep-base/libobjc2/Manifest
new file mode 100644
index 000000000000..02cb24c2a3f4
--- /dev/null
+++ b/gnustep-base/libobjc2/Manifest
@@ -0,0 +1,5 @@
+DIST gnustep-make-2.4.0.tar.gz 521818 RMD160 6f1dd81039c9935e41eb7988923c3b3c6507e383 SHA1 afda14186394c65b0871dba93f92dc965b2fc724 SHA256 8ad6c9d0e532e0bf70fdc25abe60afbd4103b16dc47b324646a147cbac6c6ef9
+DIST libobjc2-1.0.tar.bz2 66560 RMD160 24b4329f5a2416ca5b1e489599eea642137d5a4e SHA1 45229f7057839a4b7f82c84a8f76888fc5726893 SHA256 8903157a6fe6b82b4571a33855f98e0da0fe92a94f69a9a5edd1af94310f0566
+EBUILD libobjc2-1.0.ebuild 1265 RMD160 b132751d66419ab92a9343aa24af82fff044cd97 SHA1 19d19b0e91fa3820b873e888fa315284ba55d853 SHA256 707bebbbca977de5e806e2937d0f63813c6def05be0ca6219d1db1e6c744551b
+MISC ChangeLog 436 RMD160 c2ad22730d36ce3c0c748ad94f1f72a3adcb3714 SHA1 6c818d030dcf4c3b5b292bd0f196742b790f97a0 SHA256 b3ef80a3ee96f792e3d2f9976077b3d45dfc125a05ef2c78aceb5ab9c853edee
+MISC metadata.xml 1000 RMD160 f690d496d08d713b6e13cf667c108a8c34afb69a SHA1 9f0e5c27c268d04c28f0fd053ce8a7f542522726 SHA256 1ebede837fa5494828df361bba9f025ea5fe7cd5cc6720656560e6b2ee4af1df
diff --git a/gnustep-base/libobjc2/libobjc2-1.0.ebuild b/gnustep-base/libobjc2/libobjc2-1.0.ebuild
new file mode 100644
index 000000000000..d10d21671f58
--- /dev/null
+++ b/gnustep-base/libobjc2/libobjc2-1.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnustep-base/libobjc2/libobjc2-1.0.ebuild,v 1.1 2010/10/13 15:16:41 voyageur Exp $
+
+EAPI=3
+inherit multilib
+
+# We need gnustep-make, but gnustep-make can depend on libobjc
+# Use a temporary setup to install in /usr/
+GSMAKE=gnustep-make-2.4.0
+DESCRIPTION="GNUstep Objective-C runtime"
+HOMEPAGE="http://www.gnustep.org"
+SRC_URI="http://download.gna.org/gnustep/${P}.tar.bz2
+ ftp://ftp.gnustep.org/pub/gnustep/core/${GSMAKE}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=sys-devel/gcc-3.3[objc]
+ >=sys-devel/make-3.75"
+RDEPEND=""
+
+S=${WORKDIR}/${PN}
+GSMAKE_S=${WORKDIR}/${GSMAKE}
+
+src_prepare() {
+ # Multilib-strict
+ cd "${GSMAKE_S}"
+ sed -e "s/lib/$(get_libdir)/g" \
+ -i FilesystemLayouts/fhs-system || die "multilib path sed failed"
+}
+
+src_configure() {
+ cd "${GSMAKE_S}"
+ econf --with-layout=fhs-system
+}
+
+src_compile() {
+ emake GNUSTEP_MAKEFILES="${GSMAKE_S}" || die "compilation failed"
+}
+
+src_install() {
+ emake GNUSTEP_MAKEFILES="${GSMAKE_S}" \
+ GNUSTEP_CONFIG_FILE="${GSMAKE_S}"/GNUstep.conf \
+ GNUSTEP_INSTALLATION_DOMAIN=SYSTEM \
+ DESTDIR="${D}" install || die "install has failed"
+}
diff --git a/gnustep-base/libobjc2/metadata.xml b/gnustep-base/libobjc2/metadata.xml
new file mode 100644
index 000000000000..6d5c816014c3
--- /dev/null
+++ b/gnustep-base/libobjc2/metadata.xml
@@ -0,0 +1,27 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>gnustep</herd>
+ <longdescription>
+The GNUstep Objective-C runtime is designed as a drop-in replacement for the
+GCC runtime. It supports both a legacy and a modern ABI, allowing code
+compiled with old versions of GCC to be supported without requiring
+recompilation. The modern ABI adds the following features:
+
+- Non-fragile instance variables.
+- Protocol uniquing.
+- Object planes support.
+- Declared property introspection.
+
+Both ABIs support the following feature above and beyond the GCC runtime:
+
+- The modern Objective-C runtime APIs, introduced with OS X 10.5.
+- Blocks (closures).
+- Low memory profile for platforms where memory usage is more important than
+ speed.
+- Synthesised property accessors.
+- Efficient support for @synchronized()
+- Type-dependent dispatch, eliminating stack corruption from mismatched
+ selectors.
+</longdescription>
+</pkgmetadata>