summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2007-08-18 14:56:40 +0000
committerFabian Groffen <grobian@gentoo.org>2007-08-18 14:56:40 +0000
commit05c253ec3d61ed1be354cf43f717c637008b2576 (patch)
tree05c4e7d3cc3684fad7d31b825984e83bef3151e1 /gnustep-base
parentUpdated udev rules, to work with newer kernels, Bug #188573. This requires ne... (diff)
downloadhistorical-05c253ec3d61ed1be354cf43f717c637008b2576.tar.gz
historical-05c253ec3d61ed1be354cf43f717c637008b2576.tar.bz2
historical-05c253ec3d61ed1be354cf43f717c637008b2576.zip
Bump from GNUstep overlay. Using new gnustep eclasses
Package-Manager: portage-2.1.2.11
Diffstat (limited to 'gnustep-base')
-rw-r--r--gnustep-base/gnustep-gui/ChangeLog8
-rw-r--r--gnustep-base/gnustep-gui/files/digest-gnustep-gui-0.12.03
-rw-r--r--gnustep-base/gnustep-gui/gnustep-gui-0.12.0.ebuild43
-rw-r--r--gnustep-base/mknfonts/ChangeLog8
-rw-r--r--gnustep-base/mknfonts/files/digest-mknfonts-0.5-r13
-rw-r--r--gnustep-base/mknfonts/files/mknfonts-rename.patch15
-rw-r--r--gnustep-base/mknfonts/mknfonts-0.5-r1.ebuild24
7 files changed, 102 insertions, 2 deletions
diff --git a/gnustep-base/gnustep-gui/ChangeLog b/gnustep-base/gnustep-gui/ChangeLog
index ebd93bf594b5..e46a42e1b617 100644
--- a/gnustep-base/gnustep-gui/ChangeLog
+++ b/gnustep-base/gnustep-gui/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnustep-base/gnustep-gui
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-gui/ChangeLog,v 1.44 2007/07/22 10:25:37 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-gui/ChangeLog,v 1.45 2007/08/18 14:52:24 grobian Exp $
+
+*gnustep-gui-0.12.0 (18 Aug 2007)
+
+ 18 Aug 2007; Fabian Groffen <grobian@gentoo.org>
+ +gnustep-gui-0.12.0.ebuild:
+ Bump from GNUstep overlay. Using new gnustep eclasses
22 Jul 2007; Donnie Berkholz <dberkholz@gentoo.org>;
gnustep-gui-0.9.5.ebuild, gnustep-gui-0.10.3.ebuild,
diff --git a/gnustep-base/gnustep-gui/files/digest-gnustep-gui-0.12.0 b/gnustep-base/gnustep-gui/files/digest-gnustep-gui-0.12.0
new file mode 100644
index 000000000000..745c79f9d5ee
--- /dev/null
+++ b/gnustep-base/gnustep-gui/files/digest-gnustep-gui-0.12.0
@@ -0,0 +1,3 @@
+MD5 13f1ec9910a99105ed0f1f79f2ff2db0 gnustep-gui-0.12.0.tar.gz 1738576
+RMD160 886839d60065dbb598d9aefed929a820a0b5dc36 gnustep-gui-0.12.0.tar.gz 1738576
+SHA256 07fc74efb2db23a4499289aa690754d533c19897681152add93a074c05fd8a6e gnustep-gui-0.12.0.tar.gz 1738576
diff --git a/gnustep-base/gnustep-gui/gnustep-gui-0.12.0.ebuild b/gnustep-base/gnustep-gui/gnustep-gui-0.12.0.ebuild
new file mode 100644
index 000000000000..7ed7d4d1229a
--- /dev/null
+++ b/gnustep-base/gnustep-gui/gnustep-gui-0.12.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-gui/gnustep-gui-0.12.0.ebuild,v 1.1 2007/08/18 14:52:24 grobian Exp $
+
+inherit gnustep-base
+
+DESCRIPTION="Library of GUI classes written in Obj-C"
+HOMEPAGE="http://www.gnustep.org/"
+SRC_URI="ftp://ftp.gnustep.org/pub/gnustep/core/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+LICENSE="LGPL-2.1"
+
+IUSE="jpeg gif png cups"
+
+DEPEND="${GNUSTEP_CORE_DEPEND}
+ >=gnustep-base/gnustep-base-1.14.0
+ x11-libs/libXt
+ >=media-libs/tiff-3
+ jpeg? ( >=media-libs/jpeg-6b )
+ gif? ( >=media-libs/giflib-4.1 )
+ png? ( >=media-libs/libpng-1.2 )
+ cups? ( >=net-print/cups-1.1 )
+ media-libs/audiofile
+ app-text/aspell"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ egnustep_env
+
+ myconf="--with-tiff-include=/usr/include --with-tiff-library=/usr/lib"
+ use gif && myconf="$myconf --disable-ungif --enable-libgif"
+ myconf="$myconf `use_enable jpeg`"
+ myconf="$myconf `use_enable png`"
+ myconf="$myconf `use_enable cups`"
+ # gsnd is disabled until portaudio-19 is unmasked in portage
+ myconf="$myconf --disable-gsnd"
+
+ econf $myconf || die "configure failed"
+
+ egnustep_make || die
+}
diff --git a/gnustep-base/mknfonts/ChangeLog b/gnustep-base/mknfonts/ChangeLog
index 1e28194c059a..63d784728ea3 100644
--- a/gnustep-base/mknfonts/ChangeLog
+++ b/gnustep-base/mknfonts/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnustep-base/mknfonts
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnustep-base/mknfonts/ChangeLog,v 1.14 2007/02/09 07:49:10 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnustep-base/mknfonts/ChangeLog,v 1.15 2007/08/18 14:56:40 grobian Exp $
+
+*mknfonts-0.5-r1 (18 Aug 2007)
+
+ 18 Aug 2007; Fabian Groffen <grobian@gentoo.org>
+ +files/mknfonts-rename.patch, +mknfonts-0.5-r1.ebuild:
+ Bump from GNUstep overlay. Using new gnustep eclasses
09 Feb 2007; Diego Pettenò <flameeyes@gentoo.org> ChangeLog:
Regenerate digest in Manifest2 format.
diff --git a/gnustep-base/mknfonts/files/digest-mknfonts-0.5-r1 b/gnustep-base/mknfonts/files/digest-mknfonts-0.5-r1
new file mode 100644
index 000000000000..32ae9b351b29
--- /dev/null
+++ b/gnustep-base/mknfonts/files/digest-mknfonts-0.5-r1
@@ -0,0 +1,3 @@
+MD5 1cd463efe56c274379bdbd4ecf50b08a mknfonts.tool_0.5.orig.tar.gz 2890
+RMD160 0baef5e7fbfdd8e8f4cba0183524c8a2086d54ac mknfonts.tool_0.5.orig.tar.gz 2890
+SHA256 5afc97d63c918f14026239bcc97104c3f990ed144c50f639fd04e03bac207f30 mknfonts.tool_0.5.orig.tar.gz 2890
diff --git a/gnustep-base/mknfonts/files/mknfonts-rename.patch b/gnustep-base/mknfonts/files/mknfonts-rename.patch
new file mode 100644
index 000000000000..ffd49997177c
--- /dev/null
+++ b/gnustep-base/mknfonts/files/mknfonts-rename.patch
@@ -0,0 +1,15 @@
+--- mknfonts.m.orig 2007-05-03 11:46:27.000000000 +0200
++++ mknfonts.m 2007-05-03 11:47:34.000000000 +0200
+@@ -310,12 +310,6 @@
+ {
+ fi=[faceinfos objectAtIndex: i];
+ [faces addObject: [fi faceInfoDictionary]];
+- for (j=0;j<[fi->files count];j++)
+- {
+- [fm movePath: [fi->files objectAtIndex: j]
+- toPath: [path stringByAppendingPathComponent: [[fi->files objectAtIndex: j] lastPathComponent]]
+- handler: nil];
+- }
+ }
+
+ [family_info
diff --git a/gnustep-base/mknfonts/mknfonts-0.5-r1.ebuild b/gnustep-base/mknfonts/mknfonts-0.5-r1.ebuild
new file mode 100644
index 000000000000..f1468c7b3621
--- /dev/null
+++ b/gnustep-base/mknfonts/mknfonts-0.5-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnustep-base/mknfonts/mknfonts-0.5-r1.ebuild,v 1.1 2007/08/18 14:56:40 grobian Exp $
+
+inherit eutils gnustep-base
+
+DESCRIPTION="Provides the tool to create .nfont packages suitable for use with gnustep-back-art."
+
+HOMEPAGE="http://packages.debian.org/mknfonts.tool"
+SRC_URI="mirror://debian/pool/main/m/${PN}.tool/${PN}.tool_${PV}.orig.tar.gz"
+KEYWORDS="~x86 ~amd64"
+SLOT="0"
+LICENSE="GPL-2"
+
+DEPEND="gnustep-base/gnustep-gui
+ >=media-libs/freetype-2.1"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/${PN}-rename.patch
+}