summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2002-04-29 04:43:53 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2002-04-29 04:43:53 +0000
commitdb170f79f6eb2bcc2406f80070d354daea997e8e (patch)
treea60ab06ee3f6717b85c64bd6bfe350e30de8138a /gnome-extra
parentversion bump (diff)
downloadhistorical-db170f79f6eb2bcc2406f80070d354daea997e8e.tar.gz
historical-db170f79f6eb2bcc2406f80070d354daea997e8e.tar.bz2
historical-db170f79f6eb2bcc2406f80070d354daea997e8e.zip
Added app-text/scrollkeeper to DEPEND. resolves bug #2138
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/libgda/ChangeLog9
-rw-r--r--gnome-extra/libgda/files/digest-libgda-0.2.95-r11
-rw-r--r--gnome-extra/libgda/libgda-0.2.95-r1.ebuild120
3 files changed, 129 insertions, 1 deletions
diff --git a/gnome-extra/libgda/ChangeLog b/gnome-extra/libgda/ChangeLog
index 30f53c2c051a..9e5c9d518977 100644
--- a/gnome-extra/libgda/ChangeLog
+++ b/gnome-extra/libgda/ChangeLog
@@ -1,7 +1,14 @@
# ChangeLog for gnome-extra/libgda
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/libgda/ChangeLog,v 1.1 2002/02/01 21:53:29 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/libgda/ChangeLog,v 1.2 2002/04/29 04:43:53 mkennedy Exp $
+*libgda-0.2.95-r1 (29 Apr 2002)
+
+ 29 Apr 2002; Matthew Kennedy <mkennedy@gentoo.org> ChangeLog,
+ libgda-0.2.95-r1.ebuild, files/digest-libgda-0.2.95-r1 :
+
+ Added app-text/scrollkeeper to DEPEND.
+
*libgda-0.2.95 (1 Feb 2002)
1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
diff --git a/gnome-extra/libgda/files/digest-libgda-0.2.95-r1 b/gnome-extra/libgda/files/digest-libgda-0.2.95-r1
new file mode 100644
index 000000000000..e64c1a19887d
--- /dev/null
+++ b/gnome-extra/libgda/files/digest-libgda-0.2.95-r1
@@ -0,0 +1 @@
+MD5 4edd46fc1ead7ff1b2931fbf5a24d600 libgda-0.2.95.tar.gz 1320331
diff --git a/gnome-extra/libgda/libgda-0.2.95-r1.ebuild b/gnome-extra/libgda/libgda-0.2.95-r1.ebuild
new file mode 100644
index 000000000000..93e2abcc8ffb
--- /dev/null
+++ b/gnome-extra/libgda/libgda-0.2.95-r1.ebuild
@@ -0,0 +1,120 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/libgda/libgda-0.2.95-r1.ebuild,v 1.1 2002/04/29 04:43:53 mkennedy Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="gda lib"
+SRC_URI="ftp://ftp.gnome-db.org/pub/gnome-db/sources/latest/${P}.tar.gz
+ ftp://ftp.gnome.org/pub/GNOME/stable/sources/${PN}/${P}.tar.gz"
+HOMEPAGE="http://www.gnome.org/gnome-db"
+
+RDEPEND="virtual/glibc
+ >=gnome-base/gconf-1.0.4-r2
+ >=gnome-base/oaf-0.6.6-r1
+ >=gnome-base/bonobo-1.0.9-r1
+ >=dev-libs/libxslt-1.0.1
+ >=sys-libs/gdbm-1.8.0
+ >=sys-libs/readline-4.1
+ >=dev-perl/CORBA-ORBit-0.4.3
+ >=dev-db/sqlite-2.0.8
+ mysql? ( >=dev-db/mysql-3.23.26 )
+ postgres? ( >=dev-db/postgresql-7.1 )
+ odbc? ( >=dev-db/unixODBC-1.8.13 )
+ ldap? ( >=net-nds/openldap-1.2.11 )"
+
+DEPEND="${RDEPEND}
+ >=app-text/scrollkeeper-0.2-r3
+ sys-apps/which"
+
+
+src_compile() {
+
+ local myconf
+
+ if [ "`use mysql`" ]
+ then
+ myconf="--with-mysql=/usr"
+ fi
+
+ if [ "`use ldap`" ]
+ then
+ myconf="$myconf --with-ldap=/usr"
+ fi
+
+ if [ "`use odbc`" ]
+ then
+ myconf="$myconf --with-odbc"
+ fi
+
+ if [ "`use postgres`" ]
+ then
+ myconf="$myconf --with-postgres=/usr"
+ fi
+
+ # Wierd one, it dont detect bonobo. If someone could have a look
+ # and fix if i havent gotten to it yet.
+# myconf="$myconf --disable-bonobotest"
+
+ # Do not compile buildin sqlite
+ cp configure configure.orig
+ grep -v sqlite configure.orig >configure
+ chmod +x configure
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var/lib \
+ $myconf || die
+
+ # Build and use an external version of sqlite since some versions
+ # of libgda have a bug where the buildin do not compile.
+ # Also cant hurt to use the latest version of sqlite :)
+ mv ${S}/providers/gda-default-server/gda-default.h \
+ ${S}/gda-default.h.orig
+ sed -e 's/\"build_sqlite\/sqlite\.h\"/<sqlite.h>/' \
+ ${S}/gda-default.h.orig > \
+ ${S}/providers/gda-default-server/gda-default.h || die
+ ln -s /usr/lib/libsqlite.a \
+ ${S}/providers/gda-default-server/sqlite/libsqlite.a
+ mv providers/gda-default-server/Makefile \
+ providers/gda-default-server/Makefile.orig
+ grep -v '= sqlite' providers/gda-default-server/Makefile.orig > \
+ providers/gda-default-server/Makefile
+
+ # Doesn't work with -j 4 (hallski)
+ make LDFLAGS="-lncurses" LIBREADLINE="-lreadline -lncurses" || die
+}
+
+src_install() {
+
+ cd ${S}/doc
+ cp Makefile Makefile.old
+ sed -e "s:scrollkeeper-update.*::g" Makefile.old > Makefile
+ rm Makefile.old
+ cd ${S}
+
+ make prefix=${D}/usr \
+ sysconfdir=${D}/etc \
+ localstatedir=${D}/var/lib \
+ INSTALLMAN3DIR=${D}/usr/share/man/man3 \
+ GDA_oafinfodir=${D}/usr/share/oaf \
+ install || die
+
+ into /usr
+
+ # Not needed as we build sqlite seperately
+# dobin providers/gda-default-server/build_sqlite/{lemon,sqlite}
+
+ dodoc AUTHORS COPYING.* ChangeLog NEWS README
+}
+
+pkg_postinst() {
+ echo ">>> Updating Scrollkeeper database..."
+ scrollkeeper-update >/dev/null 2>&1
+}
+
+pkg_postrm() {
+ echo ">>> Updating Scrollkeeper database..."
+ scrollkeeper-update >/dev/null 2>&1
+}