summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-03-26 20:05:41 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-03-26 20:05:41 +0000
commitdddfe04293f955d14b2f318f21ac408fd83e8e81 (patch)
tree469322def2f749febddb65f6e68d6b47fb683432 /gnome-extra/wp_tray
parentInclude upstream patches and opensuse fixes for crashes when printing and fre... (diff)
downloadhistorical-dddfe04293f955d14b2f318f21ac408fd83e8e81.tar.gz
historical-dddfe04293f955d14b2f318f21ac408fd83e8e81.tar.bz2
historical-dddfe04293f955d14b2f318f21ac408fd83e8e81.zip
Fix building with x11-libs/libnotify >= 0.7 wrt #360627 by Joost Ruis.
Package-Manager: portage-2.2.0_alpha28/cvs/Linux x86_64
Diffstat (limited to 'gnome-extra/wp_tray')
-rw-r--r--gnome-extra/wp_tray/ChangeLog6
-rw-r--r--gnome-extra/wp_tray/files/wp_tray-0.5.5-libnotify-0.7.patch28
-rw-r--r--gnome-extra/wp_tray/wp_tray-0.5.5.ebuild12
3 files changed, 41 insertions, 5 deletions
diff --git a/gnome-extra/wp_tray/ChangeLog b/gnome-extra/wp_tray/ChangeLog
index 1b0d207ab33b..8b22b1298c1e 100644
--- a/gnome-extra/wp_tray/ChangeLog
+++ b/gnome-extra/wp_tray/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for gnome-extra/wp_tray
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/wp_tray/ChangeLog,v 1.5 2011/01/11 20:19:47 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/wp_tray/ChangeLog,v 1.6 2011/03/26 20:05:41 ssuominen Exp $
+
+ 26 Mar 2011; Samuli Suominen <ssuominen@gentoo.org> wp_tray-0.5.5.ebuild,
+ +files/wp_tray-0.5.5-libnotify-0.7.patch:
+ Fix building with x11-libs/libnotify >= 0.7 wrt #360627 by Joost Ruis.
11 Jan 2011; Pacho Ramos <pacho@gentoo.org> wp_tray-0.5.5.ebuild:
Needs gnome-panel with bonobo support (bug #348173).
diff --git a/gnome-extra/wp_tray/files/wp_tray-0.5.5-libnotify-0.7.patch b/gnome-extra/wp_tray/files/wp_tray-0.5.5-libnotify-0.7.patch
new file mode 100644
index 000000000000..b835a8a81663
--- /dev/null
+++ b/gnome-extra/wp_tray/files/wp_tray-0.5.5-libnotify-0.7.patch
@@ -0,0 +1,28 @@
+--- src/LibNotify.cc
++++ src/LibNotify.cc
+@@ -11,6 +11,10 @@
+ #include "LibNotify.hh"
+ #include "Applet.hh"
+
++#ifndef NOTIFY_CHECK_VERSION
++#define NOTIFY_CHECK_VERSION(x,y,z) 0
++#endif
++
+ //------------------------------------------------------------------------
+ /**
+ <fn_NotifyCallbackReject>
+@@ -111,9 +115,12 @@
+ NotifyNotification * p_Notification = notify_notification_new (
+ _("Wallpaper Tray is about to change your wallpaper"),
+ sz_MsgText.c_str(),
+- NULL,
+- NULL//GTK_WIDGET(m_pApplet->gobj())
++ NULL
++#if NOTIFY_CHECK_VERSION (0, 7, 0)
+ );
++#else
++ , NULL);
++#endif
+
+ m_SigcConnection = Glib::signal_timeout().connect (
+ sigc::mem_fun(this, &LibNotify::OnNotificationChangeAccept), 1000 * 7
diff --git a/gnome-extra/wp_tray/wp_tray-0.5.5.ebuild b/gnome-extra/wp_tray/wp_tray-0.5.5.ebuild
index ebf9f29e10ec..53c029548200 100644
--- a/gnome-extra/wp_tray/wp_tray-0.5.5.ebuild
+++ b/gnome-extra/wp_tray/wp_tray-0.5.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/wp_tray/wp_tray-0.5.5.ebuild,v 1.6 2011/01/11 20:19:47 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/wp_tray/wp_tray-0.5.5.ebuild,v 1.7 2011/03/26 20:05:41 ssuominen Exp $
EAPI=2
GCONF_DEBUG=no
@@ -17,10 +17,11 @@ IUSE=""
RDEPEND="|| ( gnome-base/gnome-panel[bonobo] <gnome-base/gnome-panel-2.32 )
>=gnome-base/libgnomeui-2
- >=x11-libs/gtk+-2
+ x11-libs/gtk+:2
>=gnome-base/libglade-2
dev-cpp/libgnomeuimm
- dev-cpp/libxmlpp"
+ dev-cpp/libxmlpp
+ x11-libs/libnotify"
DEPEND="${RDEPEND}
dev-util/pkgconfig
dev-libs/boost"
@@ -32,7 +33,10 @@ pkg_setup() {
}
src_prepare() {
- epatch "${FILESDIR}"/${P}-gcc45.patch
+ epatch \
+ "${FILESDIR}"/${P}-gcc45.patch \
+ "${FILESDIR}"/${P}-libnotify-0.7.patch
+
gnome2_src_prepare
}