summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gardiner <obz@gentoo.org>2003-10-13 17:10:23 +0000
committerMike Gardiner <obz@gentoo.org>2003-10-13 17:10:23 +0000
commit160f7df35da178318d8571e5481bff77f0d6145a (patch)
tree72053bc5a0eaae033477bc2d0cce12a65eeaf9ca /gnome-extra/libgda
parentNew version (diff)
downloadhistorical-160f7df35da178318d8571e5481bff77f0d6145a.tar.gz
historical-160f7df35da178318d8571e5481bff77f0d6145a.tar.bz2
historical-160f7df35da178318d8571e5481bff77f0d6145a.zip
New version
Diffstat (limited to 'gnome-extra/libgda')
-rw-r--r--gnome-extra/libgda/Manifest4
-rw-r--r--gnome-extra/libgda/files/digest-libgda-1.0.11
-rw-r--r--gnome-extra/libgda/libgda-1.0.1.ebuild101
3 files changed, 104 insertions, 2 deletions
diff --git a/gnome-extra/libgda/Manifest b/gnome-extra/libgda/Manifest
index 165002a20a9f..29fcb521d54e 100644
--- a/gnome-extra/libgda/Manifest
+++ b/gnome-extra/libgda/Manifest
@@ -2,9 +2,9 @@ MD5 ec4c66af4e7ca373e370223b7d126a4b libgda-0.2.96-r2.ebuild 3495
MD5 21d7bf915f9fdd61a090b47644a39662 libgda-0.12.1.ebuild 2570
MD5 084cc2ae44169bf5200493bd49c428e9 libgda-1.0.0.ebuild 2535
MD5 37f9b04c394742e1ffcb6bf1218b6358 libgda-0.2.95-r1.ebuild 3283
-MD5 10e28d9c4f764fa78820012131af36ae ChangeLog 4266
+MD5 1cc4efbb322af0e53192719771c77e4a ChangeLog 4373
MD5 03ad2e6c4ab41244af1015a8bbb0b39f metadata.xml 158
-MD5 ba86defa6eb1f9f1ccf523d39e620c9c libgda-1.0.1.ebuild 2434
+MD5 9d9efab5162c093b02596779f7f59490 libgda-1.0.1.ebuild 2532
MD5 3ca3af1e56c86303037c0792d9c90d3d files/digest-libgda-1.0.0 66
MD5 49ea693a813a629d57b5fe1ac8001ff6 files/digest-libgda-1.0.1 66
MD5 40bbf8acf6e08a15e8e61573f6f07724 files/digest-libgda-0.2.95-r1 66
diff --git a/gnome-extra/libgda/files/digest-libgda-1.0.1 b/gnome-extra/libgda/files/digest-libgda-1.0.1
new file mode 100644
index 000000000000..6d8e03614b51
--- /dev/null
+++ b/gnome-extra/libgda/files/digest-libgda-1.0.1
@@ -0,0 +1 @@
+MD5 a3f7c8aed0d85e68e1dd8ae3343ce476 libgda-1.0.1.tar.bz2 1029966
diff --git a/gnome-extra/libgda/libgda-1.0.1.ebuild b/gnome-extra/libgda/libgda-1.0.1.ebuild
new file mode 100644
index 000000000000..a3e8f5bd6844
--- /dev/null
+++ b/gnome-extra/libgda/libgda-1.0.1.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/libgda/libgda-1.0.1.ebuild,v 1.1 2003/10/13 17:10:10 obz Exp $
+
+IUSE="odbc postgres mysql ldap firebird freetds sqlite mdb oci8 doc"
+
+inherit gnome2
+
+DESCRIPTION="Gnome Database Access Library"
+HOMEPAGE="http://www.gnome-db.org/"
+SLOT="1"
+LICENSE="GPL-2 LGPL-2"
+KEYWORDS="~x86 ~ppc"
+
+RDEPEND=">=dev-libs/glib-2.0
+ >=dev-libs/libxml2-2.0
+ >=dev-libs/libxslt-1.0.9
+ >=gnome-base/gnome-vfs-2.0
+ dev-libs/popt
+ sys-libs/ncurses
+ mysql? ( >=dev-db/mysql-3.23.51 )
+ postgres? ( >=dev-db/postgresql-7.2.1 )
+ odbc? ( >=dev-db/unixODBC-2.0.6 )
+ ldap? ( >=net-nds/openldap-2.0.25 )
+ firebird? ( >=dev-db/firebird-1.0 )
+ freetds? ( >=dev-db/freetds-0.5 )
+ sqlite? ( >=dev-db/sqlite-2.4.2 )
+ mdb? ( >=app-office/mdbtools-0.5 )"
+
+DEPEND=">=dev-util/pkgconfig-0.8
+ >=dev-util/intltool-0.22
+ >=sys-devel/gettext-0.11
+ app-text/scrollkeeper
+ doc? ( dev-util/gtk-doc )
+ ${RDEPEND}"
+
+DOCS="AUTHORS COPYING* ChangeLog INSTALL NEWS README"
+
+# problems with parallel builds
+MAKEOPTS="${MAKEOPTS} -j1"
+
+src_unpack() {
+ unpack ${A}
+ gnome2_omf_fix ${S}/doc/Makefile.in
+}
+
+src_compile() {
+
+ local myconf
+
+ use mysql \
+ && myconf="${myconf} --with-mysql=/usr" \
+ || myconf="${myconf} --without-mysql"
+
+ use postgres \
+ && myconf="${myconf} --with-postgres=/usr" \
+ || myconf="${myconf} --without-postgres"
+
+ use odbc \
+ && myconf="${myconf} --with-odbc=/usr" \
+ || myconf="${myconf} --without-odbc"
+
+ use ldap \
+ && myconf="${myconf} --with-ldap=/usr" \
+ || myconf="${myconf} --without-ldap"
+
+ use sqlite \
+ && myconf="$myconf --with-sqlite=/usr" \
+ || myconf="$myconf --without-sqlite"
+
+ use freetds \
+ && myconf="$myconf --with-tds=/usr" \
+ || myconf="$myconf --without-tds"
+
+ use firebird \
+ && myconf="${myconf} --with-firebird=/usr" \
+ || myconf="${myconf} --without-firebird"
+
+ use mdb \
+ && myconf="${myconf} --with-mdb=/usr" \
+ || myconf="${myconf} --without-mdb"
+
+ # not in portage (http://linux.techass.com/projects/xdb/)
+ myconf="${myconf} --without-xbase"
+ myconf="${myconf} --without-msql"
+
+ # closed source dbs
+ myconf="${myconf} --without-ibmdb2"
+ myconf="${myconf} --without-sybase"
+ use oci8 || myconf="${myconf} --without-oracle"
+
+ # workaround for readline-4.1 profile - disables building of gda-config-tool
+ if has_version "=sys-libs/readline-4.1*"; then
+ export CONFIG_TOOL_HEADERS="wrong"
+ fi
+
+ gnome2_src_compile ${myconf}
+
+ unset CONFIG_TOOL_HEADERS
+
+}