summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-11-07 11:01:30 +0000
committerAchim Gottinger <achim@gentoo.org>2001-11-07 11:01:30 +0000
commit7e8c8e8f96fd3a79c3306ddfa97de882962dd677 (patch)
tree4bf749f8d0a8d8d7669ed23d1552102cf174a347 /gnome-base
parentnew updated recommended package. (diff)
downloadhistorical-7e8c8e8f96fd3a79c3306ddfa97de882962dd677.tar.gz
historical-7e8c8e8f96fd3a79c3306ddfa97de882962dd677.tar.bz2
historical-7e8c8e8f96fd3a79c3306ddfa97de882962dd677.zip
*** empty log message ***
Diffstat (limited to 'gnome-base')
-rw-r--r--gnome-base/gconf/files/gconf-1.0.7-gentoo.diff64
-rw-r--r--gnome-base/gconf/gconf-1.0.7.ebuild8
2 files changed, 71 insertions, 1 deletions
diff --git a/gnome-base/gconf/files/gconf-1.0.7-gentoo.diff b/gnome-base/gconf/files/gconf-1.0.7-gentoo.diff
new file mode 100644
index 000000000000..33c866e4b555
--- /dev/null
+++ b/gnome-base/gconf/files/gconf-1.0.7-gentoo.diff
@@ -0,0 +1,64 @@
+diff -ur GConf-1.0.7/backends.orig/xml-backend.c GConf-1.0.7/backends/xml-backend.c
+--- GConf-1.0.7/backends.orig/xml-backend.c Fri Oct 12 21:30:26 2001
++++ GConf-1.0.7/backends/xml-backend.c Sat Nov 24 15:26:48 2001
+@@ -26,8 +26,8 @@
+ #include "xml-cache.h"
+
+
+-#include <libxml/tree.h>
+-#include <libxml/parser.h>
++#include <gnome-xml/tree.h>
++#include <gnome-xml/parser.h>
+
+ #include <stdio.h>
+ #include <time.h>
+diff -ur GConf-1.0.7/backends.orig/xml-cache.h GConf-1.0.7/backends/xml-cache.h
+--- GConf-1.0.7/backends.orig/xml-cache.h Fri Oct 12 21:01:20 2001
++++ GConf-1.0.7/backends/xml-cache.h Sat Nov 24 15:27:04 2001
+@@ -21,7 +21,7 @@
+ #define GCONF_XML_CACHE_H
+
+ #include <gconf/gconf.h>
+-#include <libxml/tree.h>
++#include <gnome-xml/tree.h>
+ #include "xml-dir.h"
+
+ typedef struct _Cache Cache;
+diff -ur GConf-1.0.7/backends.orig/xml-dir.c GConf-1.0.7/backends/xml-dir.c
+--- GConf-1.0.7/backends.orig/xml-dir.c Fri Oct 12 21:01:25 2001
++++ GConf-1.0.7/backends/xml-dir.c Sat Nov 24 15:27:19 2001
+@@ -20,7 +20,7 @@
+ #include "xml-dir.h"
+ #include "xml-entry.h"
+
+-#include <libxml/parser.h>
++#include <gnome-xml/parser.h>
+
+ #include <stdio.h>
+ #include <time.h>
+diff -ur GConf-1.0.7/backends.orig/xml-dir.h GConf-1.0.7/backends/xml-dir.h
+--- GConf-1.0.7/backends.orig/xml-dir.h Fri Oct 12 21:01:30 2001
++++ GConf-1.0.7/backends/xml-dir.h Sat Nov 24 15:27:27 2001
+@@ -21,7 +21,7 @@
+ #define GCONF_XML_DIR_H
+
+ #include <gconf/gconf.h>
+-#include <libxml/tree.h>
++#include <gnome-xml/tree.h>
+
+ /* Dir stores the information about a given directory */
+
+diff -ur GConf-1.0.7/backends.orig/xml-entry.c GConf-1.0.7/backends/xml-entry.c
+--- GConf-1.0.7/backends.orig/xml-entry.c Fri Oct 12 21:30:58 2001
++++ GConf-1.0.7/backends/xml-entry.c Sat Nov 24 15:27:44 2001
+@@ -20,8 +20,8 @@
+ #include "xml-entry.h"
+ #include <gconf/gconf-internals.h>
+ #include <stdlib.h>
+-#include <libxml/entities.h>
+-#include <libxml/xmlmemory.h>
++#include <gnome-xml/entities.h>
++#include <gnome-xml/xmlmemory.h>
+
+ static void
+ entry_sync_if_needed(Entry* e, GConfValue* val);
diff --git a/gnome-base/gconf/gconf-1.0.7.ebuild b/gnome-base/gconf/gconf-1.0.7.ebuild
index 90a2ce804782..5b766f3d0129 100644
--- a/gnome-base/gconf/gconf-1.0.7.ebuild
+++ b/gnome-base/gconf/gconf-1.0.7.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gconf/gconf-1.0.7.ebuild,v 1.1 2001/10/30 22:06:00 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gconf/gconf-1.0.7.ebuild,v 1.2 2001/11/07 10:59:21 achim Exp $
P=GConf-${PV}
S=${WORKDIR}/${P}
@@ -18,6 +18,12 @@ DEPEND="${RDEPEND}
nls? ( sys-devel/gettext )
>=dev-util/guile-1.4"
+
+src_unpack() {
+ unpack ${A}
+ patch -p0 < ${FILESDIR}/gconf-${PV}-gentoo.diff
+}
+
src_compile() {
local myconf