summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-08-23 03:18:02 +0000
committerMike Frysinger <vapier@gentoo.org>2005-08-23 03:18:02 +0000
commit9b848d7f635ac436d566e6d09e1110820516cb2e (patch)
tree33293d1c397e7179e1daf54b74015ead372aa02d /games-util
parentstable on ia64 (diff)
downloadhistorical-9b848d7f635ac436d566e6d09e1110820516cb2e.tar.gz
historical-9b848d7f635ac436d566e6d09e1110820516cb2e.tar.bz2
historical-9b848d7f635ac436d566e6d09e1110820516cb2e.zip
Make sure we build even with older linux-headers #103270 by David Mulford.
Package-Manager: portage-2.0.51.22-r2
Diffstat (limited to 'games-util')
-rw-r--r--games-util/joystick/ChangeLog6
-rw-r--r--games-util/joystick/Manifest15
-rw-r--r--games-util/joystick/files/joystick-MCS-defines.patch27
-rw-r--r--games-util/joystick/joystick-20050720.ebuild10
4 files changed, 54 insertions, 4 deletions
diff --git a/games-util/joystick/ChangeLog b/games-util/joystick/ChangeLog
index 4fa22789b5f3..37682c9c6133 100644
--- a/games-util/joystick/ChangeLog
+++ b/games-util/joystick/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-util/joystick
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-util/joystick/ChangeLog,v 1.2 2005/07/21 07:53:07 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-util/joystick/ChangeLog,v 1.3 2005/08/23 03:18:02 vapier Exp $
+
+ 23 Aug 2005; Mike Frysinger <vapier@gentoo.org>
+ +files/joystick-MCS-defines.patch, joystick-20050720.ebuild:
+ Make sure we build even with older linux-headers #103270 by David Mulford.
21 Jul 2005; David Holm <dholm@gentoo.org> joystick-20050720.ebuild:
Added to ~ppc.
diff --git a/games-util/joystick/Manifest b/games-util/joystick/Manifest
index 185651a105e2..a67723be17d7 100644
--- a/games-util/joystick/Manifest
+++ b/games-util/joystick/Manifest
@@ -1,4 +1,15 @@
-MD5 87a7a68ac83bc46f771574846d76b663 ChangeLog 428
-MD5 a271d6f4beaefdfc237885a836c13116 joystick-20050720.ebuild 654
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 81906644bf9cbed72bd3a4b7c0fb896e joystick-20050720.ebuild 762
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
+MD5 726ec0f4239c175e4e5068a8aeced3e4 ChangeLog 620
MD5 329c2c6c17d30f706c38fb2d53108816 files/digest-joystick-20050720 69
+MD5 4fa67a6834ab2028a7d57b149b14769e files/joystick-MCS-defines.patch 575
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.2 (GNU/Linux)
+
+iD8DBQFDCpWbgIKl8Uu19MoRAiEyAJ0YO1urzmq3e9y4O58CaFxUujQSKACePKEZ
+ee7gD/5f2o/xKWGGutyBIXU=
+=AmM7
+-----END PGP SIGNATURE-----
diff --git a/games-util/joystick/files/joystick-MCS-defines.patch b/games-util/joystick/files/joystick-MCS-defines.patch
new file mode 100644
index 000000000000..9fa8aad16880
--- /dev/null
+++ b/games-util/joystick/files/joystick-MCS-defines.patch
@@ -0,0 +1,27 @@
+http://bugs.gentoo.org/103270
+
+--- evtest.c
++++ evtest.c
+@@ -254,6 +254,22 @@
+ [ABS_VOLUME] = "Volume", [ABS_MISC] = "Misc",
+ };
+
++/* many of these MSC defines are only in newer linux headers */
++#ifndef MSC_SERIAL
++# define MSC_SERIAL
++#endif 0x00
++#ifndef MSC_PULSELED
++# define MSC_PULSELED 0x01
++#endif
++#ifndef MSC_GESTURE
++# define MSC_GESTURE 0x02
++#endif
++#ifndef MSC_RAW
++# define MSC_RAW 0x03
++#endif
++#ifndef MSC_SCAN
++# define MSC_SCAN 0x04
++#endif
+ char *misc[MSC_MAX + 1] = {
+ [ 0 ... MSC_MAX] = NULL,
+ [MSC_SERIAL] = "Serial", [MSC_PULSELED] = "Pulseled",
diff --git a/games-util/joystick/joystick-20050720.ebuild b/games-util/joystick/joystick-20050720.ebuild
index 583dc329d8cb..7c4dfeb02754 100644
--- a/games-util/joystick/joystick-20050720.ebuild
+++ b/games-util/joystick/joystick-20050720.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-util/joystick/joystick-20050720.ebuild,v 1.2 2005/07/21 07:53:07 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-util/joystick/joystick-20050720.ebuild,v 1.3 2005/08/23 03:18:02 vapier Exp $
+
+inherit eutils
DESCRIPTION="joystick testing utilities"
HOMEPAGE="http://atrey.karlin.mff.cuni.cz/~vojtech/input/"
@@ -15,6 +17,12 @@ DEPEND="sdl? ( media-libs/libsdl )"
S=${WORKDIR}/utils
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/joystick-MCS-defines.patch
+}
+
src_compile() {
local SDL
use sdl && SDL=1 || SDL=0