summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-11-23 08:00:13 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-11-23 08:00:13 +0000
commita559896231cefd4ea32d1c2e09d267223c03e622 (patch)
tree847f9daeeeba9ec3340b4b560e333cd597d31314 /games-strategy/wesnoth
parentRemoved patch applied upstream. (diff)
downloadhistorical-a559896231cefd4ea32d1c2e09d267223c03e622.tar.gz
historical-a559896231cefd4ea32d1c2e09d267223c03e622.tar.bz2
historical-a559896231cefd4ea32d1c2e09d267223c03e622.zip
version bump
Package-Manager: portage-2.0.51.22-r3
Diffstat (limited to 'games-strategy/wesnoth')
-rw-r--r--games-strategy/wesnoth/ChangeLog8
-rw-r--r--games-strategy/wesnoth/Manifest4
-rw-r--r--games-strategy/wesnoth/files/digest-wesnoth-1.0.21
-rw-r--r--games-strategy/wesnoth/wesnoth-1.0.2.ebuild71
4 files changed, 82 insertions, 2 deletions
diff --git a/games-strategy/wesnoth/ChangeLog b/games-strategy/wesnoth/ChangeLog
index 85c8fdbdad41..2f0c19a47b3d 100644
--- a/games-strategy/wesnoth/ChangeLog
+++ b/games-strategy/wesnoth/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-strategy/wesnoth
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/ChangeLog,v 1.68 2005/11/22 20:09:32 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/ChangeLog,v 1.69 2005/11/23 08:00:13 mr_bones_ Exp $
+
+*wesnoth-1.0.2 (23 Nov 2005)
+
+ 23 Nov 2005; Michael Sterrett <mr_bones_@gentoo.org>
+ +wesnoth-1.0.2.ebuild:
+ version bump
22 Nov 2005; Simon Stelling <blubb@gentoo.org> wesnoth-1.0.1.ebuild:
stable on amd64
diff --git a/games-strategy/wesnoth/Manifest b/games-strategy/wesnoth/Manifest
index 6538ae72ffd1..4ef2370f2eae 100644
--- a/games-strategy/wesnoth/Manifest
+++ b/games-strategy/wesnoth/Manifest
@@ -1,5 +1,7 @@
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
+MD5 6a6519f513023f064f92f48d54971b9c wesnoth-1.0.2.ebuild 1988
MD5 583db22f94cfbcce2bdf462ddf3615aa wesnoth-1.0.1.ebuild 1980
-MD5 9ba243e9b33926b492d2e74dc4b65863 ChangeLog 9109
+MD5 7fe8991a0fb180b32b5cb95555715d3d ChangeLog 9239
+MD5 3831d294741fa1f1cf243836b6c1788d files/digest-wesnoth-1.0.2 67
MD5 6a73a3191925d45024cf48879c799e0e files/digest-wesnoth-1.0.1 67
MD5 2238ca275d6ab646096d612c46b1eb05 files/wesnothd.rc 619
diff --git a/games-strategy/wesnoth/files/digest-wesnoth-1.0.2 b/games-strategy/wesnoth/files/digest-wesnoth-1.0.2
new file mode 100644
index 000000000000..86599777024b
--- /dev/null
+++ b/games-strategy/wesnoth/files/digest-wesnoth-1.0.2
@@ -0,0 +1 @@
+MD5 1d2a26062ce1c90cbf10845023f9435c wesnoth-1.0.2.tar.gz 40034289
diff --git a/games-strategy/wesnoth/wesnoth-1.0.2.ebuild b/games-strategy/wesnoth/wesnoth-1.0.2.ebuild
new file mode 100644
index 000000000000..1955f381e270
--- /dev/null
+++ b/games-strategy/wesnoth/wesnoth-1.0.2.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/wesnoth-1.0.2.ebuild,v 1.1 2005/11/23 08:00:13 mr_bones_ Exp $
+
+inherit eutils toolchain-funcs flag-o-matic games
+
+MY_PV=${PV/_/}
+DESCRIPTION="A fantasy turn-based strategy game"
+HOMEPAGE="http://www.wesnoth.org/"
+SRC_URI="mirror://sourceforge/wesnoth/${PN}-${MY_PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="dedicated editor gnome kde lite nls server tools"
+
+DEPEND=">=media-libs/libsdl-1.2.7
+ !dedicated? (virtual/x11
+ >=media-libs/freetype-2 )
+ >=media-libs/sdl-mixer-1.2
+ >=media-libs/sdl-image-1.2
+ media-libs/sdl-net
+ sys-libs/zlib"
+
+S=${WORKDIR}/${PN}-${MY_PV}
+
+src_unpack() {
+ unpack ${A}
+ if use server ; then
+ sed \
+ -e "s:GAMES_BINDIR:${GAMES_BINDIR}:" \
+ -e "s:GAMES_STATEDIR:${GAMES_STATEDIR}:" \
+ -e "s/GAMES_USER_DED/${GAMES_USER_DED}/" \
+ -e "s/GAMES_GROUP/${GAMES_GROUP}/" "${FILESDIR}"/wesnothd.rc \
+ > "${T}"/wesnothd \
+ || die "sed failed"
+ fi
+
+}
+src_compile() {
+ filter-flags -ftracer -fomit-frame-pointer
+ if [[ $(gcc-major-version) -eq 3 ]] ; then
+ filter-flags -fstack-protector
+ append-flags -fno-stack-protector
+ fi
+ egamesconf \
+ --disable-dependency-tracking \
+ $(use_enable lite) \
+ $(use_enable server) \
+ $(use_enable server campaign-server) \
+ $(use server && echo --with-server-uid=${GAMES_USER_DED} --with-server-gid=${GAMES_GROUP}) \
+ $(use_enable editor) \
+ $(use_enable tools) \
+ $(use_enable nls) \
+ $(use_enable !dedicated game) \
+ $(use_with gnome) \
+ $(use_with kde) \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ mv "${D}${GAMES_DATADIR}/"{icons,applnk,applications} "${D}/usr/share/"
+ dodoc MANUAL changelog
+ if use server; then
+ keepdir "${GAMES_STATEDIR}/run/wesnothd"
+ doinitd "${T}"/wesnothd || die "doinitd failed"
+ fi
+ prepgamesdirs
+}