summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2008-04-28 21:44:09 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2008-04-28 21:44:09 +0000
commit449b4e805ff283f3fef9d431c3804b3badbc1f30 (patch)
tree6d4598c12006662531bddcaa9f7d236fa0080124 /games-strategy/glob2/glob2-0.9.3.ebuild
parentDelete old versions. (diff)
downloadhistorical-449b4e805ff283f3fef9d431c3804b3badbc1f30.tar.gz
historical-449b4e805ff283f3fef9d431c3804b3badbc1f30.tar.bz2
historical-449b4e805ff283f3fef9d431c3804b3badbc1f30.zip
version bump
Package-Manager: portage-2.1.4.4
Diffstat (limited to 'games-strategy/glob2/glob2-0.9.3.ebuild')
-rw-r--r--games-strategy/glob2/glob2-0.9.3.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/games-strategy/glob2/glob2-0.9.3.ebuild b/games-strategy/glob2/glob2-0.9.3.ebuild
new file mode 100644
index 000000000000..020e7fd8a388
--- /dev/null
+++ b/games-strategy/glob2/glob2-0.9.3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/glob2/glob2-0.9.3.ebuild,v 1.1 2008/04/28 21:44:09 mr_bones_ Exp $
+
+inherit eutils games
+
+DESCRIPTION="Real Time Strategy (RTS) game involving a brave army of globs"
+HOMEPAGE="http://globulation2.org/"
+SRC_URI="http://dl.sv.nongnu.org/releases/glob2/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="virtual/opengl
+ virtual/glu
+ >=dev-libs/boost-1.34
+ media-libs/libsdl
+ media-libs/sdl-net
+ media-libs/sdl-ttf
+ media-libs/sdl-image
+ media-libs/libvorbis
+ media-libs/speex"
+DEPEND="${RDEPEND}
+ >=dev-util/scons-0.97"
+
+src_compile() {
+ scons \
+ CXXFLAGS="${CXXFLAGS}" \
+ LINKFLAGS="${LDFLAGS}" \
+ INSTALLDIR="${GAMES_DATADIR}"/${PN} \
+ || die "scons failed again"
+}
+
+src_install() {
+ dogamesbin src/${PN} || die "dogamesbin failed"
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r campaigns data maps scripts || die "doins failed"
+ find "${D}/${GAMES_DATADIR}"/${PN} -name SConscript -exec rm -f {} \;
+ newicon data/icons/glob2-icon-48x48.png ${PN}.png
+ make_desktop_entry glob2 "Globulation 2"
+ dodoc AUTHORS README*
+ prepgamesdirs
+}