summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-09-11 12:26:35 +0000
committerMike Frysinger <vapier@gentoo.org>2003-09-11 12:26:35 +0000
commitc9e5781499d5c516b39e7a45b475f01e04f46e97 (patch)
treecdffe15a600d2482841c484f1460fc53564b90d7 /games-sports/soccar/soccar-0.5.2.ebuild
parentsimulation games (diff)
downloadhistorical-c9e5781499d5c516b39e7a45b475f01e04f46e97.tar.gz
historical-c9e5781499d5c516b39e7a45b475f01e04f46e97.tar.bz2
historical-c9e5781499d5c516b39e7a45b475f01e04f46e97.zip
sports games !
Diffstat (limited to 'games-sports/soccar/soccar-0.5.2.ebuild')
-rw-r--r--games-sports/soccar/soccar-0.5.2.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/games-sports/soccar/soccar-0.5.2.ebuild b/games-sports/soccar/soccar-0.5.2.ebuild
new file mode 100644
index 000000000000..d341e83685be
--- /dev/null
+++ b/games-sports/soccar/soccar-0.5.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-sports/soccar/soccar-0.5.2.ebuild,v 1.1 2003/09/11 12:26:35 vapier Exp $
+
+inherit games eutils
+
+DESCRIPTION="Soccer with Cars"
+HOMEPAGE="http://soccar.sourceforge.net/"
+SRC_URI="mirror://sourceforge/soccar/${P}-src.tar.bz2
+ mirror://sourceforge/soccar/${P}-data.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="dev-util/jam
+ dev-games/ogre
+ dev-games/ode
+ net-libs/enet"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PV}-cfg-reloc.patch
+ sed -i "s:GENTOO_CFGDIR:${GAMES_SYSCONFDIR}/${PN}:" src/{app,config}.cpp
+ sed -i "s:-g -O2:${CXXFLAGS} `pkg-config OGRE --cflags`:" src/Jamfile
+ sed -i 's:/local/:/:' plugins.cfg
+}
+
+src_compile() {
+ jam || die
+}
+
+src_install() {
+ insinto ${GAMES_SYSCONFDIR}/${PN}
+ echo "FileSystem=${GAMES_DATADIR}/${PN}/" > resources.cfg
+ doins resources.cfg plugins.cfg
+ insinto ${GAMES_DATADIR}/${PN}
+ doins data/*
+ dogamesbin src/soccar
+ prepgamesdirs
+}