summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-08-19 23:21:47 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-08-19 23:21:47 +0000
commitb84fbce1a6434212c60fee02087363271b117d52 (patch)
treee8ac0673fa2dca299301a2248c55f79bae9897b2 /games-simulation/cannonsmash
parentAdded to ~ppc (diff)
downloadhistorical-b84fbce1a6434212c60fee02087363271b117d52.tar.gz
historical-b84fbce1a6434212c60fee02087363271b117d52.tar.bz2
historical-b84fbce1a6434212c60fee02087363271b117d52.zip
Fix datadir issue (bug #60933)
Diffstat (limited to 'games-simulation/cannonsmash')
-rw-r--r--games-simulation/cannonsmash/ChangeLog6
-rw-r--r--games-simulation/cannonsmash/Manifest4
-rw-r--r--games-simulation/cannonsmash/cannonsmash-0.6.6.ebuild18
3 files changed, 16 insertions, 12 deletions
diff --git a/games-simulation/cannonsmash/ChangeLog b/games-simulation/cannonsmash/ChangeLog
index 00bc26a9fbc7..a75c6f67b74b 100644
--- a/games-simulation/cannonsmash/ChangeLog
+++ b/games-simulation/cannonsmash/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-simulation/cannonsmash
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/cannonsmash/ChangeLog,v 1.7 2004/07/01 11:23:39 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/cannonsmash/ChangeLog,v 1.8 2004/08/19 23:21:47 mr_bones_ Exp $
+
+ 19 Aug 2004; Michael Sterrett <mr_bones_@gentoo.org>
+ cannonsmash-0.6.6.ebuild:
+ Fix datadir issue (bug #60933)
01 Jul 2004; Jeremy Huddleston <eradicator@gentoo.org>
cannonsmash-0.6.5.ebuild, cannonsmash-0.6.6.ebuild:
diff --git a/games-simulation/cannonsmash/Manifest b/games-simulation/cannonsmash/Manifest
index f92907f628c2..e514da37965e 100644
--- a/games-simulation/cannonsmash/Manifest
+++ b/games-simulation/cannonsmash/Manifest
@@ -1,7 +1,7 @@
-MD5 fc052bf7623ae5f3ca9f34298bbda6c1 ChangeLog 1485
+MD5 d920dfd9e15c7a3d0ff0a3021bca58b7 ChangeLog 1601
MD5 4b819a835be0a8ef63c9b89f18e20221 cannonsmash-0.6.5.ebuild 1337
-MD5 712b437fa3cae062876b334356c68824 cannonsmash-0.6.6.ebuild 1377
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
+MD5 c401891defca0cbfacaec7bbc53e71af cannonsmash-0.6.6.ebuild 1404
MD5 2ca70e3856451ca1226bb3461a653895 files/0.6.5-loadparts.patch 348
MD5 fbc7d2161999a96e4c8cd035592ba8d5 files/digest-cannonsmash-0.6.5 134
MD5 e82483f8829d68c4582a2b5ea52ba427 files/digest-cannonsmash-0.6.6 134
diff --git a/games-simulation/cannonsmash/cannonsmash-0.6.6.ebuild b/games-simulation/cannonsmash/cannonsmash-0.6.6.ebuild
index 7b879de643bd..86f732d9977c 100644
--- a/games-simulation/cannonsmash/cannonsmash-0.6.6.ebuild
+++ b/games-simulation/cannonsmash/cannonsmash-0.6.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/cannonsmash/cannonsmash-0.6.6.ebuild,v 1.4 2004/07/01 11:23:39 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/cannonsmash/cannonsmash-0.6.6.ebuild,v 1.5 2004/08/19 23:21:47 mr_bones_ Exp $
inherit games
@@ -29,27 +29,27 @@ S="${WORKDIR}/csmash-${PV}"
src_unpack() {
unpack csmash-${PV}.tar.gz
- cd ${S}
+ cd "${S}"
if use oggvorbis ; then
- cp ${DISTDIR}/${MY_OGG} ${S}/ || die "cp failed"
+ cp "${DISTDIR}/${MY_OGG}" "${S}/" || die "cp failed"
sed -i \
-e "s:${MY_OGG}:${GAMES_DATADIR}/csmash/${MY_OGG}:" ttinc.h \
- || die "setting ogg loc"
+ || die "setting ogg loc"
fi
}
src_compile() {
egamesconf \
- `use_enable nls` \
+ $(use_enable nls) \
--datadir="${GAMES_DATADIR_BASE}" \
|| die
- emake || die "emake failed"
+ emake \
+ localedir="/usr/share" \
+ || die "emake failed"
}
src_install() {
- egamesinstall \
- datadir="${D}/${GAMES_DATADIR_BASE}" \
- || die
+ make DESTDIR="${D}" install || die "make install failed"
if use oggvorbis ; then
insinto "${GAMES_DATADIR}/csmash"
doins "${MY_OGG}"