summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <tristan@gentoo.org>2006-11-24 15:44:07 +0000
committerTristan Heaven <tristan@gentoo.org>2006-11-24 15:44:07 +0000
commit72a4faad0643abb90d8123d067c4ec2c76339dcc (patch)
treeb7d15b6a01b6937e9fafd01de573f6756c5a027b /games-roguelike
parentMarking sparc stable (diff)
downloadhistorical-72a4faad0643abb90d8123d067c4ec2c76339dcc.tar.gz
historical-72a4faad0643abb90d8123d067c4ec2c76339dcc.tar.bz2
historical-72a4faad0643abb90d8123d067c4ec2c76339dcc.zip
Version bump
Package-Manager: portage-2.1.2_rc2-r1
Diffstat (limited to 'games-roguelike')
-rw-r--r--games-roguelike/tome/ChangeLog10
-rw-r--r--games-roguelike/tome/files/2.3.4-gentoo-paths.patch31
-rw-r--r--games-roguelike/tome/files/digest-tome-2.3.43
-rw-r--r--games-roguelike/tome/files/tome-2.3.4-gcc41.patch18
-rw-r--r--games-roguelike/tome/tome-2.3.4.ebuild125
5 files changed, 186 insertions, 1 deletions
diff --git a/games-roguelike/tome/ChangeLog b/games-roguelike/tome/ChangeLog
index 6f00d111cee9..de41a489a93f 100644
--- a/games-roguelike/tome/ChangeLog
+++ b/games-roguelike/tome/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for games-roguelike/tome
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-roguelike/tome/ChangeLog,v 1.24 2006/10/08 20:54:22 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/tome/ChangeLog,v 1.25 2006/11/24 15:44:07 nyhm Exp $
+
+*tome-2.3.4 (24 Nov 2006)
+
+ 24 Nov 2006; Tristan Heaven <nyhm@gentoo.org>
+ -files/2.3.0-gentoo-paths.patch, +files/tome-2.3.4-gcc41.patch,
+ -files/2.2.7-gentoo-paths.patch, +files/2.3.4-gentoo-paths.patch,
+ -tome-2.2.7-r1.ebuild, -tome-2.3.0.ebuild, +tome-2.3.4.ebuild:
+ Version bump
08 Oct 2006; <tupone@gentoo.org> +files/tome-2.3.3-gcc41.patch,
tome-2.3.3.ebuild:
diff --git a/games-roguelike/tome/files/2.3.4-gentoo-paths.patch b/games-roguelike/tome/files/2.3.4-gentoo-paths.patch
new file mode 100644
index 000000000000..d171a1cf540f
--- /dev/null
+++ b/games-roguelike/tome/files/2.3.4-gentoo-paths.patch
@@ -0,0 +1,31 @@
+diff -rU 1 tome-225-src.orig/src/files.c tome-225-src/src/files.c
+--- tome-225-src.orig/src/files.c 2004-01-14 11:17:02.423263360 -0500
++++ tome-225-src/src/files.c 2004-01-14 11:17:50.074019344 -0500
+@@ -5670,3 +5670,3 @@
+ /* Build the filename */
+- path_build(buf, 1024, ANGBAND_DIR_APEX, "scores.raw");
++ sprintf(buf, "GENTOO_DIR/tome-scores.raw");
+
+@@ -5748,3 +5748,3 @@
+ /* Build the filename */
+- path_build(buf, 1024, ANGBAND_DIR_APEX, "scores.raw");
++ sprintf(buf, "GENTOO_DIR/tome-scores.raw");
+
+@@ -5846,3 +5846,3 @@
+ /* Build the filename */
+- path_build(buf, 1024, ANGBAND_DIR_APEX, "scores.raw");
++ sprintf(buf, "GENTOO_DIR/tome-scores.raw");
+
+@@ -6296,3 +6296,3 @@
+ /* Build the filename */
+- path_build(buf, 1024, ANGBAND_DIR_APEX, "scores.raw");
++ sprintf(buf, "GENTOO_DIR/tome-scores.raw");
+
+diff -rU 1 tome-225-src.orig/src/init2.c tome-225-src/src/init2.c
+--- tome-225-src.orig/src/init2.c 2004-01-14 11:17:02.473255760 -0500
++++ tome-225-src/src/init2.c 2004-01-14 11:17:58.286770816 -0500
+@@ -6686,3 +6686,3 @@
+ /* Build the filename */
+- path_build(buf, 1024, ANGBAND_DIR_APEX, "scores.raw");
++ sprintf(buf, "GENTOO_DIR/tome-scores.raw");
+
diff --git a/games-roguelike/tome/files/digest-tome-2.3.4 b/games-roguelike/tome/files/digest-tome-2.3.4
new file mode 100644
index 000000000000..2c6bf666ed6f
--- /dev/null
+++ b/games-roguelike/tome/files/digest-tome-2.3.4
@@ -0,0 +1,3 @@
+MD5 a97dc78e8964987adc6c0a796b560a14 tome-234-src.tar.bz2 2909120
+RMD160 c932786beda9aa7f7bc5d371a8f6fe18089ec94c tome-234-src.tar.bz2 2909120
+SHA256 ed119f4dfbb0ba984092cd6fddf5dcb5dc2c12a66d57be791182b8274c4f463b tome-234-src.tar.bz2 2909120
diff --git a/games-roguelike/tome/files/tome-2.3.4-gcc41.patch b/games-roguelike/tome/files/tome-2.3.4-gcc41.patch
new file mode 100644
index 000000000000..89ef0bb2e07d
--- /dev/null
+++ b/games-roguelike/tome/files/tome-2.3.4-gcc41.patch
@@ -0,0 +1,18 @@
+--- src/main-gtk.c.old 2006-10-08 22:36:50.000000000 +0200
++++ src/main-gtk.c 2006-10-08 22:37:24.000000000 +0200
+@@ -4478,13 +4478,13 @@
+ strnfmt(buf, 64, "/Terms/%s", angband_term_name[i]);
+
+ /* XXX XXX Store it in the menu definition */
+- (cptr)term_entry[i].path = string_make(buf);
++ term_entry[i].path = string_make(buf);
+
+ /* XXX XXX Build the real path name to the entry */
+ strnfmt(buf, 64, "/Options/Font/%s", angband_term_name[i]);
+
+ /* XXX XXX Store it in the menu definition */
+- (cptr)font_entry[i].path = string_make(buf);
++ font_entry[i].path = string_make(buf);
+ }
+ }
+
diff --git a/games-roguelike/tome/tome-2.3.4.ebuild b/games-roguelike/tome/tome-2.3.4.ebuild
new file mode 100644
index 000000000000..ca23e282cfb5
--- /dev/null
+++ b/games-roguelike/tome/tome-2.3.4.ebuild
@@ -0,0 +1,125 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/tome/tome-2.3.4.ebuild,v 1.1 2006/11/24 15:44:07 nyhm Exp $
+
+inherit eutils flag-o-matic games
+
+MY_PV=${PV//./}
+DESCRIPTION="save the world from Morgoth and battle evil (or become evil ;])"
+HOMEPAGE="http://t-o-m-e.net/"
+SRC_URI="http://t-o-m-e.net/dl/src/tome-${MY_PV}-src.tar.bz2"
+
+LICENSE="Moria"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc-macos ~x86"
+IUSE="X Xaw3d gtk sdl"
+
+RDEPEND=">=sys-libs/ncurses-5
+ X? ( x11-libs/libX11 )
+ Xaw3d? ( x11-libs/libXaw )
+ sdl? (
+ media-libs/sdl-ttf
+ media-libs/sdl-image
+ media-libs/libsdl
+ )
+ gtk? ( !amd64? ( =x11-libs/gtk+-1.2* ) )"
+DEPEND="${REDEPEND}
+ x11-misc/makedepend"
+
+S=${WORKDIR}/tome-${MY_PV}-src
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gcc41.patch
+ cd "src"
+ mv makefile.std makefile
+ epatch "${FILESDIR}/${PV}-gentoo-paths.patch"
+ sed -i \
+ -e "s:GENTOO_DIR:${GAMES_STATEDIR}:" files.c init2.c \
+ || die "sed failed"
+
+ find "${S}" -name .cvsignore -exec rm -f \{\} \;
+ find "${S}/lib/edit" -type f -exec chmod a-x \{\} \;
+}
+
+src_compile() {
+ local GENTOO_INCLUDES="" GENTOO_DEFINES="-DUSE_GCU " GENTOO_LIBS="-lncurses"
+ if use sdl || use X || use gtk || use Xaw3d; then
+ GENTOO_DEFINES="${GENTOO_DEFINES} -DUSE_EGO_GRAPHICS -DUSE_TRANSPARENCY \
+ -DSUPPORT_GAMMA"
+ fi
+ if use sdl || use X || use Xaw3d; then
+ GENTOO_DEFINES="${GENTOO_DEFINES} -DUSE_PRECISE_CMOVIE -DUSE_UNIXSOCK "
+ fi
+ if use sdl; then
+ GENTOO_INCLUDES="${GENTOO_INCLUDES} $(sdl-config --cflags)"
+ GENTOO_DEFINES="${GENTOO_DEFINES} -DUSE_SDL "
+ GENTOO_LIBS="${GENTOO_LIBS} $(sdl-config --libs) -lSDL_image -lSDL_ttf"
+ fi
+ if use X; then
+ GENTOO_INCLUDES="${GENTOO_INCLUDES} -I/usr/X11R6/include "
+ GENTOO_DEFINES="${GENTOO_DEFINES} -DUSE_X11 "
+ GENTOO_LIBS="${GENTOO_LIBS} -L/usr/X11R6/lib -lX11 "
+ fi
+ if use Xaw3d; then
+ GENTOO_INCLUDES="${GENTOO_INCLUDES} -I/usr/X11R6/include "
+ GENTOO_DEFINES="${GENTOO_DEFINES} -DUSE_XAW "
+ GENTOO_LIBS="${GENTOO_LIBS} -L/usr/X11R6/lib -lXaw -lXmu -lXt -lX11 "
+ fi
+ if use gtk; then
+ if use amd64; then
+ einfo "gtk support will not be built for amd64"
+ else
+ GENTOO_INCLUDES="${GENTOO_INCLUDES} $(gtk-config --cflags)"
+ GENTOO_DEFINES="${GENTOO_DEFINES} -DUSE_GTK "
+ GENTOO_LIBS="${GENTOO_LIBS} $(gtk-config --libs) "
+ fi
+ fi
+ GENTOO_INCLUDES="${GENTOO_INCLUDES} -Ilua -I."
+ GENTOO_DEFINES="${GENTOO_DEFINES} -DUSE_LUA"
+ append-ldflags $(bindnow-flags)
+ cd src
+ make \
+ INCLUDES="${GENTOO_INCLUDES}" \
+ DEFINES="${GENTOO_DEFINES}" \
+ depend || die "make depend failed"
+ emake ./tolua || die "emake ./tolua failed"
+ emake \
+ COPTS="${CFLAGS}" \
+ INCLUDES="${GENTOO_INCLUDES}" \
+ DEFINES="${GENTOO_DEFINES}" \
+ LIBS="${GENTOO_LIBS}" \
+ BINDIR="${GAMES_BINDIR}" \
+ LIBDIR="${GAMES_DATADIR}/${PN}" \
+ || die "emake failed"
+}
+
+src_install() {
+ cd src
+ make \
+ DESTDIR="${D}" \
+ OWNER="${GAMES_USER}" \
+ BINDIR="${GAMES_BINDIR}" \
+ LIBDIR="${GAMES_DATADIR}/${PN}" install \
+ || die "make install failed"
+ cd "${S}"
+ dodoc *.txt
+
+ dodir "${GAMES_STATEDIR}"
+ touch "${D}/${GAMES_STATEDIR}/${PN}-scores.raw"
+ prepgamesdirs
+ fperms g+w "${GAMES_STATEDIR}/${PN}-scores.raw"
+ #FIXME: something has to be done about this.
+ fperms g+w "${GAMES_DATADIR}/${PN}/data"
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ echo
+ ewarn "ToME ${PV} is not save-game compatible with 2.3.0 and previous versions."
+ echo
+ ewarn "If you have older save files and you wish to continue those games,"
+ ewarn "you'll need to remerge the version of ToME with which you started"
+ ewarn "those save-games."
+}