summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-08-19 01:16:17 +0000
committerMike Frysinger <vapier@gentoo.org>2005-08-19 01:16:17 +0000
commit45f9640fdd8458cdc6a67afb5ac64f59bbd570bc (patch)
tree456115230563354d82d2ee4a150de6a1c11b7262 /games-puzzle
parentFixed multilib-strict issue, bug 102562. (diff)
downloadhistorical-45f9640fdd8458cdc6a67afb5ac64f59bbd570bc.tar.gz
historical-45f9640fdd8458cdc6a67afb5ac64f59bbd570bc.tar.bz2
historical-45f9640fdd8458cdc6a67afb5ac64f59bbd570bc.zip
Initial import. Ebuild submitted by Dick Marinus #88492.
Package-Manager: portage-2.0.51.22-r2
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/tod/ChangeLog8
-rw-r--r--games-puzzle/tod/Manifest15
-rw-r--r--games-puzzle/tod/files/digest-tod-01
-rw-r--r--games-puzzle/tod/files/tod-0-makefile.patch13
-rw-r--r--games-puzzle/tod/metadata.xml5
-rw-r--r--games-puzzle/tod/tod-0.ebuild38
6 files changed, 80 insertions, 0 deletions
diff --git a/games-puzzle/tod/ChangeLog b/games-puzzle/tod/ChangeLog
new file mode 100644
index 000000000000..53db18fb3fec
--- /dev/null
+++ b/games-puzzle/tod/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for games-puzzle/tod
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/tod/ChangeLog,v 1.1 2005/08/19 01:16:17 vapier Exp $
+
+*tod-0 (18 Aug 2005)
+
+ 18 Aug 2005; Mike Frysinger <vapier@gentoo.org> :
+ Initial import. Ebuild submitted by Dick Marinus #88492.
diff --git a/games-puzzle/tod/Manifest b/games-puzzle/tod/Manifest
new file mode 100644
index 000000000000..a57dff56ec17
--- /dev/null
+++ b/games-puzzle/tod/Manifest
@@ -0,0 +1,15 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
+MD5 b0662b8b52fec11f76ffd1b664252e4a ChangeLog 339
+MD5 ad7c048c88e15d12e64a394a63d04db2 tod-0.ebuild 881
+MD5 aaabc4fed4897548287b0533ee9239e2 files/digest-tod-0 55
+MD5 83bc1cae0ee9d4d09b38cb2a013726d3 files/tod-0-makefile.patch 332
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.2 (GNU/Linux)
+
+iD8DBQFDBTL8gIKl8Uu19MoRApD+AJ9Z1/dhzbmb2/DtywJ/EWQGEkgFzACffgTm
+gA0NMlJ7wy5UPILHokGoQOo=
+=5hjt
+-----END PGP SIGNATURE-----
diff --git a/games-puzzle/tod/files/digest-tod-0 b/games-puzzle/tod/files/digest-tod-0
new file mode 100644
index 000000000000..bfc02c539dd2
--- /dev/null
+++ b/games-puzzle/tod/files/digest-tod-0
@@ -0,0 +1 @@
+MD5 228c9076cd6b350368f776644fe099e3 wintod.zip 115653
diff --git a/games-puzzle/tod/files/tod-0-makefile.patch b/games-puzzle/tod/files/tod-0-makefile.patch
new file mode 100644
index 000000000000..cd17d1cce42b
--- /dev/null
+++ b/games-puzzle/tod/files/tod-0-makefile.patch
@@ -0,0 +1,13 @@
+--- makefile
++++ makefile
+@@ -1,8 +1,7 @@
+ OBJ = hiscore rec scrctl tetanus crc allegdlg hgrcos
+ HEADS = tod.h allegdlg.h crc.h hgrcos.h hiscore.h
+-LIBS = -lalleg
+-CFLAGS = -Wall -march=i486 -mcpu=i686 -O3 -ffast-math
+-LDFLAGS = -mwindows
++LIBS = `allegro-config --libs`
++CFLAGS += `allegro-config --cflags`
+ CC = gcc
+
+
diff --git a/games-puzzle/tod/metadata.xml b/games-puzzle/tod/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-puzzle/tod/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-puzzle/tod/tod-0.ebuild b/games-puzzle/tod/tod-0.ebuild
new file mode 100644
index 000000000000..ebef393b625a
--- /dev/null
+++ b/games-puzzle/tod/tod-0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/tod/tod-0.ebuild,v 1.1 2005/08/19 01:16:17 vapier Exp $
+
+inherit games
+
+DESCRIPTION="Tetanus On Drugs simulates playing a Tetris clone under the influence of hallucinogenic drugs"
+HOMEPAGE="http://www.pineight.com/tod/"
+SRC_URI="http://www.pineight.com/pc/win${PN}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 x86"
+IUSE=""
+
+DEPEND="media-libs/allegro"
+
+S=${WORKDIR}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-makefile.patch
+ sed -i \
+ -e "s:idltd\.dat:${GAMES_DATADIR}/${PN}/idltd.dat:" \
+ rec.c || die
+}
+
+src_compile() {
+ emake -f makefile || die "make failed"
+}
+
+src_install() {
+ newgamesbin tod-debug.exe tod || die
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins idltd.dat || die
+ dodoc readme.txt
+}