summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-11-30 21:45:03 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-11-30 21:45:03 +0000
commit66beba812c49cd618b8bdfad2f9595ab6f4e394d (patch)
tree6839b425e1cf0baee286237ccb89ba4e558ec40a /games-puzzle/xbomb/xbomb-2.2a.ebuild
parentold (diff)
downloadhistorical-66beba812c49cd618b8bdfad2f9595ab6f4e394d.tar.gz
historical-66beba812c49cd618b8bdfad2f9595ab6f4e394d.tar.bz2
historical-66beba812c49cd618b8bdfad2f9595ab6f4e394d.zip
version bump
Package-Manager: portage-2.1.6.13/cvs/Linux i686
Diffstat (limited to 'games-puzzle/xbomb/xbomb-2.2a.ebuild')
-rw-r--r--games-puzzle/xbomb/xbomb-2.2a.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/games-puzzle/xbomb/xbomb-2.2a.ebuild b/games-puzzle/xbomb/xbomb-2.2a.ebuild
new file mode 100644
index 000000000000..7e275d8c02ce
--- /dev/null
+++ b/games-puzzle/xbomb/xbomb-2.2a.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/xbomb/xbomb-2.2a.ebuild,v 1.1 2009/11/30 21:45:03 mr_bones_ Exp $
+
+EAPI=2
+inherit eutils games
+
+DESCRIPTION="Minesweeper clone with hexagonal, rectangular and triangular grid"
+HOMEPAGE="http://www.gedanken.demon.co.uk/xbomb/"
+SRC_URI="http://www.gedanken.demon.co.uk/download-xbomb/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="x11-libs/libXaw"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-DESTDIR.patch
+ sed -i \
+ -e '/strip/d' \
+ -e "/^CFLAGS/ { s:=.*:=${CFLAGS}: }" \
+ -e "s:/usr/bin:${GAMES_BINDIR}:" \
+ Makefile \
+ || die "sed Makefile failed"
+ sed -i \
+ -e "s:/var/tmp:${GAMES_STATEDIR}/${PN}:g" \
+ hiscore.c \
+ || die "sed hiscore.c failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc README LSM
+ dodir "${GAMES_STATEDIR}"/${PN}
+ touch "${D}/${GAMES_STATEDIR}"/${PN}/${PN}{3,4,6}.hi || die "touch failed"
+ fperms 660 "${GAMES_STATEDIR}"/${PN}/${PN}{3,4,6}.hi || die "fperms failed"
+ prepgamesdirs
+}