summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-08-10 21:23:49 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-08-10 21:23:49 +0000
commitfb2b989c017e24e615f29429a3dfc51e9b9a05cf (patch)
tree4302710729fa5f23a37890eff42106d11cddc5a2 /games-puzzle/torrent
parentMove from dev-perl to perl-core (diff)
downloadhistorical-fb2b989c017e24e615f29429a3dfc51e9b9a05cf.tar.gz
historical-fb2b989c017e24e615f29429a3dfc51e9b9a05cf.tar.bz2
historical-fb2b989c017e24e615f29429a3dfc51e9b9a05cf.zip
EAPI=2; build with gcc43
Package-Manager: portage-2.1.6.13/cvs/Linux i686
Diffstat (limited to 'games-puzzle/torrent')
-rw-r--r--games-puzzle/torrent/ChangeLog7
-rw-r--r--games-puzzle/torrent/Manifest4
-rw-r--r--games-puzzle/torrent/torrent-0.8.2.ebuild12
3 files changed, 17 insertions, 6 deletions
diff --git a/games-puzzle/torrent/ChangeLog b/games-puzzle/torrent/ChangeLog
index 9ec428302324..5e0d05399009 100644
--- a/games-puzzle/torrent/ChangeLog
+++ b/games-puzzle/torrent/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-puzzle/torrent
-# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/torrent/ChangeLog,v 1.7 2006/08/15 15:06:23 tcort Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/torrent/ChangeLog,v 1.8 2009/08/10 21:23:49 mr_bones_ Exp $
+
+ 10 Aug 2009; Michael Sterrett <mr_bones_@gentoo.org> torrent-0.8.2.ebuild:
+ EAPI=2; build with gcc43
15 Aug 2006; Thomas Cort <tcort@gentoo.org> torrent-0.8.2.ebuild:
Stable on amd64 wrt Bug #143961
diff --git a/games-puzzle/torrent/Manifest b/games-puzzle/torrent/Manifest
index 472372e63bcd..4fa7ed699b2b 100644
--- a/games-puzzle/torrent/Manifest
+++ b/games-puzzle/torrent/Manifest
@@ -1,4 +1,4 @@
DIST torrent-0.8.2.tar.gz 555686 RMD160 97875f42e4f1d1633500ca1a412d05f2b7a0142f SHA1 9cd8c6629f38344674c34f67091f3ded5152b287 SHA256 93890ed9287061f6b8d63993962c188013388fe7cf4d3d334ca7e72cc3209a67
-EBUILD torrent-0.8.2.ebuild 747 RMD160 af3345c1d88cbb984598bb5407fee69388020c0e SHA1 7d01016702a3faf4b19abec9db74245463ab46ad SHA256 d4a008b1011a39bc64f22236efccaffd232bfcef01b9c8a8f43c4f1a62689140
-MISC ChangeLog 875 RMD160 77e15781b1827b4c8941d7371f6c150589c8e574 SHA1 a8d2feba9bb9da7aaf6b2ce490410c43691387df SHA256 af77e1eea52a799fb33ff1117c8f459c2414c13e7587f4d67830bdc963a0c8bf
+EBUILD torrent-0.8.2.ebuild 886 RMD160 33b9178ad870ea6fd1fa42b3e05e3944ab7cd70b SHA1 07150c603332900e8ed414d6b781d1128ae3abdb SHA256 86ec810bd2441d0a9eeeef77274fd5cfbda309f498fb640ab11eff9c0262bf3b
+MISC ChangeLog 984 RMD160 9a360452e97b649a123cc3c1054cc9f5644d36e6 SHA1 4d684cdc4c22e2ce36740e1b0b5a3a9b1a47a617 SHA256 1483ab089cd2b6d3383419b914f830ca08bfb11f1bfe209be46b3e0267f797e2
MISC metadata.xml 158 RMD160 cbd9984bb6b426c8c9cee5022fe0a26261612fea SHA1 be5251fa1dacef5c41b74761bb1c8c54fb633b9e SHA256 1423a4fdd4a79b1728a2056d9e300f7e1074253095d82726218d9e9b953888a3
diff --git a/games-puzzle/torrent/torrent-0.8.2.ebuild b/games-puzzle/torrent/torrent-0.8.2.ebuild
index fcc78d8cd6bf..0b1de2df34e1 100644
--- a/games-puzzle/torrent/torrent-0.8.2.ebuild
+++ b/games-puzzle/torrent/torrent-0.8.2.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/torrent/torrent-0.8.2.ebuild,v 1.5 2006/08/15 15:06:23 tcort Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/torrent/torrent-0.8.2.ebuild,v 1.6 2009/08/10 21:23:49 mr_bones_ Exp $
+EAPI=2
inherit games
DESCRIPTION="Match rising tiles to score as many points as possible before the tiles touch the top of the board"
@@ -18,6 +19,13 @@ DEPEND=">=media-libs/libsdl-1.2.4
>=media-libs/sdl-image-1.2
media-libs/sdl-ttf"
+src_prepare() {
+ sed -i \
+ -e 's/inline void SE_CheckEvents/void SE_CheckEvents/' \
+ src/torrent.c \
+ || die "sed failed"
+}
+
src_install() {
make DESTDIR="${D}" install || die "make install failed"
dodoc ChangeLog