summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-11-22 06:37:18 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-11-22 06:37:18 +0000
commit363e7aebd338a9c63ce1a34e3543039a6deeb820 (patch)
tree56a5a0ac3db8adc9ce167dea8fce0faf5aa88cd5 /games-kids
parentinitial import (diff)
downloadhistorical-363e7aebd338a9c63ce1a34e3543039a6deeb820.tar.gz
historical-363e7aebd338a9c63ce1a34e3543039a6deeb820.tar.bz2
historical-363e7aebd338a9c63ce1a34e3543039a6deeb820.zip
version bump
Package-Manager: portage-2.0.51.22-r3
Diffstat (limited to 'games-kids')
-rw-r--r--games-kids/gcompris/ChangeLog7
-rw-r--r--games-kids/gcompris/Manifest4
-rw-r--r--games-kids/gcompris/files/digest-gcompris-7.11
-rw-r--r--games-kids/gcompris/gcompris-7.1.ebuild58
4 files changed, 68 insertions, 2 deletions
diff --git a/games-kids/gcompris/ChangeLog b/games-kids/gcompris/ChangeLog
index d2c0303a46c5..2e20fceb88c6 100644
--- a/games-kids/gcompris/ChangeLog
+++ b/games-kids/gcompris/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-kids/gcompris
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-kids/gcompris/ChangeLog,v 1.18 2005/11/21 17:51:22 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-kids/gcompris/ChangeLog,v 1.19 2005/11/22 06:37:18 mr_bones_ Exp $
+
+*gcompris-7.1 (22 Nov 2005)
+
+ 22 Nov 2005; Michael Sterrett <mr_bones_@gentoo.org> +gcompris-7.1.ebuild:
+ version bump
*gcompris-6.5.3-r1 (21 Nov 2005)
diff --git a/games-kids/gcompris/Manifest b/games-kids/gcompris/Manifest
index b604caca6a48..9716e3440a2e 100644
--- a/games-kids/gcompris/Manifest
+++ b/games-kids/gcompris/Manifest
@@ -1,6 +1,8 @@
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
MD5 fe3c32d12e59a1ca0cc3b1f2dc9eb953 gcompris-6.5.3-r1.ebuild 1797
-MD5 9996f11c74a761b827fa2aab50317661 ChangeLog 2867
+MD5 f0737cedf953cc207a2f505c57bb835a gcompris-7.1.ebuild 1423
+MD5 4b7fb6a84e6479f71bb3a70efbb7566b ChangeLog 2989
MD5 0f3e1b204624641e356707b88dce2171 gcompris-6.5.3.ebuild 1784
MD5 557b7f4481b6c30ca79251c8a19af714 files/digest-gcompris-6.5.3 68
MD5 557b7f4481b6c30ca79251c8a19af714 files/digest-gcompris-6.5.3-r1 68
+MD5 b74a9e31115d9b60b21c599ca52e7cd5 files/digest-gcompris-7.1 66
diff --git a/games-kids/gcompris/files/digest-gcompris-7.1 b/games-kids/gcompris/files/digest-gcompris-7.1
new file mode 100644
index 000000000000..29b16c8c29cf
--- /dev/null
+++ b/games-kids/gcompris/files/digest-gcompris-7.1
@@ -0,0 +1 @@
+MD5 8020824fbe7dbaa334611e3d7aee7d7c gcompris-7.1.tar.gz 58790298
diff --git a/games-kids/gcompris/gcompris-7.1.ebuild b/games-kids/gcompris/gcompris-7.1.ebuild
new file mode 100644
index 000000000000..ae25351109e7
--- /dev/null
+++ b/games-kids/gcompris/gcompris-7.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-kids/gcompris/gcompris-7.1.ebuild,v 1.1 2005/11/22 06:37:18 mr_bones_ Exp $
+
+inherit eutils games
+
+DESCRIPTION="full featured educational application for children from 2 to 10"
+HOMEPAGE="http://gcompris.net"
+SRC_URI="mirror://sourceforge/gcompris/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+#IUSE="python " #doesn't like python-2.4
+IUSE=""
+
+RDEPEND="virtual/x11
+ >=dev-libs/glib-2.0
+ =x11-libs/gtk+-2*
+ >=gnome-base/libgnomecanvas-2.0.2
+ media-libs/sdl-mixer
+ media-libs/libsdl
+ dev-libs/libxml2
+ dev-libs/popt
+ sqlite? (
+ =dev-db/sqlite-3*
+ =dev-python/pysqlite-2* )"
+DEPEND="${RDEPEND}
+ sys-apps/texinfo
+ app-text/texi2html"
+RDEPEND="${RDEPEND}
+ games-board/gnuchess"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e '/^install-data-am/s/install-libgcomprisincludeHEADERS//' \
+ src/gcompris/Makefile.in \
+ || die "sed failed"
+}
+
+src_compile() {
+ export GNUCHESS="${GAMES_BINDIR}/gnuchess"
+ # $(use_with python python /usr/bin/python) - doesn't seem to work with 2.4
+ econf \
+ --disable-dependency-tracking \
+ --without-python \
+ $(use_enable sqlite) \
+ || die
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO
+ prepgamesdirs
+}