summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-03-22 05:24:26 +0000
committerMike Frysinger <vapier@gentoo.org>2005-03-22 05:24:26 +0000
commita295cdd1ae176dc57689e85001d7e9520b436401 (patch)
tree860190fabab058baf8b2cbdb8e2a3a31c158b161 /games-emulation
parentremove multilib cruft (diff)
downloadhistorical-a295cdd1ae176dc57689e85001d7e9520b436401.tar.gz
historical-a295cdd1ae176dc57689e85001d7e9520b436401.tar.bz2
historical-a295cdd1ae176dc57689e85001d7e9520b436401.zip
remove multilib cruft
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/nestra/Manifest12
-rw-r--r--games-emulation/nestra/nestra-0.66-r1.ebuild31
2 files changed, 13 insertions, 30 deletions
diff --git a/games-emulation/nestra/Manifest b/games-emulation/nestra/Manifest
index d88d5aeea817..7bc9289aa765 100644
--- a/games-emulation/nestra/Manifest
+++ b/games-emulation/nestra/Manifest
@@ -1,14 +1,4 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
MD5 5dcf1e6d60c31b8b9f909d983cb2bfdc ChangeLog 775
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
-MD5 7c0437c9970e4f82ee4aa228131096bf nestra-0.66-r1.ebuild 1606
+MD5 081b69bfdcda9c2e70fd32eb0c7db4ba nestra-0.66-r1.ebuild 1364
MD5 1b72c901305b3f39e947ffbe00b7a13e files/digest-nestra-0.66-r1 126
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.1 (GNU/Linux)
-
-iD8DBQFCPoFqArHZZzCEUG0RAil+AJ9KITtsLfZ4KT9BeWWDEOI4CntxpwCfQfuM
-Hm9eCWWZ69FR861Rio/L+LY=
-=30kT
------END PGP SIGNATURE-----
diff --git a/games-emulation/nestra/nestra-0.66-r1.ebuild b/games-emulation/nestra/nestra-0.66-r1.ebuild
index e7f4bad00cd9..838bd2518ba2 100644
--- a/games-emulation/nestra/nestra-0.66-r1.ebuild
+++ b/games-emulation/nestra/nestra-0.66-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/nestra/nestra-0.66-r1.ebuild,v 1.4 2005/03/21 08:10:09 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/nestra/nestra-0.66-r1.ebuild,v 1.5 2005/03/22 05:24:26 vapier Exp $
inherit eutils games toolchain-funcs flag-o-matic
@@ -16,29 +16,22 @@ KEYWORDS="~amd64 x86"
IUSE=""
RDEPEND="amd64? ( >=app-emulation/emul-linux-x86-xlibs-1.2-r7 )"
-
DEPEND="${RDEPEND}
virtual/x11"
-S="${WORKDIR}/${PN}"
+S=${WORKDIR}/${PN}
pkg_setup() {
- if use amd64; then
- if has_multilib_profile; then
- ABI_ALLOW="x86"
-
- # And until we get a real multilib portage...
- ABI="x86"
-
- # Yeah, this is ugly, but so's their build system...
- append-flags "-L/emul/linux/x86/usr/lib -L/emul/linux/x86/lib -L/usr/lib32 -L/lib32"
- append-ldflags $(get_abi_LDFLAGS)
- elif has_m32 ; then
- einfo "multilib detected, adding -m32 to CFLAGS."
- append-flags -m32
- else
- die "${PN} requires multilib support in gcc. please re-emerge gcc with multilib in USE and try again"
- fi
+ use amd64 || return 0
+ if has_m32 ; then
+ append-flags -m32
+ append-ldflags -m elf_i386
+ else
+ eerror "Your compiler seems to be unable to compile 32bit code."
+ eerror "Make sure you compile gcc with:"
+ echo
+ eerror " USE=multilib FEATURES=-sandbox"
+ die "Cannot produce 32bit code"
fi
}