summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2003-11-03 23:52:46 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2003-11-03 23:52:46 +0000
commit8c13e2dc23c9776e3667e4c2296cfbe59477e447 (patch)
tree25e0d3e358af596d1e5a2b20b7a1ed15c64989f5 /games-emulation
parentdb3 fix (diff)
downloadhistorical-8c13e2dc23c9776e3667e4c2296cfbe59477e447.tar.gz
historical-8c13e2dc23c9776e3667e4c2296cfbe59477e447.tar.bz2
historical-8c13e2dc23c9776e3667e4c2296cfbe59477e447.zip
replace the arch if/then thing with a case statement; added support for ia64 and amd64 for bug 32628
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/xmame/ChangeLog6
-rw-r--r--games-emulation/xmame/Manifest4
-rw-r--r--games-emulation/xmame/xmame-0.76.1.ebuild25
3 files changed, 20 insertions, 15 deletions
diff --git a/games-emulation/xmame/ChangeLog b/games-emulation/xmame/ChangeLog
index d150c4638111..c3e9eb3ad5ba 100644
--- a/games-emulation/xmame/ChangeLog
+++ b/games-emulation/xmame/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-emulation/xmame
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/xmame/ChangeLog,v 1.6 2003/11/01 07:05:06 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/xmame/ChangeLog,v 1.7 2003/11/03 23:52:43 mr_bones_ Exp $
+
+ 03 Nov 2003; Michael Sterrett <mr_bones_@gentoo.org> xmame-0.76.1.ebuild:
+ replace the arch if/then thing with a case statement; added support for ia64
+ and amd64 for bug 32628
31 Oct 2003; Michael Sterrett <mr_bones_@gentoo.org> xmame-0.76.1.ebuild:
add icc USE support (bug 31769); DEPEND on sed >= 4 for -i; add more error
diff --git a/games-emulation/xmame/Manifest b/games-emulation/xmame/Manifest
index 9fd2dcc77e74..ee43c807d805 100644
--- a/games-emulation/xmame/Manifest
+++ b/games-emulation/xmame/Manifest
@@ -1,6 +1,6 @@
-MD5 4cf67d0a4f523c4bf9cc53224c5c5680 ChangeLog 3971
+MD5 8c73139838a36df7fc1b6947c562f8f8 ChangeLog 4153
MD5 044a7a61c7aa18fa3234a7497c4f3f50 xmame-0.74.1-r1.ebuild 4298
-MD5 f508931140484a6875cf5df09aa90e5e xmame-0.76.1.ebuild 5580
+MD5 cdf504e5e3711f4d8fe1fb3ca9359d4d xmame-0.76.1.ebuild 5418
MD5 0234d9024c471faf92bb1219242614ef metadata.xml 1566
MD5 13dc5b32bbff98dec74c41dd0c9b33a1 files/0.76.1-glx-fix.patch 597
MD5 13dc5b32bbff98dec74c41dd0c9b33a1 files/0.74.1-glx-fix.patch 597
diff --git a/games-emulation/xmame/xmame-0.76.1.ebuild b/games-emulation/xmame/xmame-0.76.1.ebuild
index 96ff4ec87dac..2062a1cc3ae8 100644
--- a/games-emulation/xmame/xmame-0.76.1.ebuild
+++ b/games-emulation/xmame/xmame-0.76.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/xmame/xmame-0.76.1.ebuild,v 1.2 2003/11/01 07:05:06 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/xmame/xmame-0.76.1.ebuild,v 1.3 2003/11/03 23:52:43 mr_bones_ Exp $
inherit games flag-o-matic gcc eutils
@@ -12,7 +12,7 @@ HOMEPAGE="http://x.mame.net/"
LICENSE="xmame"
SLOT="0"
-KEYWORDS="x86 ~ppc ~sparc ~mips ~alpha"
+KEYWORDS="x86 ~ppc ~sparc ~mips ~alpha ~ia64 ~amd64"
IUSE="sdl dga xv alsa esd opengl X 3dfx svga ggi arts joystick icc"
RDEPEND="sys-libs/zlib
@@ -36,7 +36,8 @@ src_unpack() {
cd ${S}
epatch ${FILESDIR}/${PV}-glx-fix.patch
- if [ ${ARCH} == "x86" ] ; then
+ case "${ARCH}" in
+ x86|ia64|amd64)
sed -i \
-e '/X86_ASM_68000 =/s:#::' \
-e '/X86_MIPS3_DRC =/s:#::' Makefile || \
@@ -46,23 +47,23 @@ src_unpack() {
-e '/JOY_I386.*=/s:#::' Makefile || \
die "sed Makefile (joystick) failed"
fi
- elif [ ${ARCH} == "ppc" ] ; then
+ ;;
+ ppc|sparc)
sed -i \
-e '/^MY_CPU/s:i386:risc:' Makefile || \
- die "sed Makefile (ppc) failed"
- elif [ ${ARCH} == "sparc" ] ; then
- sed -i \
- -e '/^MY_CPU/s:i386:risc:' Makefile || \
- die "sed Makefile (sparc) failed"
- elif [ ${ARCH} == "alpha" ] ; then
+ die "sed Makefile (ppc|sparc) failed"
+ ;;
+ alpha)
sed -i \
-e '/^MY_CPU/s:i386:alpha:' Makefile || \
die "sed Makefile (alpha) failed"
- elif [ ${ARCH} == "mips" ] ; then
+ ;;
+ mips)
sed -i \
-e '/^MY_CPU/s:i386:mips:' Makefile || \
die "sed Makefile (mips) failed"
- fi
+ ;;
+ esac
if [ `use icc` ] ; then
sed -i \