summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-05-16 20:34:25 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-05-16 20:34:25 +0000
commitc3ee8fceffba973e7f38d7c5f69239de7c145b8e (patch)
tree31bd1c8487a59b14fc83333db98ac8b0267bcd9f /games-emulation/dosbox/dosbox-0.74.ebuild
parentStable on amd64 wrt bug #302033 (diff)
downloadhistorical-c3ee8fceffba973e7f38d7c5f69239de7c145b8e.tar.gz
historical-c3ee8fceffba973e7f38d7c5f69239de7c145b8e.tar.bz2
historical-c3ee8fceffba973e7f38d7c5f69239de7c145b8e.zip
version bump
Package-Manager: portage-2.1.8.3/cvs/Linux i686
Diffstat (limited to 'games-emulation/dosbox/dosbox-0.74.ebuild')
-rw-r--r--games-emulation/dosbox/dosbox-0.74.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/games-emulation/dosbox/dosbox-0.74.ebuild b/games-emulation/dosbox/dosbox-0.74.ebuild
new file mode 100644
index 000000000000..319783d0d406
--- /dev/null
+++ b/games-emulation/dosbox/dosbox-0.74.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/dosbox/dosbox-0.74.ebuild,v 1.1 2010/05/16 20:34:25 mr_bones_ Exp $
+
+EAPI=2
+inherit autotools eutils games
+
+DESCRIPTION="DOS emulator"
+HOMEPAGE="http://dosbox.sourceforge.net/"
+SRC_URI="mirror://sourceforge/dosbox/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="alsa debug hardened opengl"
+
+DEPEND="alsa? ( media-libs/alsa-lib )
+ opengl? ( virtual/opengl )
+ debug? ( sys-libs/ncurses )
+ media-libs/libpng
+ media-libs/libsdl[joystick,video]
+ media-libs/sdl-net
+ media-libs/sdl-sound"
+
+src_configure() {
+ egamesconf \
+ --disable-dependency-tracking \
+ $(use_enable alsa alsa-midi) \
+ $(use_enable !hardened dynamic-x86) \
+ $(use_enable debug) \
+ $(use_enable opengl)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README THANKS
+ make_desktop_entry dosbox DOSBox /usr/share/pixmaps/dosbox.ico
+ doicon src/dosbox.ico
+ prepgamesdirs
+}