summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-07-03 09:34:47 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-07-03 09:34:47 +0000
commit941e4c7c0470779906cfa9eb0e5523bafdf3d085 (patch)
tree7474cf6b14b449d30d2ba197525cac30e646f6ba /games-board
parentStable on alpha. (diff)
downloadhistorical-941e4c7c0470779906cfa9eb0e5523bafdf3d085.tar.gz
historical-941e4c7c0470779906cfa9eb0e5523bafdf3d085.tar.bz2
historical-941e4c7c0470779906cfa9eb0e5523bafdf3d085.zip
gnuconfig_update for mips; no backticks
Diffstat (limited to 'games-board')
-rw-r--r--games-board/gnubg/ChangeLog5
-rw-r--r--games-board/gnubg/Manifest6
-rw-r--r--games-board/gnubg/gnubg-0.14.2.ebuild31
3 files changed, 25 insertions, 17 deletions
diff --git a/games-board/gnubg/ChangeLog b/games-board/gnubg/ChangeLog
index 672b3313aee3..23183e916208 100644
--- a/games-board/gnubg/ChangeLog
+++ b/games-board/gnubg/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-board/gnubg
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/gnubg/ChangeLog,v 1.8 2004/06/24 22:17:33 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/gnubg/ChangeLog,v 1.9 2004/07/03 09:34:47 mr_bones_ Exp $
+
+ 03 Jul 2004; Michael Sterrett <mr_bones_@gentoo.org> gnubg-0.14.2.ebuild:
+ gnuconfig_update for mips; no backticks
03 Jun 2004; Aron Griffis <agriffis@gentoo.org> gnubg-0.13.0-r1.ebuild:
Fix use invocation
diff --git a/games-board/gnubg/Manifest b/games-board/gnubg/Manifest
index 7878a4231f57..d6615493fcdd 100644
--- a/games-board/gnubg/Manifest
+++ b/games-board/gnubg/Manifest
@@ -1,6 +1,6 @@
-MD5 7bc659276e35c74af2850c203e8e50c4 gnubg-0.13.0-r1.ebuild 2495
-MD5 f4805d178becd86fe9e1cf57bb180337 ChangeLog 1282
+MD5 cd38ebfc11393e537957876dc7c932e7 ChangeLog 1402
MD5 3f11aaf297b2fe67404a96cda13e9bfe metadata.xml 251
-MD5 55afe637573858bf590e0ceae2ebc935 gnubg-0.14.2.ebuild 2553
+MD5 7bc659276e35c74af2850c203e8e50c4 gnubg-0.13.0-r1.ebuild 2495
+MD5 82ddda14ac3715701570a2719b5a6aa5 gnubg-0.14.2.ebuild 2706
MD5 0c7a8ec2862198de493c51ea97e3eed6 files/digest-gnubg-0.14.2 252
MD5 14a8f9e2546292fc22c04fbea97287f7 files/digest-gnubg-0.13.0-r1 188
diff --git a/games-board/gnubg/gnubg-0.14.2.ebuild b/games-board/gnubg/gnubg-0.14.2.ebuild
index e44ba5a1c709..d5559c1bc5e6 100644
--- a/games-board/gnubg/gnubg-0.14.2.ebuild
+++ b/games-board/gnubg/gnubg-0.14.2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/gnubg/gnubg-0.14.2.ebuild,v 1.2 2004/06/24 22:17:33 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/gnubg/gnubg-0.14.2.ebuild,v 1.3 2004/07/03 09:34:47 mr_bones_ Exp $
-inherit games
+inherit gnuconfig games
WPV="0.14"
DESCRIPTION="GNU BackGammon"
@@ -15,10 +15,11 @@ SRC_URI="ftp://alpha.gnu.org/gnu/gnubg/${P}.tar.gz
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86"
-IUSE="gtk gtk2 readline guile X gdbm truetype nls png esd arts nas"
+IUSE="gtk gtk2 readline python guile X gdbm truetype nls png esd arts nas"
# FIXME does this need to DEPEND on netpbm?
RDEPEND="guile? ( dev-util/guile )
+ python? ( dev-lang/python )
truetype? ( =media-libs/freetype-1* )
gtk? (
gtk2? (
@@ -51,10 +52,11 @@ src_unpack() {
-e "s:-laudio:-L/usr/X11R6/lib/ -laudio:" configure.in || \
die "sed configure.in failed"
fi
+ gnuconfig_update
}
src_compile() {
- local myconf=""
+ local myconf=
if use gtk ; then
# doesn't make any sense to add this without gtk or gtk2
if has_version x11-libs/gtk+extra ; then
@@ -78,16 +80,19 @@ src_compile() {
fi
# configure script doesn't handle this option correctly.
- # `use_with guile` \
+ # `use_with guile` \
egamesconf \
- `use_enable esd` \
- `use_enable arts artsc` \
- `use_enable nas` \
- `use_with readline` \
- `use_with X x` \
- `use_with gdbm` \
- `use_with truetype freetype` \
- `use_enable nls` \
+ --disable-dependency-tracking \
+ --with-board3d \
+ $(use_with python) \
+ $(use_enable esd) \
+ $(use_enable arts artsc) \
+ $(use_enable nas) \
+ $(use_with readline) \
+ $(use_with X x) \
+ $(use_with gdbm) \
+ $(use_with truetype freetype) \
+ $(use_enable nls) \
${myconf} \
|| die
emake || die "emake failed"