summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-03-23 19:36:44 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-03-23 19:36:44 +0000
commita8ce4bddaa5bfed12d7fd85b0e424505fd495b29 (patch)
tree12357455b5ebecdf633e60931a2c1eb7f4bd1e0b /games-board/cgoban2/cgoban2-2.6.10.ebuild
parentAdded dependency on haddock. (diff)
downloadhistorical-a8ce4bddaa5bfed12d7fd85b0e424505fd495b29.tar.gz
historical-a8ce4bddaa5bfed12d7fd85b0e424505fd495b29.tar.bz2
historical-a8ce4bddaa5bfed12d7fd85b0e424505fd495b29.zip
version bump
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'games-board/cgoban2/cgoban2-2.6.10.ebuild')
-rw-r--r--games-board/cgoban2/cgoban2-2.6.10.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/games-board/cgoban2/cgoban2-2.6.10.ebuild b/games-board/cgoban2/cgoban2-2.6.10.ebuild
new file mode 100644
index 000000000000..e70bdd31803d
--- /dev/null
+++ b/games-board/cgoban2/cgoban2-2.6.10.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/cgoban2/cgoban2-2.6.10.ebuild,v 1.1 2005/03/23 19:36:44 mr_bones_ Exp $
+
+inherit games
+
+DESCRIPTION="A Java client for the Kiseido Go Server, and a SGF editor"
+HOMEPAGE="http://kgs.kiseido.com/"
+SRC_URI="http://kgs.kiseido.com/cgoban-unix-${PV}.tar.bz2"
+
+LICENSE="freedist"
+SLOT="0"
+KEYWORDS="x86 ~ppc ~amd64"
+IUSE=""
+
+RDEPEND=">=virtual/jre-1.3
+ virtual/x11"
+
+S="${WORKDIR}/cgoban"
+
+src_install() {
+ dodir "${GAMES_BINDIR}"
+ sed -e "s:INSTALL_DIR:${GAMES_DATADIR}/${PN}:" \
+ "${FILESDIR}/${PN}" > "${D}${GAMES_BINDIR}/${PN}" \
+ || die "sed failed"
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins cgoban.jar || die "doins failed"
+ prepgamesdirs
+}