summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2004-03-19 00:46:35 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2004-03-19 00:46:35 +0000
commit2778313f6166ca11c6c2dd60762dbdd54b7f7519 (patch)
tree0dc4eef1bde46860980cb3f4a56603c21bf4a061 /games-arcade/viruskiller
parentfixed bug #45016 and #45059 (diff)
downloadhistorical-2778313f6166ca11c6c2dd60762dbdd54b7f7519.tar.gz
historical-2778313f6166ca11c6c2dd60762dbdd54b7f7519.tar.bz2
historical-2778313f6166ca11c6c2dd60762dbdd54b7f7519.zip
Updating to version 0.9. Ebuild submitted by Rene Androsch <art@artstower.com>. Closing bug #44764.
Diffstat (limited to 'games-arcade/viruskiller')
-rw-r--r--games-arcade/viruskiller/ChangeLog10
-rw-r--r--games-arcade/viruskiller/Manifest6
-rw-r--r--games-arcade/viruskiller/files/digest-viruskiller-0.91
-rw-r--r--games-arcade/viruskiller/viruskiller-0.9.ebuild46
4 files changed, 59 insertions, 4 deletions
diff --git a/games-arcade/viruskiller/ChangeLog b/games-arcade/viruskiller/ChangeLog
index 70099d38ad1f..17a0b5acd038 100644
--- a/games-arcade/viruskiller/ChangeLog
+++ b/games-arcade/viruskiller/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-arcade/viruskiller
-# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/viruskiller/ChangeLog,v 1.1 2004/01/18 04:39:31 vapier Exp $
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/viruskiller/ChangeLog,v 1.2 2004/03/19 00:46:34 wolf31o2 Exp $
+
+*viruskiller-0.9 (18 Mar 2004)
+
+ 18 Mar 2004; Chris Gianelloni <wolf31o2@gentoo.org> viruskiller-0.9.ebuild:
+ Updating to version 0.9. Ebuild submitted by Rene Androsch
+ <art@artstower.com>. Closing bug #44764.
*viruskiller-0.1 (17 Jan 2004)
diff --git a/games-arcade/viruskiller/Manifest b/games-arcade/viruskiller/Manifest
index a93712f3a6a4..4e01159712da 100644
--- a/games-arcade/viruskiller/Manifest
+++ b/games-arcade/viruskiller/Manifest
@@ -1,4 +1,6 @@
-MD5 61b43a8a7e6d5caa700b9b57fa45122e ChangeLog 396
+MD5 2da2e0429e99f614898cfa444c715adb viruskiller-0.9.ebuild 1102
+MD5 3ab54c5cb4698d8e45c4bf3a9ae366fa ChangeLog 613
+MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
MD5 2ef870404b180bda39acc22dce8b9a6d viruskiller-0.1.ebuild 1102
-MD5 a30c9d4ce8f9629d6d7323eaab258343 metadata.xml 241
MD5 5a039497fd26db84e5233c78ace9db37 files/digest-viruskiller-0.1 70
+MD5 7aed6b4a5ef035f812b711d9b650f0e0 files/digest-viruskiller-0.9 70
diff --git a/games-arcade/viruskiller/files/digest-viruskiller-0.9 b/games-arcade/viruskiller/files/digest-viruskiller-0.9
new file mode 100644
index 000000000000..f9c2c4ae10e8
--- /dev/null
+++ b/games-arcade/viruskiller/files/digest-viruskiller-0.9
@@ -0,0 +1 @@
+MD5 5dd118cce987cf0cea027f5960bd53e1 viruskiller-0.9-1.tar.gz 2171004
diff --git a/games-arcade/viruskiller/viruskiller-0.9.ebuild b/games-arcade/viruskiller/viruskiller-0.9.ebuild
new file mode 100644
index 000000000000..39e6f68f768e
--- /dev/null
+++ b/games-arcade/viruskiller/viruskiller-0.9.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/viruskiller/viruskiller-0.9.ebuild,v 1.1 2004/03/19 00:46:34 wolf31o2 Exp $
+
+inherit games
+
+DESCRIPTION="Simple arcade game, shoot'em up style, where you must defend your file system from invading viruses"
+HOMEPAGE="http://www.parallelrealities.co.uk/virusKiller.php"
+SRC_URI="${P}-1.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+RESTRICT="fetch"
+
+DEPEND="media-libs/libsdl
+ media-libs/sdl-mixer
+ media-libs/sdl-image
+ media-libs/sdl-ttf
+ dev-libs/zziplib"
+
+pkg_nofetch() {
+ einfo "Please download ${A} from"
+ einfo "http://www.parallelrealities.co.uk/virusKiller.php#Downloads"
+ einfo "and save the file in ${DISTDIR}"
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i \
+ -e "/^BINDIR = /s:/$:/bin/:" \
+ -e "/^DOCDIR = /s:doc/.*:doc/${PF}/html/:" \
+ makefile
+}
+
+src_compile() {
+ emake || die
+}
+
+src_install() {
+ emake install DESTDIR=${D} || die
+ rm ${D}/usr/share/doc/${PF}/html/{README,LICENSE}
+ dodoc doc/README
+ prepgamesdirs
+}