summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-10-19 02:35:57 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-10-19 02:35:57 +0000
commit31a00ca506765d7431dc69020c7fbd8c9be3e79e (patch)
treedb573a7c6020159f8ad5a535a24f3c8cc66d8cf3 /games-arcade/tomatoes
parentfix removeal of -r1 without any notice (diff)
downloadhistorical-31a00ca506765d7431dc69020c7fbd8c9be3e79e.tar.gz
historical-31a00ca506765d7431dc69020c7fbd8c9be3e79e.tar.bz2
historical-31a00ca506765d7431dc69020c7fbd8c9be3e79e.zip
gcc34 patch from Chris White via bug #68089
Diffstat (limited to 'games-arcade/tomatoes')
-rw-r--r--games-arcade/tomatoes/ChangeLog6
-rw-r--r--games-arcade/tomatoes/Manifest5
-rw-r--r--games-arcade/tomatoes/files/1.5-gcc34.patch20
-rw-r--r--games-arcade/tomatoes/tomatoes-1.5.ebuild6
4 files changed, 32 insertions, 5 deletions
diff --git a/games-arcade/tomatoes/ChangeLog b/games-arcade/tomatoes/ChangeLog
index bfeccc727279..f1f7b81e5a4d 100644
--- a/games-arcade/tomatoes/ChangeLog
+++ b/games-arcade/tomatoes/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-arcade/tomatoes
# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/tomatoes/ChangeLog,v 1.1 2004/10/19 02:00:48 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/tomatoes/ChangeLog,v 1.2 2004/10/19 02:35:57 mr_bones_ Exp $
+
+ 18 Oct 2004; Michael Sterrett <mr_bones_@gentoo.org> +files/1.5-gcc34.patch,
+ tomatoes-1.5.ebuild:
+ gcc34 patch from Chris White via bug #68089
*tomatoes-1.5 (18 Oct 2004)
diff --git a/games-arcade/tomatoes/Manifest b/games-arcade/tomatoes/Manifest
index 155e701e103d..d2d5332dc38f 100644
--- a/games-arcade/tomatoes/Manifest
+++ b/games-arcade/tomatoes/Manifest
@@ -1,4 +1,5 @@
-MD5 cf157414c307fe4bafdfaef4a50b5452 tomatoes-1.5.ebuild 1731
+MD5 141957abaf30c10abd0014e5c62c2e9e tomatoes-1.5.ebuild 1775
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
-MD5 de4c26b6f0170091d2c282ea5316b8be ChangeLog 406
+MD5 989250c815fec245fecb52e392f73c7f ChangeLog 555
MD5 2c9494bdf746978eff80c55028b0e5dc files/digest-tomatoes-1.5 146
+MD5 541cb5f35391525048ce62e6d28a5f17 files/1.5-gcc34.patch 712
diff --git a/games-arcade/tomatoes/files/1.5-gcc34.patch b/games-arcade/tomatoes/files/1.5-gcc34.patch
new file mode 100644
index 000000000000..5666195f2e28
--- /dev/null
+++ b/games-arcade/tomatoes/files/1.5-gcc34.patch
@@ -0,0 +1,20 @@
+--- src/texture.cpp_old 2004-10-19 01:30:14.744127000 +0900
++++ src/texture.cpp 2004-10-19 01:30:34.948055536 +0900
+@@ -108,7 +108,7 @@
+ SDL_LockSurface(img);
+
+ // Flip the surface pixels upside down
+- Uint8 *line = new (Uint8)[img->w*img->format->BytesPerPixel];
++ Uint8 *line = new Uint8[img->w*img->format->BytesPerPixel];
+ if(!line)
+ error_msg("Unable to flip surface %s:\nOut of memory!\n");
+
+@@ -207,7 +207,7 @@
+ SDL_LockSurface(img);
+
+ // Flip the surface pixels upside down
+- Uint8 *line = new (Uint8)[img->w*img->format->BytesPerPixel];
++ Uint8 *line = new Uint8[img->w*img->format->BytesPerPixel];
+ if(!line)
+ error_msg("Unable to flip surface %s:\nOut of memory!\n");
+
diff --git a/games-arcade/tomatoes/tomatoes-1.5.ebuild b/games-arcade/tomatoes/tomatoes-1.5.ebuild
index 1d39ad9e22fb..5a32236b71d0 100644
--- a/games-arcade/tomatoes/tomatoes-1.5.ebuild
+++ b/games-arcade/tomatoes/tomatoes-1.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/tomatoes/tomatoes-1.5.ebuild,v 1.1 2004/10/19 02:00:48 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/tomatoes/tomatoes-1.5.ebuild,v 1.2 2004/10/19 02:35:57 mr_bones_ Exp $
inherit eutils games
@@ -21,6 +21,7 @@ DEPEND="virtual/opengl
src_unpack() {
unpack ${A}
+ cd "${S}"
sed -i \
-e '/^CC/d' \
@@ -31,8 +32,9 @@ src_unpack() {
-e "/^HISCOREDIR = /s:./:${GAMES_STATEDIR}/${PN}/:" \
-e "/^CONFIGDIR = /s:./:${GAMES_SYSCONFDIR}/${PN}/:" \
-e "/^OVERRIDEDIR = /s:./data/:${GAMES_DATADIR}/${PN}/data/:" \
- "${S}/makefile" \
+ makefile \
|| die "sed failed"
+ epatch "${FILESDIR}/${PV}-gcc34.patch"
}
src_install() {