summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-02-17 09:29:16 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-02-17 09:29:16 +0000
commit625e605cd8944d93e22595b83e5c443de3a7e983 (patch)
tree9a8e402252396f52d71475ab07a95b171ab48040 /games-arcade/solarwolf/solarwolf-1.5.ebuild
parentmasked due to API changes which break apps. (diff)
downloadhistorical-625e605cd8944d93e22595b83e5c443de3a7e983.tar.gz
historical-625e605cd8944d93e22595b83e5c443de3a7e983.tar.bz2
historical-625e605cd8944d93e22595b83e5c443de3a7e983.zip
version bump
Diffstat (limited to 'games-arcade/solarwolf/solarwolf-1.5.ebuild')
-rw-r--r--games-arcade/solarwolf/solarwolf-1.5.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/games-arcade/solarwolf/solarwolf-1.5.ebuild b/games-arcade/solarwolf/solarwolf-1.5.ebuild
new file mode 100644
index 000000000000..c2ec90823a1a
--- /dev/null
+++ b/games-arcade/solarwolf/solarwolf-1.5.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/solarwolf/solarwolf-1.5.ebuild,v 1.1 2004/02/17 09:29:16 mr_bones_ Exp $
+
+inherit games
+
+DESCRIPTION="action/arcade recreation of SolarFox"
+HOMEPAGE="http://www.pygame.org/shredwheat/solarwolf/"
+SRC_URI="http://www.pygame.org/shredwheat/solarwolf/${P}.tar.gz"
+
+KEYWORDS="x86 ~sparc hppa"
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE=""
+
+DEPEND=">=dev-python/pygame-1.5.6
+ >=dev-lang/python-2.3
+ media-libs/libsdl"
+
+src_unpack() {
+ unpack ${A}
+ find ${S} -name .xvpics | xargs rm -rf
+}
+
+src_install() {
+ dodoc readme.txt
+ doman dist/solarwolf.6.gz
+ dodir ${GAMES_LIBDIR}/${PN}
+ cp -r code/ data/ *py ${D}/${GAMES_LIBDIR}/${PN}/ || die "cp failed"
+ games_make_wrapper solarwolf "python ./solarwolf.py" ${GAMES_LIBDIR}/${PN}
+ insinto /usr/share/icons
+ doins dist/solarwolf.png
+ make_desktop_entry solarwolf
+ prepgamesdirs
+}