summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2003-11-07 23:47:30 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2003-11-07 23:47:30 +0000
commit377f6cbaec15a9c8a6d03b50cecfc106a649c14f (patch)
tree110d6d0d1ff10979ffdee382bab4034b07fdcdcb /games-arcade/balloonchase
parentinitial commit (bug 32889) (diff)
downloadhistorical-377f6cbaec15a9c8a6d03b50cecfc106a649c14f.tar.gz
historical-377f6cbaec15a9c8a6d03b50cecfc106a649c14f.tar.bz2
historical-377f6cbaec15a9c8a6d03b50cecfc106a649c14f.zip
initial commit (bug 32889)
Diffstat (limited to 'games-arcade/balloonchase')
-rw-r--r--games-arcade/balloonchase/Manifest4
-rw-r--r--games-arcade/balloonchase/balloonchase-0.9.6.ebuild41
-rw-r--r--games-arcade/balloonchase/files/digest-balloonchase-0.9.61
-rw-r--r--games-arcade/balloonchase/metadata.xml9
4 files changed, 54 insertions, 1 deletions
diff --git a/games-arcade/balloonchase/Manifest b/games-arcade/balloonchase/Manifest
index 7e72946f89ce..1c0a127f8687 100644
--- a/games-arcade/balloonchase/Manifest
+++ b/games-arcade/balloonchase/Manifest
@@ -1,2 +1,4 @@
-MD5 9fba4c49375e8643e6ab6ad792bd68de balloonchase-0.9.6.ebuild 618
+MD5 91414c753957f2d7fd1cec05500cb233 balloonchase-0.9.6.ebuild 1200
+MD5 a30c9d4ce8f9629d6d7323eaab258343 metadata.xml 241
+MD5 53b1d62db3726be87ebc7d862831a8b3 ChangeLog 435
MD5 27e80fdc216d610068fca431f7812acf files/digest-balloonchase-0.9.6 71
diff --git a/games-arcade/balloonchase/balloonchase-0.9.6.ebuild b/games-arcade/balloonchase/balloonchase-0.9.6.ebuild
new file mode 100644
index 000000000000..6e6d14c0d0cf
--- /dev/null
+++ b/games-arcade/balloonchase/balloonchase-0.9.6.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/balloonchase/balloonchase-0.9.6.ebuild,v 1.1 2003/11/07 23:47:27 mr_bones_ Exp $
+
+inherit games
+
+DESCRIPTION="Fly a hot air balloon and try to blow the other player out of the screen"
+HOMEPAGE="http://koti.mbnet.fi/makegho/c/bchase/"
+SRC_URI="http://koti.mbnet.fi/makegho/c/bchase/${P}.tar.bz2"
+
+KEYWORDS="x86"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND="media-libs/libsdl"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ sed -i \
+ -e '/opendir/ i\ if (getenv("HOME")) { chdir(getenv("HOME")); }
+ ' \
+ -e 's:balloonchase.dat:.balloonchaserc:ig' \
+ -e "s:\"images/:\"${GAMES_DATADIR}/${PN}/images/:" src/main.c || \
+ die 'sed main.c failed'
+ sed -i \
+ -e "/^CFLAGS/ s:=.*:= ${CFLAGS}:" Makefile || \
+ die 'sed Makefile failed'
+}
+
+src_install() {
+ dogamesbin balloonchase || die "dogamesbin failed"
+ dodir "${GAMES_DATADIR}/${PN}"
+ cp -r images "${D}/${GAMES_DATADIR}/${PN}/" || die "cp failed"
+ dodoc README || die "dodoc failed"
+ prepgamesdirs
+}
diff --git a/games-arcade/balloonchase/files/digest-balloonchase-0.9.6 b/games-arcade/balloonchase/files/digest-balloonchase-0.9.6
new file mode 100644
index 000000000000..26342aa7e100
--- /dev/null
+++ b/games-arcade/balloonchase/files/digest-balloonchase-0.9.6
@@ -0,0 +1 @@
+MD5 ed386a8e30f90ad13dd404f219e4332b balloonchase-0.9.6.tar.bz2 523085
diff --git a/games-arcade/balloonchase/metadata.xml b/games-arcade/balloonchase/metadata.xml
new file mode 100644
index 000000000000..1cef6e243af3
--- /dev/null
+++ b/games-arcade/balloonchase/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+<maintainer>
+<email>games@gentoo.org</email>
+<name>Games Team</name>
+</maintainer>
+</pkgmetadata>