summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-10-06 18:27:27 +0000
committerMike Frysinger <vapier@gentoo.org>2003-10-06 18:27:27 +0000
commitbd17d42559577612277f4aee3a8176b7a8d382dc (patch)
tree0d5b7e7f934032da449e21458e88584715332ea6 /games-action/glaxium
parentNew portage. Fixes create() tracebacks. (diff)
downloadhistorical-bd17d42559577612277f4aee3a8176b7a8d382dc.tar.gz
historical-bd17d42559577612277f4aee3a8176b7a8d382dc.tar.bz2
historical-bd17d42559577612277f4aee3a8176b7a8d382dc.zip
nvidia fixes #30322
Diffstat (limited to 'games-action/glaxium')
-rw-r--r--games-action/glaxium/ChangeLog5
-rw-r--r--games-action/glaxium/files/0.5-20021024-Makefile.in60
-rw-r--r--games-action/glaxium/files/0.5-glx.patch59
-rw-r--r--games-action/glaxium/files/glx-test.c4
-rw-r--r--games-action/glaxium/glaxium-0.5.ebuild20
5 files changed, 77 insertions, 71 deletions
diff --git a/games-action/glaxium/ChangeLog b/games-action/glaxium/ChangeLog
index 1f9fd1577c20..eff3222af7d4 100644
--- a/games-action/glaxium/ChangeLog
+++ b/games-action/glaxium/ChangeLog
@@ -1,9 +1,12 @@
# ChangeLog for games-action/glaxium
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/glaxium/ChangeLog,v 1.2 2003/09/10 20:29:40 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/glaxium/ChangeLog,v 1.3 2003/10/06 18:27:27 vapier Exp $
*glaxium-0.5 (19 Jun 2003)
+ 06 Oct 2003; Mike Frysinger <vapier@gentoo.org> :
+ Make it work w/nvidia opengl header files #30322.
+
19 Jun 2003; Mike Frysinger <vapier@gentoo.org> :
Initial import. Ebuild submitted by Thomas R. (TRauMa) <trauma@web.de>
and Bret Towe <btowe@gbis.com> #6752.
diff --git a/games-action/glaxium/files/0.5-20021024-Makefile.in b/games-action/glaxium/files/0.5-20021024-Makefile.in
deleted file mode 100644
index 0b420a978c58..000000000000
--- a/games-action/glaxium/files/0.5-20021024-Makefile.in
+++ /dev/null
@@ -1,60 +0,0 @@
-
-CC=@CXX@
-INCLUDE=@CFLAGS@ @CPPFLAGS@
-LIB=@LIBS@
-
-OBJ= $(patsubst %.cpp,%.o,$(wildcard *.cpp))
-DATE=`date +"%d.%m.%Y"`
-
-
-prefix=@prefix@
-exec_prefix=@exec_prefix@
-datadir=@datadir@
-bindir=@bindir@
-mandir=@mandir@
-
-GLAXIUM_INSTALLDIR=$(bindir)
-DATA_DIRS=samples textures
-GLAXIUM_HOME=$(datadir)/games/glaxium
-MAN_DIR=$(mandir)
-
-glaxium : $(OBJ)
- gcc -g -o glaxium $(OBJ) $(LIB)
-
-
-
-nosound:
- (SOUND=no; make)
-
-clean:
- rm -f $(OBJ) glaxium config.log config.cache config.status aclocal.m4 *~
-
-
-%.o : %.cpp
- $(CC) -c $(INCLUDE) $< -o $@ -DDATADIR=\"$(GLAXIUM_HOME)\"
-
-
-install: glaxium
- @echo Instaling glaxium in $(GLAXIUM_INSTALLDIR) and its data in $(GLAXIUM_HOME)
-
- @if [ ! -d $(DESTDIR)$(GLAXIUM_HOME) ] ; then \
- mkdir -p $(DESTDIR)$(GLAXIUM_HOME) ; \
- fi
-
- @if [ ! -d $(DESTDIR)$(GLAXIUM_INSTALLDIR) ] ; then \
- mkdir -p $(DESTDIR)$(GLAXIUM_INSTALLDIR) ; \
- fi
-
- @if [ ! -d $(DESTDIR)$(MAN_DIR)/man6 ] ; then \
- mkdir -p $(DESTDIR)$(MAN_DIR)/man6 ; \
- fi
-
- @cp -f glaxium $(DESTDIR)$(GLAXIUM_INSTALLDIR)/
- @cp -R $(DATA_DIRS) $(DESTDIR)$(GLAXIUM_HOME)
- @cp -f glaxium.6 $(DESTDIR)$(MAN_DIR)/man6/glaxium.6
-
-uninstall:
- @echo Uninstaling glaxium
- rm -f $(GLAXIUM_INSTALLDIR)/glaxium
- rm -rf $(GLAXIUM_HOME)
- rm -f $(MAN_DIR)/man6/glaxium.6
diff --git a/games-action/glaxium/files/0.5-glx.patch b/games-action/glaxium/files/0.5-glx.patch
new file mode 100644
index 000000000000..c36355f62023
--- /dev/null
+++ b/games-action/glaxium/files/0.5-glx.patch
@@ -0,0 +1,59 @@
+--- ./scene.cpp.gege 2002-10-10 14:57:58.000000000 +0200
++++ ./scene.cpp 2003-04-25 12:30:01.000000000 +0200
+@@ -51,6 +51,7 @@
+ extern bool bKeyDown;
+
+
++/*
+ PFNGLCOMBINERPARAMETERINVPROC glCombinerParameteriNV;
+ PFNGLCOMBINERINPUTNVPROC glCombinerInputNV;
+ PFNGLCOMBINEROUTPUTNVPROC glCombinerOutputNV;
+@@ -67,6 +68,7 @@
+ PFNGLACTIVETEXTUREARBPROC glActiveTextureARB;
+ PFNGLMULTITEXCOORD2FARBPROC glMultiTexCoord2fARB;
+ #endif
++*/
+
+ GLenum glError;
+
+@@ -1511,6 +1511,7 @@
+ glTrackMatrixNV=(PFNGLTRACKMATRIXNVPROC)wglGetProcAddress("glTrackMatrixNV");
+ glProgramParameter4fNV=(PFNGLPROGRAMPARAMETER4FNVPROC)wglGetProcAddress("glProgramParameter4fNV");
+ #else
++/*
+ glCombinerParameteriNV=(PFNGLCOMBINERPARAMETERINVPROC)glXGetProcAddressARB((const GLubyte *)"glCombinerParameteriNV");
+ glCombinerInputNV=(PFNGLCOMBINERINPUTNVPROC)glXGetProcAddressARB((const GLubyte *)"glCombinerInputNV");
+ glCombinerOutputNV=(PFNGLCOMBINEROUTPUTNVPROC)glXGetProcAddressARB((const GLubyte *)"glCombinerOutputNV");
+@@ -1520,6 +1521,7 @@
+ glBindProgramNV=(PFNGLBINDPROGRAMNVPROC)glXGetProcAddressARB((const GLubyte *)"glBindProgramNV");
+ glTrackMatrixNV=(PFNGLTRACKMATRIXNVPROC)glXGetProcAddressARB((const GLubyte *)"glTrackMatrixNV");
+ glProgramParameter4fNV=(PFNGLPROGRAMPARAMETER4FNVPROC)glXGetProcAddressARB((const GLubyte *)"glProgramParameter4fNV");
++*/
+ #endif
+ // enabled in when required
+ glDisable(GL_VERTEX_PROGRAM_NV);
+--- ./myship.cpp.gege 2002-10-12 23:16:16.000000000 +0200
++++ ./myship.cpp 2003-04-25 12:26:58.000000000 +0200
+@@ -19,6 +19,7 @@
+
+
+
++#define GL_GLEXT_PROTOTYPES 1
+ #include <GL/glut.h>
+ #include <GL/glext.h>
+
+@@ -35,10 +36,10 @@
+ #include "modeles/protection.c"
+
+
+-extern PFNGLCOMBINERPARAMETERINVPROC glCombinerParameteriNV;
+-extern PFNGLCOMBINERINPUTNVPROC glCombinerInputNV;
+-extern PFNGLCOMBINEROUTPUTNVPROC glCombinerOutputNV;
+-extern PFNGLFINALCOMBINERINPUTNVPROC glFinalCombinerInputNV;
++//extern PFNGLCOMBINERPARAMETERINVPROC glCombinerParameteriNV;
++//extern PFNGLCOMBINERINPUTNVPROC glCombinerInputNV;
++//extern PFNGLCOMBINEROUTPUTNVPROC glCombinerOutputNV;
++//extern PFNGLFINALCOMBINERINPUTNVPROC glFinalCombinerInputNV;
+ #ifdef WIN32
+ extern PFNGLACTIVETEXTUREARBPROC glActiveTextureARB;
+ #endif
diff --git a/games-action/glaxium/files/glx-test.c b/games-action/glaxium/files/glx-test.c
new file mode 100644
index 000000000000..4919a0f87b68
--- /dev/null
+++ b/games-action/glaxium/files/glx-test.c
@@ -0,0 +1,4 @@
+#include <GL/glut.h>
+#include <GL/glext.h>
+PFNGLCOMBINERPARAMETERINVPROC t;
+int main(){return 0;}
diff --git a/games-action/glaxium/glaxium-0.5.ebuild b/games-action/glaxium/glaxium-0.5.ebuild
index af1f08503931..d8cdbda10340 100644
--- a/games-action/glaxium/glaxium-0.5.ebuild
+++ b/games-action/glaxium/glaxium-0.5.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/glaxium/glaxium-0.5.ebuild,v 1.1 2003/09/10 19:29:16 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/glaxium/glaxium-0.5.ebuild,v 1.2 2003/10/06 18:27:27 vapier Exp $
-inherit games flag-o-matic
+inherit games flag-o-matic gcc
DESCRIPTION="OpenGL-based space-ship shoot-em-up style game"
HOMEPAGE="http://xhosxe.free.fr/glaxium/"
@@ -12,24 +12,24 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86"
-DEPEND=">=libsdl-1.1.5
+DEPEND=">=media-libs/libsdl-1.1.5
>=media-libs/sdl-mixer-1.2.4
virtual/x11
virtual/opengl
virtual/glu
virtual/glut
- >=libpng-1.0.0"
+ >=media-libs/libpng-1.0.0"
S=${WORKDIR}/${PN}_${PV}
-pkg_setup() {
- ewarn "This currently only compiles with XFree OpenGL support"
- ewarn "Use \`opengl-update xfree\` before emerging"
-}
-
src_unpack() {
unpack ${A}
- cp ${FILESDIR}/${PV}-20021024-Makefile.in ${S}/
+ cd ${S}
+ ebegin "Checking if glx patch is needed"
+ $(gcc-getCXX) ${FILESDIR}/glx-test.c
+ local ret=$?
+ [ ${ret} -eq 0 ] || epatch ${FILESDIR}/${PV}-glx.patch
+ eend ${ret}
}
src_compile() {