summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorJohn Mylchreest <johnm@gentoo.org>2004-02-18 20:24:52 +0000
committerJohn Mylchreest <johnm@gentoo.org>2004-02-18 20:24:52 +0000
commit836f09fc740c3e8ff3f8c042dcf0176f1962d804 (patch)
tree9cc872d02c5fd24c5a21e58485733a530712b024 /eclass
parentA new revision to fix issues with 2.6.3 kernels. (diff)
downloadhistorical-836f09fc740c3e8ff3f8c042dcf0176f1962d804.tar.gz
historical-836f09fc740c3e8ff3f8c042dcf0176f1962d804.tar.bz2
historical-836f09fc740c3e8ff3f8c042dcf0176f1962d804.zip
small fix in case /usr/src/linux/Makefile doesnt exist
Diffstat (limited to 'eclass')
-rw-r--r--eclass/kernel-2.eclass6
1 files changed, 5 insertions, 1 deletions
diff --git a/eclass/kernel-2.eclass b/eclass/kernel-2.eclass
index 05bafdfb0010..e53654c8f03c 100644
--- a/eclass/kernel-2.eclass
+++ b/eclass/kernel-2.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/kernel-2.eclass,v 1.29 2004/02/16 18:30:33 johnm Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/kernel-2.eclass,v 1.30 2004/02/18 20:24:52 johnm Exp $
# kernel.eclass rewrite for a clean base regarding the 2.6 series of kernel
# with back-compatibility for 2.4
@@ -35,6 +35,10 @@
ECLASS="kernel-2"
EXPORT_FUNCTIONS pkg_setup src_unpack src_compile src_install pkg_preinst pkg_postinst
+# to prevent errors if theres no sources in /usr/src
+# we set KV and re-set it later on as well.
+[ -z "${KV}" ] && KV=${PV}
+
HOMEPAGE="http://www.kernel.org/ http://www.gentoo.org/"
LICENSE="GPL-2"
IUSE="${IUSE} build"