summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-12-29 06:45:06 +0000
committerMike Frysinger <vapier@gentoo.org>2012-12-29 06:45:06 +0000
commit73e6951044d7109a95845108c969507af8f75706 (patch)
tree62e8929dcb6499162b1d23af72cf47d6f15af0d8 /eclass
parentchange `use doc` to `use_if_iuse doc` since not all gcc versions have USE=doc (diff)
downloadhistorical-73e6951044d7109a95845108c969507af8f75706.tar.gz
historical-73e6951044d7109a95845108c969507af8f75706.tar.bz2
historical-73e6951044d7109a95845108c969507af8f75706.zip
enable libffi with gcc-3.0+ (i did not have a local copy at the time to check against)
Diffstat (limited to 'eclass')
-rw-r--r--eclass/toolchain.eclass4
1 files changed, 2 insertions, 2 deletions
diff --git a/eclass/toolchain.eclass b/eclass/toolchain.eclass
index c521c606e945..14a1a353afcc 100644
--- a/eclass/toolchain.eclass
+++ b/eclass/toolchain.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/toolchain.eclass,v 1.565 2012/12/29 06:44:03 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/toolchain.eclass,v 1.566 2012/12/29 06:45:06 vapier Exp $
#
# Maintainer: Toolchain Ninjas <toolchain@gentoo.org>
@@ -779,7 +779,7 @@ toolchain_src_unpack() {
fi
# Prevent libffi from being installed
- if tc_version_is_at_least 3.1 ; then
+ if tc_version_is_at_least 3.0 ; then
sed -i -e 's/\(install.*:\) install-.*recursive/\1/' "${S}"/libffi/Makefile.in || die
sed -i -e 's/\(install-data-am:\).*/\1/' "${S}"/libffi/include/Makefile.in || die
fi