summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-04-27 00:12:04 +0000
committerMike Frysinger <vapier@gentoo.org>2006-04-27 00:12:04 +0000
commit5688ffa267746ab792ca067c1c067186461686c6 (patch)
treee3fede575df3414d7f40bd5ee2fc384cc243e680 /eclass
parentVersion bump from upstream (diff)
downloadhistorical-5688ffa267746ab792ca067c1c067186461686c6.tar.gz
historical-5688ffa267746ab792ca067c1c067186461686c6.tar.bz2
historical-5688ffa267746ab792ca067c1c067186461686c6.zip
redo how we enable protoize so it works with cross-compiling/bsd/etc... #130962
Diffstat (limited to 'eclass')
-rw-r--r--eclass/toolchain.eclass18
1 files changed, 5 insertions, 13 deletions
diff --git a/eclass/toolchain.eclass b/eclass/toolchain.eclass
index 997f90856006..87ee25f9455e 100644
--- a/eclass/toolchain.eclass
+++ b/eclass/toolchain.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/toolchain.eclass,v 1.275 2006/04/25 00:26:17 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/toolchain.eclass,v 1.276 2006/04/27 00:12:04 vapier Exp $
HOMEPAGE="http://gcc.gnu.org/"
LICENSE="GPL-2 LGPL-2.1"
@@ -979,6 +979,10 @@ gcc_src_unpack() {
${ETYPE}_src_unpack || die "failed to ${ETYPE}_src_unpack"
+ # enable protoize / unprotoize
+ sed -i -e '/^COMPILERS =/s:$: protoize$(exeext) unprotoize$(exeext):' \
+ "${S}"/gcc/Makefile.in
+
fix_files=""
for x in contrib/test_summary libstdc++-v3/scripts/check_survey.in ; do
[[ -e ${x} ]] && fix_files="${fix_files} ${x}"
@@ -1335,18 +1339,6 @@ gcc_do_make() {
${GCC_MAKE_TARGET} \
|| die "emake failed with ${GCC_MAKE_TARGET}"
- if [[ ${CTARGET} != *-freebsd* ]]; then
- einfo "Running make LDFLAGS=\"${LDFLAGS}\" STAGE1_CFLAGS=\"${STAGE1_CFLAGS}\" LIBPATH=\"${LIBPATH}\" BOOT_CFLAGS=\"${BOOT_CFLAGS}\" proto"
- # Build protoize
- emake -C gcc \
- LDFLAGS="${LDFLAGS}" \
- STAGE1_CFLAGS="${STAGE1_CFLAGS}" \
- LIBPATH="${LIBPATH}" \
- BOOT_CFLAGS="${BOOT_CFLAGS}" \
- proto \
- || die "emake failed with proto"
- fi
-
if ! use build && ! is_crosscompile && ! use nocxx && use doc ; then
if type -p doxygen > /dev/null ; then
cd "${CTARGET}"/libstdc++-v3