summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2002-01-04 12:06:28 +0000
committerDan Armak <danarmak@gentoo.org>2002-01-04 12:06:28 +0000
commit518ad691bcb0696cd19a909ce31ff5dfe6d571ab (patch)
treec1ed1d12e4097a62754c2ca4b792f3cad4b6f25a /eclass
parentfix for qt (diff)
downloadhistorical-518ad691bcb0696cd19a909ce31ff5dfe6d571ab.tar.gz
historical-518ad691bcb0696cd19a909ce31ff5dfe6d571ab.tar.bz2
historical-518ad691bcb0696cd19a909ce31ff5dfe6d571ab.zip
merged virtual.eclass -> inherit.eclass. added || die to inherit(). added cvs snapshot support to
kde.eclass (runs make -f admin/Makefile.common where appropriate). misc small fixes.
Diffstat (limited to 'eclass')
-rw-r--r--eclass/autotools.eclass8
-rw-r--r--eclass/base.eclass3
-rw-r--r--eclass/doc/news.txt4
-rw-r--r--eclass/inherit.eclass56
-rw-r--r--eclass/kde-base.eclass4
-rw-r--r--eclass/kde-dist.eclass4
-rw-r--r--eclass/kde-i18n.eclass4
-rw-r--r--eclass/kde.eclass15
-rw-r--r--eclass/koffice-i18n.eclass4
9 files changed, 82 insertions, 20 deletions
diff --git a/eclass/autotools.eclass b/eclass/autotools.eclass
index 18f11dca867c..559251d9cbd2 100644
--- a/eclass/autotools.eclass
+++ b/eclass/autotools.eclass
@@ -1,7 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author: Martin Schlemmer <azarah@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/eclass/autotools.eclass,v 1.1 2001/12/31 23:43:41 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/autotools.eclass,v 1.2 2002/01/04 12:06:28 danarmak Exp $
# The autotools eclass enables building of the apps that needs the latest autconf/automake.
#
# NOTES:
@@ -22,7 +22,7 @@
# # Copyright 1999-2002 Gentoo Technologies, Inc.
# # Distributed under the terms of the GNU General Public License, v2 or later
# # Maintainer: John Doe <john@foo.com>
-# # $Header: /var/cvsroot/gentoo-x86/eclass/autotools.eclass,v 1.1 2001/12/31 23:43:41 azarah Exp $
+# # $Header: /var/cvsroot/gentoo-x86/eclass/autotools.eclass,v 1.2 2002/01/04 12:06:28 danarmak Exp $
#
# # If you need to set the versions different from in here, it *must*
# # be done before inherit.eclass is sourced
@@ -30,8 +30,8 @@
# #AMAKEVER=1.5b
#
# # Source inherit.eclass and inherit AutoTools
-# . /usr/portage/eclass/inherit.eclass || die
-# inherit autotools || die
+# . /usr/portage/eclass/inherit.eclass
+# inherit autotools
#
# # This is pretty standard.
# S=${WORKDIR}/${P}
diff --git a/eclass/base.eclass b/eclass/base.eclass
index d03fe63f6be6..0c630bfe2dce 100644
--- a/eclass/base.eclass
+++ b/eclass/base.eclass
@@ -1,10 +1,9 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Dan Armak <danarmak@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/eclass/base.eclass,v 1.8 2001/12/22 14:52:29 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/base.eclass,v 1.9 2002/01/04 12:06:28 danarmak Exp $
# The base eclass defines some default functions and variables. Nearly everything
# else inherits from here.
-inherit virtual || die
ECLASS=base
S=${WORKDIR}/${P}
diff --git a/eclass/doc/news.txt b/eclass/doc/news.txt
index 0758fa87e1eb..e2c0b7efaad0 100644
--- a/eclass/doc/news.txt
+++ b/eclass/doc/news.txt
@@ -1,3 +1,7 @@
+04/01/2002
+merged virtual.eclass -> inherit.eclass.
+added || die to source statement in inherit(), so it's no longer needed when calling it.
+
28/12
v5.1
Really big changes. Most of what has been added in the last versions has been deleted. Summary of changes:
diff --git a/eclass/inherit.eclass b/eclass/inherit.eclass
index ba981df71853..7d5f8b8e10f7 100644
--- a/eclass/inherit.eclass
+++ b/eclass/inherit.eclass
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Dan Armak <danarmak@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/eclass/inherit.eclass,v 1.8 2001/10/03 17:10:16 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/inherit.eclass,v 1.9 2002/01/04 12:06:28 danarmak Exp $
# This eclass provides the inherit() function. In the future it will be placed in ebuild.sh, but for now drobbins
# doesn't want to make a new portage just for my testing, so every eclass/ebuild will source this file manually and
# then inherit(). This way when the tmie comes for this to move into stable ebuild.sh, we can just delete the source lines.
@@ -12,12 +12,60 @@ inherit() {
while [ "$1" ]; do
location="${ECLASSDIR}/${1}.eclass"
- # someday we'll do this the right way.
- # for now, disable by deafult because it creates a lot extra sourcing.
+ # for now, disable by deafult because it creates a lot extra sourcing. (get debug lvels there already!)
# . ${ECLASSDIR}/debug.eclass
# debug-print "inherit: $1 -> $location"
- source "$location"
+ source "$location" || die
shift
done
}
+
+# this was once virtual.eclass, now merged
+# provides empty functions that call debug-print-function and the EXPORT_FUNCTIONS() implementation
+
+inherit debug
+
+ECLASS=virtual
+
+DESCRIPTION="Based on the $ECLASS eclass."
+
+virtual_src_unpack() {
+debug-print-function $FUNCNAME $*
+}
+virtual_src_compile() {
+debug-print-function $FUNCNAME $*
+}
+virtual_src_install() {
+debug-print-function $FUNCNAME $*
+}
+virtual_pkg_preinst() {
+debug-print-function $FUNCNAME $*
+}
+virtual_pkg_postinst() {
+debug-print-function $FUNCNAME $*
+}
+virtual_pkg_prerm() {
+debug-print-function $FUNCNAME $*
+}
+virtual_pkg_postrm() {
+debug-print-function $FUNCNAME $*
+}
+
+# EXPORT_FUNCTIONS trick
+# This is the global part, defined here only.
+
+EXPORT_FUNCTIONS() {
+
+ while [ "$1" ]; do
+ debug-print "EXPORT_FUNCTIONS: ${1} -> ${ECLASS}_${1}"
+ eval "$1() { ${ECLASS}_$1 ; }" > /dev/null
+ shift
+ done
+
+}
+
+
+# This part should be repeated for every eclass inheriting from here.
+EXPORT_FUNCTIONS src_unpack src_compile src_install pkg_preinst pkg_postinst pkg_prerm pkg_postrm
+
diff --git a/eclass/kde-base.eclass b/eclass/kde-base.eclass
index 818b8c3dc5fa..022bb0350d2e 100644
--- a/eclass/kde-base.eclass
+++ b/eclass/kde-base.eclass
@@ -1,10 +1,10 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Dan Armak <danarmak@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/eclass/kde-base.eclass,v 1.12 2001/12/23 21:35:15 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/kde-base.eclass,v 1.13 2002/01/04 12:06:28 danarmak Exp $
# This is the kde ebuild for std. kde-dependant apps which follow configure/make/make install
# procedures and have std. configure options.
-inherit c kde || die
+inherit c kde
ECLASS=kde-base
DESCRIPTION="Based on the $ECLASS eclass"
diff --git a/eclass/kde-dist.eclass b/eclass/kde-dist.eclass
index bd49b1050e9f..fb2b51a748fe 100644
--- a/eclass/kde-dist.eclass
+++ b/eclass/kde-dist.eclass
@@ -1,10 +1,10 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Dan Armak <danarmak@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/eclass/kde-dist.eclass,v 1.6 2001/12/23 21:35:15 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/kde-dist.eclass,v 1.7 2002/01/04 12:06:28 danarmak Exp $
# This is the kde-dist eclass for >=2.2.1 kde base packages. Don't use for kdelibs though :-)
# Don't use it for e.g. kdevelop, koffice because of their separate versionnig schemes.
-inherit kde-base kde.org || die
+inherit kde-base kde.org
ECLASS=kde-dist
need-kde $PV
diff --git a/eclass/kde-i18n.eclass b/eclass/kde-i18n.eclass
index 670db750a040..060d6bb3d0ed 100644
--- a/eclass/kde-i18n.eclass
+++ b/eclass/kde-i18n.eclass
@@ -1,8 +1,8 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Dan Armak <danarmak@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/eclass/kde-i18n.eclass,v 1.8 2001/12/29 17:41:37 danarmak Exp $
-inherit kde kde.org || die
+# $Header: /var/cvsroot/gentoo-x86/eclass/kde-i18n.eclass,v 1.9 2002/01/04 12:06:28 danarmak Exp $
+inherit kde kde.org
ECLASS=kde-i18n
S=${WORKDIR}/${PN}
diff --git a/eclass/kde.eclass b/eclass/kde.eclass
index ff7ff1c38102..12122d742042 100644
--- a/eclass/kde.eclass
+++ b/eclass/kde.eclass
@@ -1,9 +1,9 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Dan Armak <danarmak@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/eclass/kde.eclass,v 1.30 2002/01/03 20:31:10 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/kde.eclass,v 1.31 2002/01/04 12:06:28 danarmak Exp $
# The kde eclass is inherited by all kde-* eclasses. Few ebuilds inherit straight from here.
-inherit autoconf base || die
+inherit autoconf base
ECLASS=kde
DESCRIPTION="Based on the $ECLASS eclass"
@@ -28,6 +28,17 @@ kde_src_compile() {
configure)
debug-print-section configure
debug-print "$FUNCNAME::configure: myconf=$myconf"
+
+ # This can happen with e.g. a cvs snapshot
+ if [ ! -f "./configure" ]; then
+ for x in admin/Makefile.common; do
+ if [ -f "$x" ]; then
+ make -f $x # don't || die here!
+ fi
+ done
+ [ -f "./configure" ] || die
+ fi
+
export PATH="${KDEDIR}/bin:${PATH}"
./configure ${myconf} || die
;;
diff --git a/eclass/koffice-i18n.eclass b/eclass/koffice-i18n.eclass
index 96ad251e16bd..78c26bea5f79 100644
--- a/eclass/koffice-i18n.eclass
+++ b/eclass/koffice-i18n.eclass
@@ -1,8 +1,8 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Dan Armak <danarmak@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/eclass/koffice-i18n.eclass,v 1.4 2001/12/23 21:35:15 danarmak Exp $
-inherit kde || die
+# $Header: /var/cvsroot/gentoo-x86/eclass/koffice-i18n.eclass,v 1.5 2002/01/04 12:06:28 danarmak Exp $
+inherit kde
ECLASS=koffice-i18n
case $PV in