summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCiaran McCreesh <ciaranm@gentoo.org>2006-01-17 17:00:30 +0000
committerCiaran McCreesh <ciaranm@gentoo.org>2006-01-17 17:00:30 +0000
commit65b327d81698388616ebcd5835b7ad380748da00 (patch)
tree13f49ca4270799e78d6f43209bb7ea201daa43e3 /eclass/vim.eclass
parentAdded ~ppc keyword. bug 119156 (diff)
downloadhistorical-65b327d81698388616ebcd5835b7ad380748da00.tar.gz
historical-65b327d81698388616ebcd5835b7ad380748da00.tar.bz2
historical-65b327d81698388616ebcd5835b7ad380748da00.zip
Fix vim7 build, bug #119023
Diffstat (limited to 'eclass/vim.eclass')
-rw-r--r--eclass/vim.eclass6
1 files changed, 5 insertions, 1 deletions
diff --git a/eclass/vim.eclass b/eclass/vim.eclass
index ae189aba5887..98d01280697e 100644
--- a/eclass/vim.eclass
+++ b/eclass/vim.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/vim.eclass,v 1.139 2006/01/13 18:45:43 ciaranm Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/vim.eclass,v 1.140 2006/01/17 17:00:30 ciaranm Exp $
# Authors:
# Ryan Phillips <rphillips@gentoo.org>
@@ -328,6 +328,10 @@ END
"${S}/src/po/Makefile"
fi
+ # Temporary vim7 fix, bug #119023.
+ if [[ $(get_major_version ) -ge 7 ]] ; then
+ sed -i -e '/deadly_exit/d' "${S}/src/gui_gtk_x11.c"
+ fi
}
vim_src_compile() {