summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Callen <jcallen@gentoo.org>2011-06-07 20:11:04 +0000
committerJonathan Callen <jcallen@gentoo.org>2011-06-07 20:11:04 +0000
commit6aef0ea72fbf3b96c78357f1acbf4c6946cf4846 (patch)
treed248d2fad7714dfd6bb08b67e71b05b9f798bb76 /eclass/kde4-meta.eclass
parentFix manifest. (diff)
downloadhistorical-6aef0ea72fbf3b96c78357f1acbf4c6946cf4846.tar.gz
historical-6aef0ea72fbf3b96c78357f1acbf4c6946cf4846.tar.bz2
historical-6aef0ea72fbf3b96c78357f1acbf4c6946cf4846.zip
Sync KDE eclasses with overlay again (prerequisite for slotmoves)
Diffstat (limited to 'eclass/kde4-meta.eclass')
-rw-r--r--eclass/kde4-meta.eclass40
1 files changed, 13 insertions, 27 deletions
diff --git a/eclass/kde4-meta.eclass b/eclass/kde4-meta.eclass
index c1b17e5f52cb..81503a0dc966 100644
--- a/eclass/kde4-meta.eclass
+++ b/eclass/kde4-meta.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/kde4-meta.eclass,v 1.53 2011/06/06 17:51:26 abcd Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/kde4-meta.eclass,v 1.54 2011/06/07 20:11:04 abcd Exp $
#
# @ECLASS: kde4-meta.eclass
# @MAINTAINER:
@@ -208,7 +208,7 @@ kde4-meta_src_extract() {
;;
esac
else
- local abort tarball tarfile f extractlist moduleprefix postfix
+ local abort tarball tarfile f extractlist postfix
KMTARPARAMS+=" --bzip2"
postfix="bz2"
@@ -217,10 +217,6 @@ kde4-meta_src_extract() {
kdebase-apps)
# kdebase/apps -> kdebase-apps
tarball="kdebase-${PV}.tar.${postfix}"
- if ! slot_is_at_least 4.6 ${SLOT} || [[ ${PV} == "4.6.0" ]]; then
- moduleprefix=apps/
- KMTARPARAMS+=" --transform=s|apps/||"
- fi
;;
*)
# Create tarball name from module name (this is the default)
@@ -241,7 +237,7 @@ kde4-meta_src_extract() {
for f in cmake/ CMakeLists.txt ConfigureChecks.cmake config.h.cmake
do
- extractlist+=" ${topdir}${moduleprefix}${f}"
+ extractlist+=" ${topdir}${f}"
done
extractlist+=" $(__list_needed_subdirectories)"
@@ -268,9 +264,6 @@ kde4-meta_src_extract() {
eend $?
- # We need to clear it here to make verification below work
- unset moduleprefix
-
if [[ -n ${KDE4_STRICTER} ]]; then
for f in $(__list_needed_subdirectories fatal); do
if [[ ! -e ${S}/${f#*/} ]]; then
@@ -296,7 +289,7 @@ kde4-meta_create_extractlists() {
# Add default handbook locations
# FIXME - legacy code - remove when 4.4.5 is gone or preferrably port 4.4.5.
- if ! slot_is_at_least 4.5 ${SLOT} && has handbook ${IUSE//+} && use handbook && [[ -z ${KMNOMODULE} ]]; then
+ if [[ $(get_kde_version) < 4.5 ]] && has handbook ${IUSE//+} && use handbook && [[ -z ${KMNOMODULE} ]]; then
# We use the basename of $KMMODULE because $KMMODULE can contain
# the path to the module subdirectory.
KMEXTRA_NONFATAL+="
@@ -312,18 +305,7 @@ kde4-meta_create_extractlists() {
# Note that this actually doesn't include KMEXTRA handling.
# In those cases you should care to add the relevant files to KMEXTRACTONLY
case ${KMNAME} in
- kdebase)
- if ! slot_is_at_least 4.6 ${SLOT} || [[ ${PV} == "4.6.0" ]]; then
- KMEXTRACTONLY+="
- apps/config-apps.h.cmake
- apps/ConfigureChecks.cmake"
- else
- KMEXTRACTONLY+="
- config-apps.h.cmake
- ConfigureChecks.cmake"
- fi
- ;;
- kdebase-apps | kde-baseapps)
+ kdebase | kdebase-apps | kde-base-apps)
KMEXTRACTONLY+="
config-apps.h.cmake
ConfigureChecks.cmake"
@@ -356,7 +338,7 @@ kde4-meta_create_extractlists() {
KMEXTRACTONLY+="
config-enterprise.h.cmake
kleopatra/ConfigureChecks.cmake"
- if slot_is_at_least 4.5 ${SLOT}; then
+ if ! [[ $(get_kde_version) < 4.5 ]]; then
KMEXTRACTONLY+="
CTestCustom.cmake
kdepim-version.h.cmake"
@@ -391,7 +373,11 @@ kde4-meta_create_extractlists() {
# Don't install cmake modules for split ebuilds, to avoid collisions.
# note: kdegraphics >= 4.6.2 does not even have code to do that, so we
# should not try in that case
- if [[ ${KMNAME} != kdegraphics ]] || { [[ ${SLOT} != 4.6 || ${PV} < 4.6.2 ]] && ! slot_is_at_least 4.7 ${SLOT}; }; then
+ # note2: kdeedu 4.6.4 does not have a cmake/modules/ subdir anymore :(
+ # it may be possible to formulate this shorter, but it should also
+ # still be understandable...
+ if [[ ${KMNAME} != kdegraphics || ( ( $(get_kde_version) != 4.6 || ${PV} < 4.6.2 ) && $(get_kde_version) < 4.7 ) ]] \
+ && ! [[ ${KMNAME} == kdeedu && ${PV} == 4.6.4 ]]; then
case ${KMNAME} in
kdebase-runtime|kde-runtime|kdebase-workspace|kde-workspace|kdeedu|kdegames|kdegraphics)
case ${PN} in
@@ -455,7 +441,7 @@ __list_needed_subdirectories() {
for i in ${kmmodule_expanded} ${kmextra_expanded} ${kmcompileonly_expanded} \
${KMEXTRACTONLY}
do
- extractlist+=" ${topdir}${moduleprefix}${i}"
+ extractlist+=" ${topdir}${i}"
done
echo ${extractlist}
@@ -603,7 +589,7 @@ kde4-meta_change_cmakelists() {
-e '/if[[:space:]]*([[:space:]]*[[:alnum:]]*_FOUND[[:space:]]*)/s/^/#OVERRIDE /' \
-i kontact/plugins/CMakeLists.txt || die 'failed to override build logic'
fi
- if ! slot_is_at_least 4.5 ${SLOT}; then
+ if [[ $(get_kde_version) < 4.5 ]]; then
case ${PN} in
kalarm|kmailcvt|kontact|korganizer|korn)
sed -n -e '/qt4_generate_dbus_interface(.*org\.kde\.kmail\.\(kmail\|mailcomposer\)\.xml/p' \