summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Johanson <latexer@gentoo.org>2005-11-14 02:55:50 +0000
committerPeter Johanson <latexer@gentoo.org>2005-11-14 02:55:50 +0000
commitb7906695dfd7e8599155837b8fd01e843a7cce84 (patch)
treea35669d5ff153780b56421b5f99cf65241069522 /dev-util
parent1.2.5.1 version bump for bug 112341 (diff)
downloadhistorical-b7906695dfd7e8599155837b8fd01e843a7cce84.tar.gz
historical-b7906695dfd7e8599155837b8fd01e843a7cce84.tar.bz2
historical-b7906695dfd7e8599155837b8fd01e843a7cce84.zip
Add patch to make ISO-1 C# compliant. Needed for compilation with upcoming mono-1.1.10
Package-Manager: portage-2.0.51.22-r2
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/monodevelop/ChangeLog7
-rw-r--r--dev-util/monodevelop/Manifest5
-rw-r--r--dev-util/monodevelop/files/monodevelop-0.8-iso-api-update.diff86
-rw-r--r--dev-util/monodevelop/monodevelop-0.8.ebuild8
4 files changed, 102 insertions, 4 deletions
diff --git a/dev-util/monodevelop/ChangeLog b/dev-util/monodevelop/ChangeLog
index 37181dc03d40..6ac56e8a5099 100644
--- a/dev-util/monodevelop/ChangeLog
+++ b/dev-util/monodevelop/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/monodevelop
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/monodevelop/ChangeLog,v 1.37 2005/10/16 02:21:06 latexer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/monodevelop/ChangeLog,v 1.38 2005/11/14 02:55:50 latexer Exp $
+
+ 14 Nov 2005; Peter Johanson <latexer@gentoo.org>
+ +files/monodevelop-0.8-iso-api-update.diff, monodevelop-0.8.ebuild:
+ Add patch to make ISO-1 C# compliant. Needed for compilation with upcoming
+ mono-1.1.10
*monodevelop-0.8 (16 Oct 2005)
diff --git a/dev-util/monodevelop/Manifest b/dev-util/monodevelop/Manifest
index 6eaa2571c5ef..81492e272657 100644
--- a/dev-util/monodevelop/Manifest
+++ b/dev-util/monodevelop/Manifest
@@ -1,9 +1,9 @@
MD5 35c17e64aed292e7a7f6aeb5915787a3 monodevelop-0.5.1-r4.ebuild 1559
-MD5 163de1b84e9329ba5fc3a554d169e19c ChangeLog 6347
+MD5 e8dab68a1e5f4425475dec7559b038b3 ChangeLog 6560
MD5 76b314cc7b7b79b298dd4889dff8c9cd metadata.xml 159
MD5 9cf588769f67de01bdb230e64b451ac5 monodevelop-0.7-r1.ebuild 1800
MD5 a430f9561f918a21f460a4749427c249 monodevelop-0.7-r2.ebuild 1843
-MD5 669bd4818235a7209ff1b26efc8f3a87 monodevelop-0.8.ebuild 1273
+MD5 5aad04df993aec977ae3ca15a3bc192a monodevelop-0.8.ebuild 1358
MD5 2200a01878af7bc8553e3c3181d70463 files/digest-monodevelop-0.8 68
MD5 f36ce806f3552f974021d1a56021f67c files/monodevelop-0.5.1-iconloader.diff 1255
MD5 9e3ea3908c299c9240a5f7689f83909a files/monodevelop-0.5.1-nemerle-gtk-sharp.diff 1874
@@ -13,3 +13,4 @@ MD5 cff7e9d967516c14789c6d0246791c9d files/monodevelop-0.7-boo-0.6.0-compat.diff
MD5 31886624cd9fce60d5c7346c2b22960e files/monodevelop-0.7-gtksharp-update.diff 8260
MD5 48b6815b0eb2b1996cc0bd00b3e312a6 files/monodevelop-0.7-mcs-path-fix.diff 1917
MD5 48b44fa7ba76c3b567d260ecff9e7aea files/digest-monodevelop-0.7-r2 68
+MD5 606a61241cec46077c00541c346b0f9f files/monodevelop-0.8-iso-api-update.diff 3528
diff --git a/dev-util/monodevelop/files/monodevelop-0.8-iso-api-update.diff b/dev-util/monodevelop/files/monodevelop-0.8-iso-api-update.diff
new file mode 100644
index 000000000000..60cb641448c7
--- /dev/null
+++ b/dev-util/monodevelop/files/monodevelop-0.8-iso-api-update.diff
@@ -0,0 +1,86 @@
+diff -aur monodevelop-0.8-orig/Extras/VersionControl/VersionControl/Subversion.cs monodevelop-0.8/Extras/VersionControl/VersionControl/Subversion.cs
+--- monodevelop-0.8-orig/Extras/VersionControl/VersionControl/Subversion.cs 2005-09-23 13:11:15.000000000 -0700
++++ monodevelop-0.8/Extras/VersionControl/VersionControl/Subversion.cs 2005-11-12 22:54:54.000000000 -0800
+@@ -474,7 +474,7 @@
+ ArrayList statuses;
+ public StatusCollector(ArrayList statuses) { this.statuses = statuses; }
+ public void Func(IntPtr baton, IntPtr path, ref svn_wc_status_t status) {
+- if (status.to__svn_wc_entry_t == IntPtr.Zero)
++ if (status.to_svn_wc_entry_t == IntPtr.Zero)
+ return;
+ string pathstr = Marshal.PtrToStringAnsi(path);
+ statuses.Add(new StatusEnt(status, pathstr));
+@@ -586,18 +586,18 @@
+
+ internal StatusEnt(svn_wc_status_t status, string localpath) {
+ LocalFilePath = localpath;
+- TextStatus = (NodeStatus)status.svn_wc_status_kind__text;
+- PropsStatus = (NodeStatus)status.svn_wc_status_kind__props;
++ TextStatus = (NodeStatus)status.svn_wc_status_kind_text;
++ PropsStatus = (NodeStatus)status.svn_wc_status_kind_props;
+ Locked = status.locked != 0;
+ Copied = status.copied != 0;
+ Switched = status.switched != 0;
+- RemoteTextStatus = (NodeStatus)status.svn_wc_status_kind__text__repo;
+- RemotePropsStatus = (NodeStatus)status.svn_wc_status_kind__props__repo;
++ RemoteTextStatus = (NodeStatus)status.svn_wc_status_kind_text_repo;
++ RemotePropsStatus = (NodeStatus)status.svn_wc_status_kind_props_repo;
+
+- if (status.to__svn_wc_entry_t == IntPtr.Zero)
++ if (status.to_svn_wc_entry_t == IntPtr.Zero)
+ return;
+
+- svn_wc_entry_t ent = (svn_wc_entry_t)Marshal.PtrToStructure(status.to__svn_wc_entry_t, typeof(svn_wc_entry_t));
++ svn_wc_entry_t ent = (svn_wc_entry_t)Marshal.PtrToStructure(status.to_svn_wc_entry_t, typeof(svn_wc_entry_t));
+ Name = ent.name;
+ Revision = ent.revision;
+ Url = ent.url;
+@@ -695,7 +695,7 @@
+ private struct svn_error_t {
+ public int apr_err;
+ public string message;
+- public IntPtr svn_error_t__child;
++ public IntPtr svn_error_t_child;
+ public IntPtr pool;
+ }
+
+@@ -774,14 +774,14 @@
+ }
+
+ internal struct svn_wc_status_t {
+- public IntPtr to__svn_wc_entry_t;
+- public int svn_wc_status_kind__text;
+- public int svn_wc_status_kind__props;
++ public IntPtr to_svn_wc_entry_t;
++ public int svn_wc_status_kind_text;
++ public int svn_wc_status_kind_props;
+ public int locked;
+ public int copied;
+ public int switched;
+- public int svn_wc_status_kind__text__repo;
+- public int svn_wc_status_kind__props__repo;
++ public int svn_wc_status_kind_text_repo;
++ public int svn_wc_status_kind_props_repo;
+ }
+
+ public struct Rev {
+@@ -877,7 +877,7 @@
+ IntPtr ctx, IntPtr pool);
+
+ [DllImport(svnclientlib)] static extern IntPtr svn_client_log (
+- IntPtr apr_array_header_t__targets,
++ IntPtr apr_array_header_t_targets,
+ ref Rev rev_start, ref Rev rev_end,
+ int discover_changed_paths,
+ int strict_node_history,
+@@ -911,8 +911,8 @@
+ int recurse, IntPtr ctx, IntPtr pool);
+
+ [DllImport(svnclientlib)] static extern IntPtr svn_client_commit (
+- ref IntPtr svn_client_commit_info_t__commit_info,
+- IntPtr apr_array_header_t__targets, int nonrecursive,
++ ref IntPtr svn_client_commit_info_t_commit_info,
++ IntPtr apr_array_header_t_targets, int nonrecursive,
+ IntPtr ctx, IntPtr pool);
+ }
+
diff --git a/dev-util/monodevelop/monodevelop-0.8.ebuild b/dev-util/monodevelop/monodevelop-0.8.ebuild
index 9843411f286f..f3a76d1ae776 100644
--- a/dev-util/monodevelop/monodevelop-0.8.ebuild
+++ b/dev-util/monodevelop/monodevelop-0.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/monodevelop/monodevelop-0.8.ebuild,v 1.1 2005/10/16 02:21:06 latexer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/monodevelop/monodevelop-0.8.ebuild,v 1.2 2005/11/14 02:55:50 latexer Exp $
inherit mono eutils fdo-mime
@@ -26,6 +26,12 @@ DEPEND=">=dev-dotnet/gtksourceview-sharp-0.10
KEYWORDS="~amd64 ~ppc ~x86"
SLOT="0"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-iso-api-update.diff
+}
+
src_compile() {
econf \
$(use_enable boo) \