summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFernando J. Pereda <ferdy@gentoo.org>2005-12-02 10:40:22 +0000
committerFernando J. Pereda <ferdy@gentoo.org>2005-12-02 10:40:22 +0000
commit4a2c6b2204cb1406681899b4a3c0b7c7ab867daf (patch)
treeccddc87b8316bb16540b64f04a9530ab2431fa21 /dev-util
parentVersion bump, removing old version (diff)
downloadhistorical-4a2c6b2204cb1406681899b4a3c0b7c7ab867daf.tar.gz
historical-4a2c6b2204cb1406681899b4a3c0b7c7ab867daf.tar.bz2
historical-4a2c6b2204cb1406681899b4a3c0b7c7ab867daf.zip
remove unneeded patch
Package-Manager: portage-2.0.51.22-r3
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/git/ChangeLog6
-rw-r--r--dev-util/git/Manifest10
-rw-r--r--dev-util/git/files/git-0.99.9j-binary-diff-fix.patch46
3 files changed, 15 insertions, 47 deletions
diff --git a/dev-util/git/ChangeLog b/dev-util/git/ChangeLog
index 15d158c465bc..fa6600738caf 100644
--- a/dev-util/git/ChangeLog
+++ b/dev-util/git/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-util/git
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/git/ChangeLog,v 1.48 2005/12/01 21:10:20 ferdy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/git/ChangeLog,v 1.49 2005/12/02 10:40:22 ferdy Exp $
+
+ 02 Dec 2005; Fernando J. Pereda <ferdy@gentoo.org>
+ -files/git-0.99.9j-binary-diff-fix.patch:
+ remove unneeded patch
*git-0.99.9k (01 Dec 2005)
diff --git a/dev-util/git/Manifest b/dev-util/git/Manifest
index 5960d905341d..411cb05b70f1 100644
--- a/dev-util/git/Manifest
+++ b/dev-util/git/Manifest
@@ -1,3 +1,6 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
MD5 d35a0c0793dbfc65191588d2eca405d1 git-0.99.8a.ebuild 2835
MD5 ad5fb3a82abf5263b825d5ffd892df95 git-0.99.9k.ebuild 3328
MD5 edebd592261315b29a6b903b414573d2 git-0.7.ebuild 1312
@@ -8,3 +11,10 @@ MD5 ad6b9193f41375013fad4455bf1acda7 files/git-daemon.initd 526
MD5 62316f61a79143fdaf1e9f747d1ddf03 files/digest-git-0.99.8a 69
MD5 3c1cd0e753a45032f9c6fa9667d7cd76 files/digest-git-0.99.9k 64
MD5 8ebc37d29c321b95a3c0ae51ebee4d4d files/digest-git-0.7 59
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.2 (GNU/Linux)
+
+iD8DBQFDkCSnViELBEf1JB0RAqFcAJwMeyCInvoD7FDhsgBmXlPN5DOFggCfUIiF
+6DV9atIsY3VXjRbWGgPIV+s=
+=l3rJ
+-----END PGP SIGNATURE-----
diff --git a/dev-util/git/files/git-0.99.9j-binary-diff-fix.patch b/dev-util/git/files/git-0.99.9j-binary-diff-fix.patch
deleted file mode 100644
index 6d5e0965b52f..000000000000
--- a/dev-util/git/files/git-0.99.9j-binary-diff-fix.patch
+++ /dev/null
@@ -1,46 +0,0 @@
-From: Junio C Hamano <junkio@cox.net>
-Date: Fri, 18 Nov 2005 04:46:29 +0000 (-0800)
-Subject: Deal with binary diff output from GNU diff 2.8.7
-X-Git-Url: http://kernel.org/git/?p=git/git.git;a=commitdiff;h=3200d1aee0c22a34d075aafefe3e92f4f7d08840
-
- Deal with binary diff output from GNU diff 2.8.7
-
- Some vintage of diff says just "Files X and Y differ\n", instead
- of "Binary files X and Y differ\n", so catch both patterns.
-
- Signed-off-by: Junio C Hamano <junkio@cox.net>
----
-
---- a/apply.c
-+++ b/apply.c
-@@ -893,12 +893,24 @@ static int parse_chunk(char *buffer, uns
- patchsize = parse_single_patch(buffer + offset + hdrsize, size - offset - hdrsize, patch);
-
- if (!patchsize) {
-- static const char binhdr[] = "Binary files ";
--
-- if (sizeof(binhdr) - 1 < size - offset - hdrsize &&
-- !memcmp(binhdr, buffer + hdrsize + offset,
-- sizeof(binhdr)-1))
-- patch->is_binary = 1;
-+ static const char *binhdr[] = {
-+ "Binary files ",
-+ "Files ",
-+ NULL,
-+ };
-+ int i;
-+ int hd = hdrsize + offset;
-+ unsigned long llen = linelen(buffer + hd, size - hd);
-+
-+ if (!memcmp(" differ\n", buffer + hd + llen - 8, 8))
-+ for (i = 0; binhdr[i]; i++) {
-+ int len = strlen(binhdr[i]);
-+ if (len < size - hd &&
-+ !memcmp(binhdr[i], buffer + hd, len)) {
-+ patch->is_binary = 1;
-+ break;
-+ }
-+ }
-
- /* Empty patch cannot be applied if:
- * - it is a binary patch and we do not do binary_replace, or