summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-01-14 07:47:17 +0000
committerJustin Lecher <jlec@gentoo.org>2013-01-14 07:47:17 +0000
commit6ef1e2e06f0176567e5c7f01f245c51c2c7d3214 (patch)
tree8d282d2624aeab51bf8a63c220599d5ec0b10819 /dev-util/nvidia-cuda-toolkit/nvidia-cuda-toolkit-3.2.ebuild
parentapp-misc/gcal: Version Bump, moved to EAPI=5, #451710; fixes also build with ... (diff)
downloadhistorical-6ef1e2e06f0176567e5c7f01f245c51c2c7d3214.tar.gz
historical-6ef1e2e06f0176567e5c7f01f245c51c2c7d3214.tar.bz2
historical-6ef1e2e06f0176567e5c7f01f245c51c2c7d3214.zip
dev-util/nvidia-cuda-toolkit: Version Bump, #446072 and #451972; fine grad what msg we are showing, #440434; support prefix installations, #405317; drop old, #351702; take the package
Package-Manager: portage-2.2.0_alpha151/cvs/Linux x86_64 Manifest-Sign-Key: 0x70EB7916
Diffstat (limited to 'dev-util/nvidia-cuda-toolkit/nvidia-cuda-toolkit-3.2.ebuild')
-rw-r--r--dev-util/nvidia-cuda-toolkit/nvidia-cuda-toolkit-3.2.ebuild141
1 files changed, 0 insertions, 141 deletions
diff --git a/dev-util/nvidia-cuda-toolkit/nvidia-cuda-toolkit-3.2.ebuild b/dev-util/nvidia-cuda-toolkit/nvidia-cuda-toolkit-3.2.ebuild
deleted file mode 100644
index e6d79e172ea5..000000000000
--- a/dev-util/nvidia-cuda-toolkit/nvidia-cuda-toolkit-3.2.ebuild
+++ /dev/null
@@ -1,141 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/nvidia-cuda-toolkit/nvidia-cuda-toolkit-3.2.ebuild,v 1.11 2012/09/24 00:44:31 vapier Exp $
-
-EAPI=2
-
-inherit eutils multilib unpacker
-
-DESCRIPTION="NVIDIA CUDA Toolkit"
-HOMEPAGE="http://developer.nvidia.com/cuda"
-RESTRICT="binchecks"
-
-CUDA_V=${PV//_/-}
-DIR_V=${CUDA_V//./_}
-DIR_V=${DIR_V//beta/Beta}
-
-BASE_URI="http://developer.download.nvidia.com/compute/cuda/${DIR_V}_prod/toolkit"
-SRC_URI="amd64? ( ${BASE_URI}/cudatoolkit_${CUDA_V}.16_linux_64_ubuntu10.04.run )
- x86? ( ${BASE_URI}/cudatoolkit_${CUDA_V}.16_linux_32_ubuntu10.04.run )"
-
-LICENSE="NVIDIA"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="debugger doc profiler"
-
-RDEPEND="${DEPEND}
- >=sys-devel/binutils-2.20
- >=sys-devel/gcc-4.0
- profiler? ( x86? (
- x11-libs/qt-gui:4
- x11-libs/qt-core:4
- x11-libs/qt-assistant:4
- x11-libs/qt-sql:4[sqlite] )
- media-libs/libpng:1.2
- )
- debugger? ( >=sys-libs/libtermcap-compat-2.0.8-r2 )
- !<=x11-drivers/nvidia-drivers-256.53"
-
-S="${WORKDIR}"
-
-#QA_FLAGS_IGNORED_x86="opt/cuda/.*"
-#QA_FLAGS_IGNORED_amd64="opt/cuda/.*"
-
-src_install() {
- local DEST=/opt/cuda
-
- into ${DEST}
- dobin bin/*
- dolib $(get_libdir)/*
-
- if ! use debugger; then
- rm -f "${D}/${DEST}/bin/cuda-gdb"
- fi
-
- chmod a-x "${D}/${DEST}/bin/nvcc.profile"
-
- # TODO: Manuals are missing from this release. Remove the following
- # commented-out lines if they are not restored in the next releases.
- # doman does not respect DESTTREE
- #insinto ${DEST}/man/man1
- #doins man/man1/*
- #insinto ${DEST}/man/man3
- #doins man/man3/*
- #prepman ${DEST}
-
- insinto ${DEST}/include
- doins -r include/*
-
- insinto ${DEST}/src
- doins src/*
-
- if use doc ; then
- insinto ${DEST}/doc
- doins -r doc/*
- fi
-
- cat > "${T}/env" << EOF
-PATH=${DEST}/bin
-ROOTPATH=${DEST}/bin
-LDPATH=${DEST}/$(get_libdir)
-MANPATH=${DEST}/man
-EOF
- newenvd "${T}/env" 99cuda
-
- if use profiler; then
- local target="computeprof"
-
- into ${DEST}/${target}
- dobin ${target}/bin/${target}
-
- cat > "${T}/env" << EOF
-PATH=${DEST}/${target}/bin
-ROOTPATH=${DEST}/${target}/bin
-EOF
- if use x86 ; then
- dosym /usr/bin/assistant ${DEST}/${target}/bin
-
- insinto ${DEST}/${target}/bin
- doins ${target}/bin/cudaapitrace.so
- else
- dobin ${target}/bin/assistant
- insinto ${DEST}/${target}/bin
- doins ${target}/bin/*.so*
- insinto ${DEST}/${target}/bin/sqldrivers
- doins ${target}/bin/sqldrivers/*
-
- cat >> "${T}/env" << EOF
-LDPATH=${DEST}/${target}/bin
-EOF
- fi
-
- newenvd "${T}/env" 99${target}
-
- if use doc; then
- insinto ${DEST}/${target}
- doins ${target}/*.txt
- insinto ${DEST}/${target}/doc
- doins ${target}/doc/*
- insinto ${DEST}/${target}/projects
- doins ${target}/projects/*
- fi
-
- make_desktop_entry /opt/cuda/computeprof/bin/computeprof "NVIDIA Compute Visual Profiler"
- fi
-
- export CONF_LIBDIR_OVERRIDE="lib"
- # HACK: temporary workaround until CONF_LIBDIR_OVERRIDE is respected.
- export LIBDIR_amd64="lib"
-
- into ${DEST}/open64
- dobin open64/bin/*
- libopts -m0755
- dolib open64/lib/*
-}
-
-pkg_postinst() {
- elog "If you want to natively run the code generated by this version of the"
- elog "CUDA toolkit, you will need >=x11-drivers/nvidia-drivers-260.19.21."
- elog ""
- elog "Run '. /etc/profile' before using the CUDA toolkit. "
-}