summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Kinard <kumba@gentoo.org>2003-10-02 08:07:58 +0000
committerJoshua Kinard <kumba@gentoo.org>2003-10-02 08:07:58 +0000
commit2a8b9936921a28c659009f08298350a139bb6b69 (patch)
treec7e2de84761cdd2ca8449f67a24b83cc61c1971b /dev-util/ddd/ddd-3.3.7.ebuild
parentRevision Bump; ddd-3.3.7 compiles with gcc-3.3.1 but not gcc-2.95.x; Closes B... (diff)
downloadhistorical-2a8b9936921a28c659009f08298350a139bb6b69.tar.gz
historical-2a8b9936921a28c659009f08298350a139bb6b69.tar.bz2
historical-2a8b9936921a28c659009f08298350a139bb6b69.zip
Revision Bump; ddd-3.3.7 compiles with gcc-3.3.1 but not gcc-2.95.x; Closes Bug #28468
Diffstat (limited to 'dev-util/ddd/ddd-3.3.7.ebuild')
-rw-r--r--dev-util/ddd/ddd-3.3.7.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-util/ddd/ddd-3.3.7.ebuild b/dev-util/ddd/ddd-3.3.7.ebuild
new file mode 100644
index 000000000000..4fdd99be1502
--- /dev/null
+++ b/dev-util/ddd/ddd-3.3.7.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/ddd/ddd-3.3.7.ebuild,v 1.1 2003/10/02 08:07:56 kumba Exp $
+
+inherit eutils
+
+DESCRIPTION="graphical front-end for command-line debuggers"
+HOMEPAGE="http://www.gnu.org/software/ddd"
+SRC_URI="ftp://ftp.easynet.be/gnu/ddd/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2 LGPL-2.1 FDL-1.1"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+
+DEPEND="virtual/x11
+ >=sys-devel/gdb-4.16
+ virtual/motif"
+
+src_unpack() {
+ unpack ${A}
+}
+
+src_compile() {
+ CXXFLAGS="${CXXFLAGS}"
+ econf || die
+ emake || die
+}
+
+src_install() {
+ dodir /usr/lib
+ # If using internal libiberty.a, need to pass
+ # $tooldir to 'make install', else we get
+ # sandbox errors ... bug #4614.
+ # <azarah@gentoo.org> 05 Dec 2002
+ einstall tooldir=${D}/usr || die
+
+ # This one is from binutils
+ [ -f ${D}/usr/lib/libiberty.a ] && rm -f ${D}/usr/lib/libiberty.a
+ # Remove empty dir ...
+ rmdir ${D}/usr/lib || :
+
+ mv ${S}/doc/README ${S}/doc/README-DOC
+ dodoc ANNOUNCE AUTHORS BUGS COPYING* CREDITS INSTALL NEWS* NICKNAMES \
+ OPENBUGS PROBLEMS README* TIPS TODO
+
+ mv ${S}/doc/* ${D}/usr/share/doc/${PF}
+}