summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Maitin-Shepard <jbms@gentoo.org>2003-11-15 18:29:18 +0000
committerJeremy Maitin-Shepard <jbms@gentoo.org>2003-11-15 18:29:18 +0000
commit67b8b5f8328415d2093e701c6791370d12a6234a (patch)
tree089c0bac3e9286d5c7328cb83a82d16f793ec5f1 /dev-util/cscope
parentFixed emacs lisp and site file installation. (diff)
downloadhistorical-67b8b5f8328415d2093e701c6791370d12a6234a.tar.gz
historical-67b8b5f8328415d2093e701c6791370d12a6234a.tar.bz2
historical-67b8b5f8328415d2093e701c6791370d12a6234a.zip
Fixed emacs lisp and site file installation.
Diffstat (limited to 'dev-util/cscope')
-rw-r--r--dev-util/cscope/Manifest4
-rw-r--r--dev-util/cscope/cscope-15.4-r1.ebuild63
-rw-r--r--dev-util/cscope/files/digest-cscope-15.4-r11
3 files changed, 66 insertions, 2 deletions
diff --git a/dev-util/cscope/Manifest b/dev-util/cscope/Manifest
index 6497bf18e977..250acf2b5711 100644
--- a/dev-util/cscope/Manifest
+++ b/dev-util/cscope/Manifest
@@ -1,7 +1,7 @@
MD5 6b521f3ead303be707450feaf032153c cscope-15.4.ebuild 1385
-MD5 8e23812c6a1fadc605521e6cd0143d9b cscope-15.4-r1.ebuild 1180
+MD5 4a353bb9ad6d43511077f3abe4be6314 cscope-15.4-r1.ebuild 1278
MD5 658b0c2a114ad2401993b1da8a3dcdf9 cscope-15.3.ebuild 815
-MD5 e68e399a8e089788db66f304955f3f06 ChangeLog 2149
+MD5 bf2eeaa69d7eea1f101356b4f94e2e01 ChangeLog 2146
MD5 28ddc553966bf7045758be324600f5c8 files/50xcscope-gentoo.el 95
MD5 326b4f2785a741e10f370a6accfd1c28 files/digest-cscope-15.3 63
MD5 ae33cee910261c162094e95a82523f6c files/digest-cscope-15.4 63
diff --git a/dev-util/cscope/cscope-15.4-r1.ebuild b/dev-util/cscope/cscope-15.4-r1.ebuild
new file mode 100644
index 000000000000..fe1f1fa72683
--- /dev/null
+++ b/dev-util/cscope/cscope-15.4-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cscope/cscope-15.4-r1.ebuild,v 1.1 2003/11/15 18:29:15 jbms Exp $
+
+inherit gnuconfig elisp-common
+
+S=${WORKDIR}/${P}
+DESCRIPTION="CScope - interactively examine a C program"
+SRC_URI="mirror://sourceforge/cscope/${P}.tar.gz"
+HOMEPAGE="http://cscope.sourceforge.net"
+
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="~x86 -ppc -sparc -alpha -hppa -mips -arm"
+
+IUSE="emacs"
+
+RDEPEND=">=sys-libs/ncurses-5.2"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4
+ sys-devel/flex
+ sys-devel/bison
+ emacs? ( virtual/emacs )"
+
+SITEFILE=50xcscope-gentoo.el
+
+src_compile() {
+ gnuconfig_update
+
+ sed -i -e "s:={:{:" src/egrep.y
+
+ econf || die
+ make clean || die
+ emake || die
+
+ if use emacs
+ then
+ cd ${S}/contrib/xcscope
+ elisp-compile *.el
+ fi
+}
+
+src_install() {
+ einstall || die
+ dodoc NEWS AUTHORS TODO COPYING ChangeLog INSTALL README*
+
+ if use emacs
+ then
+ cd ${S}/contrib/xcscope
+ elisp-install xcscope *.el *.elc
+ elisp-site-file-install ${FILESDIR}/${SITEFILE}
+ dobin cscope-indexer
+ fi
+ cp -r ${S}/contrib/webcscope ${D}/usr/share/doc/${P}/
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}
diff --git a/dev-util/cscope/files/digest-cscope-15.4-r1 b/dev-util/cscope/files/digest-cscope-15.4-r1
new file mode 100644
index 000000000000..a29e5845a4fe
--- /dev/null
+++ b/dev-util/cscope/files/digest-cscope-15.4-r1
@@ -0,0 +1 @@
+MD5 4e9172cbdf17d6fe5206ebd67aa90dfc cscope-15.4.tar.gz 224057