summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Ehmsen <ehmsen@gentoo.org>2006-01-25 16:09:19 +0000
committerMartin Ehmsen <ehmsen@gentoo.org>2006-01-25 16:09:19 +0000
commitae805abcb9daa982ed2fd80ae275c9307ba7f9e8 (patch)
tree5f84ecfba5944232cbb3514524c10eea346b64ba /dev-tex/cpp2latex
parentX is implicit (diff)
downloadhistorical-ae805abcb9daa982ed2fd80ae275c9307ba7f9e8.tar.gz
historical-ae805abcb9daa982ed2fd80ae275c9307ba7f9e8.tar.bz2
historical-ae805abcb9daa982ed2fd80ae275c9307ba7f9e8.zip
Added patch and rev bump for fixing bug #44585.
Package-Manager: portage-2.1_pre3-r1
Diffstat (limited to 'dev-tex/cpp2latex')
-rw-r--r--dev-tex/cpp2latex/ChangeLog11
-rw-r--r--dev-tex/cpp2latex/Manifest7
-rw-r--r--dev-tex/cpp2latex/cpp2latex-2.3-r1.ebuild33
-rw-r--r--dev-tex/cpp2latex/files/cpp2latex-2.3.patch44
-rw-r--r--dev-tex/cpp2latex/files/digest-cpp2latex-2.3-r11
5 files changed, 92 insertions, 4 deletions
diff --git a/dev-tex/cpp2latex/ChangeLog b/dev-tex/cpp2latex/ChangeLog
index d0f2253ae374..0fc8ab870d6d 100644
--- a/dev-tex/cpp2latex/ChangeLog
+++ b/dev-tex/cpp2latex/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-tex/cpp2latex
-# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tex/cpp2latex/ChangeLog,v 1.7 2004/11/27 07:53:20 pclouds Exp $
+# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/cpp2latex/ChangeLog,v 1.8 2006/01/25 16:09:19 ehmsen Exp $
+
+*cpp2latex-2.3-r1 (25 Jan 2006)
+
+ 25 Jan 2006; Martin Ehmsen <ehmsen@gentoo.org> +files/cpp2latex-2.3.patch,
+ +cpp2latex-2.3-r1.ebuild:
+ Added patch, thanks to Alessandro Flacco, for fixing odd number of '*' in
+ comments, see bug #44585.
27 Nov 2004; <pclouds@gentoo.org> cpp2latex-2.3.ebuild:
HOMEPAGE moved
diff --git a/dev-tex/cpp2latex/Manifest b/dev-tex/cpp2latex/Manifest
index dff695c24aaa..ec7b9c576b8c 100644
--- a/dev-tex/cpp2latex/Manifest
+++ b/dev-tex/cpp2latex/Manifest
@@ -1,4 +1,7 @@
-MD5 69f801150055dcefbc9f50ce61bac59d ChangeLog 980
+MD5 a7d3e9db511e5e946d09eca412a2c421 ChangeLog 1223
+MD5 6e8c99d094e859a54895bf31009bc8da cpp2latex-2.3-r1.ebuild 789
MD5 a0cc739cc2440759d43b04c20ddde701 cpp2latex-2.3.ebuild 709
-MD5 c472f5fd1646eb8bca71d8df5cb2bdcc metadata.xml 164
+MD5 1fd22c97de733af30a9b2414f3847497 files/cpp2latex-2.3.patch 1237
MD5 4ddccb3d54e217dce70b97f0b2990111 files/digest-cpp2latex-2.3 65
+MD5 4ddccb3d54e217dce70b97f0b2990111 files/digest-cpp2latex-2.3-r1 65
+MD5 c472f5fd1646eb8bca71d8df5cb2bdcc metadata.xml 164
diff --git a/dev-tex/cpp2latex/cpp2latex-2.3-r1.ebuild b/dev-tex/cpp2latex/cpp2latex-2.3-r1.ebuild
new file mode 100644
index 000000000000..520622634a08
--- /dev/null
+++ b/dev-tex/cpp2latex/cpp2latex-2.3-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/cpp2latex/cpp2latex-2.3-r1.ebuild,v 1.1 2006/01/25 16:09:19 ehmsen Exp $
+
+inherit eutils
+
+DESCRIPTION="A program to convert C++ code to LaTeX source"
+HOMEPAGE="http://roederberg.dyndns.org/~arnold/cpp2latex"
+SRC_URI="http://www.arnoldarts.de/${P}.tar.gz"
+LICENSE="GPL-2"
+
+IUSE=""
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64 ~sparc"
+
+# although it makes sense to have tex installed, it is
+# neither a compile or runtime dependency
+
+src_unpack() {
+ unpack ${A} || die
+ cd ${S}/cpp2latex
+ # bug 44585
+ epatch ${FILESDIR}/cpp2latex-2.3.patch || die
+}
+
+src_compile() {
+ econf || die
+ emake || die
+}
+
+src_install() {
+ make install DESTDIR=${D} || die
+}
diff --git a/dev-tex/cpp2latex/files/cpp2latex-2.3.patch b/dev-tex/cpp2latex/files/cpp2latex-2.3.patch
new file mode 100644
index 000000000000..676b5ef3136c
--- /dev/null
+++ b/dev-tex/cpp2latex/files/cpp2latex-2.3.patch
@@ -0,0 +1,44 @@
+--- main.cpp Thu Mar 6 08:15:36 2003
++++ main.cpp Tue Jan 24 21:47:17 2006
+@@ -27,12 +27,14 @@
+ #include <stdio.h>
+ #include <getopt.h>
+
++using namespace std;
++
+ struct replace{
+ std::string voraus;
+ std::string ersetzt;
+ };
+
+-std::vector <replace> rules;
++std::vector<struct replace> rules;
+ std::string syntax( std::ifstream *src, char *c );
+ void initReplace();
+ bool satzzeichen( char c );
+@@ -162,9 +164,13 @@
+ if( comment && !comment1 )
+ {
+ file.get(c);
+- if(c=='/') { out+="/}"; comment=false; }
+- else { if(c=='\n') out+="\\\\"; }
+- if( !( (c=='*')||(c=='/') )) out+=c;
++ if(c=='/') {
++ out+="/}";
++ comment=false;
++ } else if (c=='\n') out+="\\\\";
++ /* .alex. 1 line substitution*/
++ else file.seekg(-1,ios::cur);
++ //if( !( (c=='*')||(c=='/') )) out+=c;
+ }
+ break;
+
+@@ -323,7 +329,7 @@
+ /** initialize the replacementrules */
+ void initReplace()
+ {
+-replace dummy;
++ struct replace dummy;
+ dummy.voraus = "and"; dummy.ersetzt = "\\textbf{and}"; rules.push_back(dummy);
+ dummy.voraus = "and_eq"; dummy.ersetzt = "\\textbf{and\\underline\\ eq}"; rules.push_back(dummy);
+ dummy.voraus = "asm"; dummy.ersetzt = "\\textbf{asm}"; rules.push_back(dummy);
diff --git a/dev-tex/cpp2latex/files/digest-cpp2latex-2.3-r1 b/dev-tex/cpp2latex/files/digest-cpp2latex-2.3-r1
new file mode 100644
index 000000000000..b7bdedaa6a38
--- /dev/null
+++ b/dev-tex/cpp2latex/files/digest-cpp2latex-2.3-r1
@@ -0,0 +1 @@
+MD5 bfe67773548df87c3e0975591f835c74 cpp2latex-2.3.tar.gz 483213