summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2004-08-07 01:46:36 +0000
committerDoug Goldstein <cardoe@gentoo.org>2004-08-07 01:46:36 +0000
commit9fd4e6abecb4bbeb1e5654e0aa852722aa3155ba (patch)
tree127b7e0145cd0cd64014a9691820a4c8e6687114 /dev-tcltk
parentBump genpatches to 7.44 from g-d-s -r12, this fixes a security issue (#59378)... (diff)
downloadhistorical-9fd4e6abecb4bbeb1e5654e0aa852722aa3155ba.tar.gz
historical-9fd4e6abecb4bbeb1e5654e0aa852722aa3155ba.tar.bz2
historical-9fd4e6abecb4bbeb1e5654e0aa852722aa3155ba.zip
Adding mmucl ebuild
Diffstat (limited to 'dev-tcltk')
-rw-r--r--dev-tcltk/mmucl/ChangeLog7
-rw-r--r--dev-tcltk/mmucl/Manifest4
-rw-r--r--dev-tcltk/mmucl/files/digest-mmucl-1.5.21
-rw-r--r--dev-tcltk/mmucl/metadata.xml9
-rw-r--r--dev-tcltk/mmucl/mmucl-1.5.2.ebuild57
5 files changed, 78 insertions, 0 deletions
diff --git a/dev-tcltk/mmucl/ChangeLog b/dev-tcltk/mmucl/ChangeLog
new file mode 100644
index 000000000000..1c6bccddf017
--- /dev/null
+++ b/dev-tcltk/mmucl/ChangeLog
@@ -0,0 +1,7 @@
+# ChangeLog for dev-tcltk/mmucl
+# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/mmucl/ChangeLog,v 1.1 2004/08/07 01:46:36 cardoe Exp $
+
+ 06 Aug 2004; Doug Goldstein <cardoe@gentoo.org>, mmucl-1.5.2.ebuild, files/digest-mmucl-1.5.2, ChangeLog :
+ Ebuild for new app submitted by Niklas Bolander <niklas.bolander@telia.com>
+
diff --git a/dev-tcltk/mmucl/Manifest b/dev-tcltk/mmucl/Manifest
new file mode 100644
index 000000000000..237070404925
--- /dev/null
+++ b/dev-tcltk/mmucl/Manifest
@@ -0,0 +1,4 @@
+MD5 b54a2a90e9d8a8d1588af2837a38dc92 metadata.xml 280
+MD5 5b2412dfcca20c5016bff30ea07cd505 ChangeLog 391
+MD5 5d3e34446e0cb3879a64e7640a774b42 mmucl-1.5.2.ebuild 1790
+MD5 53208ee117dc046fb612441ba0ee3ece files/digest-mmucl-1.5.2 63
diff --git a/dev-tcltk/mmucl/files/digest-mmucl-1.5.2 b/dev-tcltk/mmucl/files/digest-mmucl-1.5.2
new file mode 100644
index 000000000000..465a9e6550b8
--- /dev/null
+++ b/dev-tcltk/mmucl/files/digest-mmucl-1.5.2
@@ -0,0 +1 @@
+MD5 d38ad0b1a51325dada8ac6b1b15113e2 mmucl-1.5.2.tar.gz 144697
diff --git a/dev-tcltk/mmucl/metadata.xml b/dev-tcltk/mmucl/metadata.xml
new file mode 100644
index 000000000000..9a9af528d4a7
--- /dev/null
+++ b/dev-tcltk/mmucl/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>tcltk</herd>
+<maintainer>
+ <email>tcltk@gentoo.org</email>
+</maintainer>
+<longdescription>Mmucl - Mark's MUd CLient</longdescription>
+</pkgmetadata>
diff --git a/dev-tcltk/mmucl/mmucl-1.5.2.ebuild b/dev-tcltk/mmucl/mmucl-1.5.2.ebuild
new file mode 100644
index 000000000000..39a933dcb2bb
--- /dev/null
+++ b/dev-tcltk/mmucl/mmucl-1.5.2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/mmucl/mmucl-1.5.2.ebuild,v 1.1 2004/08/07 01:46:36 cardoe Exp $
+
+inherit games
+
+DESCRIPTION="Marks Mud CLient - A mud client written completly in tcl/tk"
+HOMEPAGE="http://mmucl.sourceforge.net"
+SRC_URI="mirror://sourceforge/mmucl/${P}.tar.gz"
+
+KEYWORDS="~x86"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="readline"
+
+RDEPEND=">=dev-lang/tk-8.4
+ readline? ( dev-tcltk/tclreadline )"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
+
+src_unpack() {
+ unpack ${A}
+
+ sed -i \
+ -e "/^BASE_DIR/ s:=.*:=/usr:" \
+ -e "/^BIN_DIR/ s:=.*:=${GAMES_BINDIR}:" \
+ -e "/^LIB_DIR/ s:=.*:=${GAMES_LIBDIR}/${PN}:" \
+ -e "" "${S}/Makefile" \
+ || die "sed Makefile failed"
+}
+
+src_install () {
+ local LIBDIR="${GAMES_LIBDIR}/${PN}"
+
+ dogamesbin mmucl2 || die "dogamesbin failed"
+ insinto ${LIBDIR}/lib
+ doins lib/*.tcl || die "doins failed (lib)"
+ insinto ${LIBDIR}/images
+ doins images/*.gif || die "doins failed (images)"
+ insinto ${LIBDIR}/interface
+ doins interface/*.tcl || die "doins failed (interface)"
+ insinto ${LIBDIR}/script
+ doins script/*.{tcl,rc} || die "doins failed (script)"
+ insinto ${LIBDIR}/script/contrib
+ doins script/contrib/* || die "doins failed (contrib)"
+ insinto ${LIBDIR}/test
+ doins test/*.test || die "doins failed (test)"
+ doinfo mmucl.info || die "doinfo failed"
+ dodoc CHANGES TODO INSTALL README || die "dodoc failed"
+ dohtml mmucl.html || die "dohtml failed"
+ prepgamesdirs
+}
+pkg_postinst() {
+ einfo "You must be in the 'games' group to run this application."
+ einfo "The executable for this is mmucl2."
+}
+