summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-06-06 06:12:20 +0000
committerHans de Graaff <graaff@gentoo.org>2012-06-06 06:12:20 +0000
commit94aeb84ea7796f6ba6a7829b8e79214c9d548618 (patch)
tree58e6f3da8b50403eaa6f85367e79b0e407a3ed0e /dev-ruby
parentRemove old versions. (diff)
downloadhistorical-94aeb84ea7796f6ba6a7829b8e79214c9d548618.tar.gz
historical-94aeb84ea7796f6ba6a7829b8e79214c9d548618.tar.bz2
historical-94aeb84ea7796f6ba6a7829b8e79214c9d548618.zip
Version bump.
Package-Manager: portage-2.1.10.49/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/selenium-webdriver/ChangeLog8
-rw-r--r--dev-ruby/selenium-webdriver/selenium-webdriver-2.22.1.ebuild40
-rw-r--r--dev-ruby/serialport/ChangeLog7
-rw-r--r--dev-ruby/serialport/serialport-1.1.0.ebuild50
4 files changed, 103 insertions, 2 deletions
diff --git a/dev-ruby/selenium-webdriver/ChangeLog b/dev-ruby/selenium-webdriver/ChangeLog
index e035f41dcb2e..97d65b8920ec 100644
--- a/dev-ruby/selenium-webdriver/ChangeLog
+++ b/dev-ruby/selenium-webdriver/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/selenium-webdriver
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/selenium-webdriver/ChangeLog,v 1.29 2012/06/06 06:06:12 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/selenium-webdriver/ChangeLog,v 1.30 2012/06/06 06:09:25 graaff Exp $
+
+*selenium-webdriver-2.22.1 (06 Jun 2012)
+
+ 06 Jun 2012; Hans de Graaff <graaff@gentoo.org>
+ +selenium-webdriver-2.22.1.ebuild:
+ Version bump.
06 Jun 2012; Hans de Graaff <graaff@gentoo.org>
-selenium-webdriver-2.16.0.ebuild, -selenium-webdriver-2.18.0.ebuild,
diff --git a/dev-ruby/selenium-webdriver/selenium-webdriver-2.22.1.ebuild b/dev-ruby/selenium-webdriver/selenium-webdriver-2.22.1.ebuild
new file mode 100644
index 000000000000..e15fed22d8ca
--- /dev/null
+++ b/dev-ruby/selenium-webdriver/selenium-webdriver-2.22.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/selenium-webdriver/selenium-webdriver-2.22.1.ebuild,v 1.1 2012/06/06 06:09:25 graaff Exp $
+
+EAPI=4
+USE_RUBY="ruby18 ruby19 ree18"
+
+# NOTE: this package contains precompiled code. It appears that all
+# source code can be found at http://code.google.com/p/selenium/ but the
+# repository is not organized in a way so that we can easily rebuild the
+# suited shared object. We'll just try our luck with the precompiled
+# objects for now.
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGES README"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_QA_ALLOWED_LIBS="x_ignore_nofocus.so"
+
+inherit ruby-fakegem
+
+DESCRIPTION="This gem provides Ruby bindings for WebDriver."
+HOMEPAGE="http://gemcutter.org/gems/selenium-webdriver"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/childprocess-0.2.5
+ >=dev-ruby/ffi-1.0.9
+ >=dev-ruby/multi_json-1.0.4
+ dev-ruby/rubyzip"
+
+all_ruby_prepare() {
+ # Make websocket a development dependency since it is only needed
+ # for the safari driver which we don't support on Gentoo.
+ sed -i -e '/libwebsocket/,/version_requirements/ s/runtime/development/' ../metadata || die
+}
diff --git a/dev-ruby/serialport/ChangeLog b/dev-ruby/serialport/ChangeLog
index f63dd0261037..885d4821d431 100644
--- a/dev-ruby/serialport/ChangeLog
+++ b/dev-ruby/serialport/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/serialport
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/serialport/ChangeLog,v 1.2 2012/05/01 18:24:16 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/serialport/ChangeLog,v 1.3 2012/06/06 06:12:20 graaff Exp $
+
+*serialport-1.1.0 (06 Jun 2012)
+
+ 06 Jun 2012; Hans de Graaff <graaff@gentoo.org> +serialport-1.1.0.ebuild:
+ Version bump.
01 May 2012; Raúl Porcel <armin76@gentoo.org> serialport-1.0.3.ebuild,
serialport-1.0.4.ebuild:
diff --git a/dev-ruby/serialport/serialport-1.1.0.ebuild b/dev-ruby/serialport/serialport-1.1.0.ebuild
new file mode 100644
index 000000000000..2f33feaaef8f
--- /dev/null
+++ b/dev-ruby/serialport/serialport-1.1.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/serialport/serialport-1.1.0.ebuild,v 1.1 2012/06/06 06:12:20 graaff Exp $
+
+EAPI="2"
+
+# jruby → uses native library
+USE_RUBY="ruby18 ruby19 ree18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README"
+
+inherit ruby-fakegem
+
+DESCRIPTION="a library for serial port (rs232) access in ruby"
+HOMEPAGE="http://rubyforge.org/projects/ruby-serialport/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+IUSE=""
+
+all_ruby_prepare() {
+ # Fix the miniterm script so that it might actually work, we'll
+ # install it as example.
+ sed -i -e 's:\.\./serialport.so:serialport:' test/miniterm.rb || die
+}
+
+each_ruby_configure() {
+ cd ext/native
+ ${RUBY} extconf.rb || die
+}
+
+each_ruby_compile() {
+ pushd ext/native &>/dev/null
+ emake || die
+ popd &>/dev/null
+
+ # Avoids the need for a specific install phase
+ cp ext/native/*.so lib/ || die "extension copy failed"
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ # don't compress it
+ insinto /usr/share/doc/${PF}/examples
+ doins test/miniterm.rb || die
+}