summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-04-20 07:19:48 +0000
committerHans de Graaff <graaff@gentoo.org>2012-04-20 07:19:48 +0000
commit4a71bda4981e94f0a25bb554e1aea688e7dec684 (patch)
tree9243bf21b94d92aa4e96c0f3c314f67c5690e605 /dev-ruby
parentVersion bump, fixes various bugs and crashes. (diff)
downloadhistorical-4a71bda4981e94f0a25bb554e1aea688e7dec684.tar.gz
historical-4a71bda4981e94f0a25bb554e1aea688e7dec684.tar.bz2
historical-4a71bda4981e94f0a25bb554e1aea688e7dec684.zip
Version bump.
Package-Manager: portage-2.1.10.49/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/activemodel/ChangeLog7
-rw-r--r--dev-ruby/activemodel/activemodel-3.2.3.ebuild42
-rw-r--r--dev-ruby/activeresource/ChangeLog7
-rw-r--r--dev-ruby/activeresource/activeresource-3.2.3.ebuild41
-rw-r--r--dev-ruby/activesupport/ChangeLog7
-rw-r--r--dev-ruby/activesupport/activesupport-3.2.3.ebuild53
6 files changed, 154 insertions, 3 deletions
diff --git a/dev-ruby/activemodel/ChangeLog b/dev-ruby/activemodel/ChangeLog
index 63ee421d72d9..5576795b7917 100644
--- a/dev-ruby/activemodel/ChangeLog
+++ b/dev-ruby/activemodel/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/activemodel
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activemodel/ChangeLog,v 1.24 2012/04/04 11:43:14 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activemodel/ChangeLog,v 1.25 2012/04/20 07:18:36 graaff Exp $
+
+*activemodel-3.2.3 (20 Apr 2012)
+
+ 20 Apr 2012; Hans de Graaff <graaff@gentoo.org> +activemodel-3.2.3.ebuild:
+ Version bump.
*activemodel-3.1.4 (04 Apr 2012)
diff --git a/dev-ruby/activemodel/activemodel-3.2.3.ebuild b/dev-ruby/activemodel/activemodel-3.2.3.ebuild
new file mode 100644
index 000000000000..307e94a7e992
--- /dev/null
+++ b/dev-ruby/activemodel/activemodel-3.2.3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activemodel/activemodel-3.2.3.ebuild,v 1.1 2012/04/20 07:18:36 graaff Exp $
+
+EAPI=4
+
+USE_RUBY="ruby18 ruby19 ree18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activemodel.gemspec"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="A toolkit for building modeling frameworks like Active Record and Active Resource."
+HOMEPAGE="http://github.com/rails/rails"
+SRC_URI="http://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_S="rails-rails-*/activemodel"
+
+ruby_add_rdepend "
+ ~dev-ruby/activesupport-${PV}
+ >=dev-ruby/builder-3.0.0
+ >=dev-ruby/bcrypt-ruby-3.0.0"
+
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/mocha-0.9.5
+ )"
+
+all_ruby_prepare() {
+ # Set test environment to our hand.
+ rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/load_paths/d' test/cases/helper.rb || die "Unable to remove load paths"
+}
diff --git a/dev-ruby/activeresource/ChangeLog b/dev-ruby/activeresource/ChangeLog
index 56b850fb8b94..3db272d9f514 100644
--- a/dev-ruby/activeresource/ChangeLog
+++ b/dev-ruby/activeresource/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/activeresource
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activeresource/ChangeLog,v 1.106 2012/04/04 11:44:25 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activeresource/ChangeLog,v 1.107 2012/04/20 07:19:48 graaff Exp $
+
+*activeresource-3.2.3 (20 Apr 2012)
+
+ 20 Apr 2012; Hans de Graaff <graaff@gentoo.org> +activeresource-3.2.3.ebuild:
+ Version bump.
*activeresource-3.1.4 (04 Apr 2012)
diff --git a/dev-ruby/activeresource/activeresource-3.2.3.ebuild b/dev-ruby/activeresource/activeresource-3.2.3.ebuild
new file mode 100644
index 000000000000..9a1c5e356707
--- /dev/null
+++ b/dev-ruby/activeresource/activeresource-3.2.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activeresource/activeresource-3.2.3.ebuild,v 1.1 2012/04/20 07:19:48 graaff Exp $
+
+EAPI=4
+
+USE_RUBY="ruby18 ruby19 ree18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activeresource.gemspec"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Think Active Record for web resources.."
+HOMEPAGE="http://rubyforge.org/projects/activeresource/"
+SRC_URI="http://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_S="rails-rails-*/activeresource"
+
+ruby_add_rdepend "~dev-ruby/activesupport-${PV}
+ ~dev-ruby/activemodel-${PV}"
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/mocha-0.9.5
+ virtual/ruby-test-unit
+ )"
+
+all_ruby_prepare() {
+ # Set test environment to our hand.
+ rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/load_paths/d' test/abstract_unit.rb || die "Unable to remove load paths"
+
+}
diff --git a/dev-ruby/activesupport/ChangeLog b/dev-ruby/activesupport/ChangeLog
index 1b903b29c163..6512e946b607 100644
--- a/dev-ruby/activesupport/ChangeLog
+++ b/dev-ruby/activesupport/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/activesupport
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/ChangeLog,v 1.167 2012/04/04 11:41:13 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/ChangeLog,v 1.168 2012/04/20 07:17:34 graaff Exp $
+
+*activesupport-3.2.3 (20 Apr 2012)
+
+ 20 Apr 2012; Hans de Graaff <graaff@gentoo.org> +activesupport-3.2.3.ebuild:
+ Version bump.
*activesupport-3.1.4 (04 Apr 2012)
diff --git a/dev-ruby/activesupport/activesupport-3.2.3.ebuild b/dev-ruby/activesupport/activesupport-3.2.3.ebuild
new file mode 100644
index 000000000000..2fdab2fa3a04
--- /dev/null
+++ b/dev-ruby/activesupport/activesupport-3.2.3.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/activesupport-3.2.3.ebuild,v 1.1 2012/04/20 07:17:34 graaff Exp $
+
+EAPI=4
+
+# jruby fails tests.
+USE_RUBY="ruby18 ree18 ruby19"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activesupport.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Utility Classes and Extension to the Standard Library"
+HOMEPAGE="http://rubyforge.org/projects/activesupport/"
+SRC_URI="https://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_S="rails-rails-*/${PN}"
+
+ruby_add_rdepend ">=dev-ruby/memcache-client-1.5.8
+ >=dev-ruby/multi_json-1.0
+ dev-ruby/i18n:0.6
+ !!<dev-ruby/activesupport-3.0.11-r1:3.0"
+
+# libxml-ruby, nokogiri, and builder are not strictly needed, but there
+# are tests using this code.
+ruby_add_bdepend "test? (
+ virtual/ruby-test-unit
+ >=dev-ruby/libxml-2.0.0
+ dev-ruby/nokogiri
+ dev-ruby/builder:0
+ )"
+
+all_ruby_prepare() {
+ # don't support older mocha versions as the optional codepath
+ # breaks JRuby
+ epatch "${FILESDIR}"/${PN}-3.0.3-mocha-0.9.5.patch
+
+ # Set test environment to our hand.
+# rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/load_paths/d' test/abstract_unit.rb || die "Unable to remove load paths"
+}