summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-10-24 09:30:25 +0000
committerHans de Graaff <graaff@gentoo.org>2010-10-24 09:30:25 +0000
commit69e4182e5b4e1c21654c536511d1dca130541c41 (patch)
treec2ff34e9543a00b235aae113372d1d9438ea1bcb /dev-ruby/rev
parentInitial import, dependency of dev-ruby/rev. (diff)
downloadhistorical-69e4182e5b4e1c21654c536511d1dca130541c41.tar.gz
historical-69e4182e5b4e1c21654c536511d1dca130541c41.tar.bz2
historical-69e4182e5b4e1c21654c536511d1dca130541c41.zip
Initial import. Miscompiles with --no-undefined so people won't be able to install the gem directly.
Package-Manager: portage-2.1.8.3/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby/rev')
-rw-r--r--dev-ruby/rev/ChangeLog11
-rw-r--r--dev-ruby/rev/metadata.xml5
-rw-r--r--dev-ruby/rev/rev-0.3.2.ebuild53
3 files changed, 69 insertions, 0 deletions
diff --git a/dev-ruby/rev/ChangeLog b/dev-ruby/rev/ChangeLog
new file mode 100644
index 000000000000..80aa2057235b
--- /dev/null
+++ b/dev-ruby/rev/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-ruby/rev
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rev/ChangeLog,v 1.1 2010/10/24 09:30:25 graaff Exp $
+
+*rev-0.3.2 (24 Oct 2010)
+
+ 24 Oct 2010; Hans de Graaff <graaff@gentoo.org> +rev-0.3.2.ebuild,
+ +metadata.xml:
+ Initial import. Miscompiles with --no-undefined so people won't be able to
+ install the gem directly.
+
diff --git a/dev-ruby/rev/metadata.xml b/dev-ruby/rev/metadata.xml
new file mode 100644
index 000000000000..852136183369
--- /dev/null
+++ b/dev-ruby/rev/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ruby</herd>
+</pkgmetadata>
diff --git a/dev-ruby/rev/rev-0.3.2.ebuild b/dev-ruby/rev/rev-0.3.2.ebuild
new file mode 100644
index 000000000000..bfa7fff348bd
--- /dev/null
+++ b/dev-ruby/rev/rev-0.3.2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rev/rev-0.3.2.ebuild,v 1.1 2010/10/24 09:30:25 graaff Exp $
+
+EAPI="2"
+USE_RUBY="ruby18 ree18"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGES README.textile"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Rev is an event library for Ruby, built on the libev event library."
+HOMEPAGE="http://mynyml.com/ruby/flexible-continuous-testing"
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/iobuffer-0.1.0"
+
+each_ruby_configure() {
+ ${RUBY} -C ext/rev extconf.rb || die "Unable to configure rev extionsion."
+
+ ${RUBY} -C ext/http11_client extconf.rb || die "Unable to configure http11 extension."
+}
+
+each_ruby_compile() {
+ # We have injected --no-undefined in Ruby as a safety precaution
+ # against broken ebuilds, but these bindings unfortunately rely on
+ # the lazy load of other extensions; see bug #320545.
+ find ext/rev -name Makefile -print0 | xargs -0 \
+ sed -i -e 's:-Wl,--no-undefined::' || die "--no-undefined removal failed"
+ emake -C ext/rev || die "Unable to compile rev extension."
+
+ emake -C ext/http11_client || die "Unable to compile http11 extension."
+}
+
+each_ruby_install() {
+ cp ext/rev/rev_ext.so lib
+ cp ext/http11_client/http11_client.so lib
+
+ each_fakegem_install
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/* || die "Unable to install examples."
+}