summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-09-28 17:51:28 +0000
committerHans de Graaff <graaff@gentoo.org>2011-09-28 17:51:28 +0000
commite69595df3ba25a83023a2a753982793c8ac6c4fb (patch)
tree255e97c312932427268fe5f8efcd6b52c63870ff /dev-ruby/locale
parentRemove old version. (diff)
downloadhistorical-e69595df3ba25a83023a2a753982793c8ac6c4fb.tar.gz
historical-e69595df3ba25a83023a2a753982793c8ac6c4fb.tar.bz2
historical-e69595df3ba25a83023a2a753982793c8ac6c4fb.zip
Revision bump to create stable candidate.
Package-Manager: portage-2.1.10.11/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby/locale')
-rw-r--r--dev-ruby/locale/ChangeLog8
-rw-r--r--dev-ruby/locale/locale-2.0.5-r2.ebuild4
-rw-r--r--dev-ruby/locale/locale-2.0.5-r3.ebuild46
3 files changed, 55 insertions, 3 deletions
diff --git a/dev-ruby/locale/ChangeLog b/dev-ruby/locale/ChangeLog
index 524330e711be..07fe4fb4a298 100644
--- a/dev-ruby/locale/ChangeLog
+++ b/dev-ruby/locale/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/locale
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/locale/ChangeLog,v 1.25 2011/09/28 17:46:34 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/locale/ChangeLog,v 1.26 2011/09/28 17:48:24 graaff Exp $
+
+*locale-2.0.5-r3 (28 Sep 2011)
+
+ 28 Sep 2011; Hans de Graaff <graaff@gentoo.org> locale-2.0.5-r2.ebuild,
+ +locale-2.0.5-r3.ebuild:
+ Revision bump to create stable candidate.
28 Sep 2011; Hans de Graaff <graaff@gentoo.org> -locale-2.0.5-r1.ebuild:
Remove old version.
diff --git a/dev-ruby/locale/locale-2.0.5-r2.ebuild b/dev-ruby/locale/locale-2.0.5-r2.ebuild
index b3729db727c6..eeaf0d34c0d0 100644
--- a/dev-ruby/locale/locale-2.0.5-r2.ebuild
+++ b/dev-ruby/locale/locale-2.0.5-r2.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/locale/locale-2.0.5-r2.ebuild,v 1.2 2011/07/20 10:04:23 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/locale/locale-2.0.5-r2.ebuild,v 1.3 2011/09/28 17:48:24 graaff Exp $
EAPI=2
-USE_RUBY="ruby18 ruby19 jruby ree18"
+USE_RUBY="ruby18 jruby ree18"
RUBY_FAKEGEM_TASK_DOC="rerdoc"
RUBY_FAKEGEM_DOCDIR="doc"
diff --git a/dev-ruby/locale/locale-2.0.5-r3.ebuild b/dev-ruby/locale/locale-2.0.5-r3.ebuild
new file mode 100644
index 000000000000..56b65f05a49c
--- /dev/null
+++ b/dev-ruby/locale/locale-2.0.5-r3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/locale/locale-2.0.5-r3.ebuild,v 1.1 2011/09/28 17:48:24 graaff Exp $
+
+EAPI=2
+
+USE_RUBY="ruby18 ruby19 jruby ree18"
+
+RUBY_FAKEGEM_TASK_DOC="rerdoc"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="ChangeLog README.rdoc"
+
+RUBY_FAKEGEM_TASK_TEST="test"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A pure ruby library which provides basic APIs for localization."
+HOMEPAGE="http://locale.rubyforge.org/"
+LICENSE="|| ( Ruby GPL-2 )"
+
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-macos"
+SLOT="0"
+IUSE=""
+
+ruby_add_bdepend "test? ( || ( virtual/ruby-test-unit dev-ruby/test-unit:2 ) )"
+
+RUBY_PATCHES=( "${FILESDIR}/${PN}-language-fixes.patch" )
+
+each_ruby_prepare() {
+ case ${RUBY} in
+ *jruby)
+ # Remove broken test. It's not clear if the test or code is
+ # broken... https://github.com/mutoh/locale/issues/2
+ rm test/test_detect_general.rb || die
+ ;;
+ *)
+ ;;
+ esac
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ insinto /usr/share/doc/${PF}
+ doins -r samples || die
+}