summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-01-13 04:19:42 +0000
committerIan Delaney <idella4@gentoo.org>2013-01-13 04:19:42 +0000
commit6271b9f9b425619b32c455955163e32137a23d77 (patch)
tree6ef7916e00515293cca81243c8fd6fb8f3716936 /dev-python/socketpool/socketpool-0.5.2.ebuild
parentadding arm keyword (diff)
downloadhistorical-6271b9f9b425619b32c455955163e32137a23d77.tar.gz
historical-6271b9f9b425619b32c455955163e32137a23d77.tar.bz2
historical-6271b9f9b425619b32c455955163e32137a23d77.zip
migrated to distutils-r1, added test phase, its 1 test fails making for Bug #451610
Package-Manager: portage-2.1.11.30/cvs/Linux x86_64 Manifest-Sign-Key: 0xB8072B0D
Diffstat (limited to 'dev-python/socketpool/socketpool-0.5.2.ebuild')
-rw-r--r--dev-python/socketpool/socketpool-0.5.2.ebuild23
1 files changed, 13 insertions, 10 deletions
diff --git a/dev-python/socketpool/socketpool-0.5.2.ebuild b/dev-python/socketpool/socketpool-0.5.2.ebuild
index b0ed9939840d..75ffabc21c82 100644
--- a/dev-python/socketpool/socketpool-0.5.2.ebuild
+++ b/dev-python/socketpool/socketpool-0.5.2.ebuild
@@ -1,31 +1,34 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/socketpool/socketpool-0.5.2.ebuild,v 1.1 2012/11/16 02:39:07 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/socketpool/socketpool-0.5.2.ebuild,v 1.2 2013/01/13 04:19:18 idella4 Exp $
-EAPI=4
-PYTHON_DEPEND="2:2.6"
-SUPPORT_PYTHON_ABIS=1
-RESTRICT_PYTHON_ABIS="2.5 3.*"
-inherit distutils
+EAPI=5
+PYTHON_COMPAT=( python2_6 python2_7 pypy{1_9,2_0} )
+
+inherit distutils-r1
DESCRIPTION="A simple Python socket pool"
HOMEPAGE="http://github.com/benoitc/socketpool/"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-KEYWORDS="~amd64"
+KEYWORDS="~amd64 ~x86"
IUSE="examples"
LICENSE="MIT"
SLOT="0"
RDEPEND="dev-python/gevent"
DEPEND="${RDEPEND}
- dev-python/setuptools"
+ dev-python/setuptools[${PYTHON_USEDEP}]"
src_install() {
- distutils_src_install
+ distutils-r1_src_install
if use examples; then
docompress -x usr/share/doc/${P}/examples
insinto usr/share/doc/${P}
doins -r examples/
fi
}
+src_test() {
+ PYTHONPATH=. py.test tests/test_pool_01.py
+}
+