summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris PeBenito <pebenito@gentoo.org>2003-12-07 00:59:52 +0000
committerChris PeBenito <pebenito@gentoo.org>2003-12-07 00:59:52 +0000
commitf4cd31e5ca74b4363b02e6af0d01634c23e1fe5c (patch)
tree69e0c8453c3d954436a75fb27f1024e2ad05c248 /dev-python/python-selinux
parentmoved from app-misc to x11-misc, metadata.xml created (diff)
downloadhistorical-f4cd31e5ca74b4363b02e6af0d01634c23e1fe5c.tar.gz
historical-f4cd31e5ca74b4363b02e6af0d01634c23e1fe5c.tar.bz2
historical-f4cd31e5ca74b4363b02e6af0d01634c23e1fe5c.zip
add python eclass usage
Diffstat (limited to 'dev-python/python-selinux')
-rw-r--r--dev-python/python-selinux/ChangeLog5
-rw-r--r--dev-python/python-selinux/Manifest4
-rw-r--r--dev-python/python-selinux/python-selinux-2.10.ebuild9
3 files changed, 11 insertions, 7 deletions
diff --git a/dev-python/python-selinux/ChangeLog b/dev-python/python-selinux/ChangeLog
index 4104ed4d2112..fde498a9c94b 100644
--- a/dev-python/python-selinux/ChangeLog
+++ b/dev-python/python-selinux/ChangeLog
@@ -1,10 +1,11 @@
# ChangeLog for dev-python/python-selinux
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-selinux/ChangeLog,v 1.13 2003/12/06 23:44:01 pebenito Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-selinux/ChangeLog,v 1.14 2003/12/07 00:59:49 pebenito Exp $
06 Dec 2003; Chris PeBenito <pebenito@gentoo.org>
python-selinux-2.10.ebuild:
- Add missing python DEP.
+ Add missing python DEP. Fix to use python eclass, to work with different
+ versions of python.
*python-selinux-2.10 (20 Nov 2003)
diff --git a/dev-python/python-selinux/Manifest b/dev-python/python-selinux/Manifest
index cb7d16ce9b0b..2265e9345ba2 100644
--- a/dev-python/python-selinux/Manifest
+++ b/dev-python/python-selinux/Manifest
@@ -1,5 +1,5 @@
-MD5 1c5ab0ef01568cbf783e23fd3581d035 ChangeLog 2470
+MD5 40499ee5719c9c973c2394b49bc4dfa1 ChangeLog 2541
MD5 c998c579cfc08c6860f78304a67cfce9 metadata.xml 525
-MD5 80a6e6b843598c36ec171d9ba60b5e21 python-selinux-2.10.ebuild 807
+MD5 3c4912511a7e2207b5341e7e85187f47 python-selinux-2.10.ebuild 848
MD5 d41d8cd98f00b204e9800998ecf8427e files/digest-python-selinux-2.10 0
MD5 7917bf5ac68090fb6fcfe784a4807463 files/python-selinux-2.10.c.bz2 5624
diff --git a/dev-python/python-selinux/python-selinux-2.10.ebuild b/dev-python/python-selinux/python-selinux-2.10.ebuild
index a9a7e5982220..1c442c6632aa 100644
--- a/dev-python/python-selinux/python-selinux-2.10.ebuild
+++ b/dev-python/python-selinux/python-selinux-2.10.ebuild
@@ -1,6 +1,9 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-selinux/python-selinux-2.10.ebuild,v 1.2 2003/12/06 23:44:01 pebenito Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-selinux/python-selinux-2.10.ebuild,v 1.3 2003/12/07 00:59:49 pebenito Exp $
+
+inherit python
+python_version
DESCRIPTION="Python bindings for SELinux functions"
HOMEPAGE="http://www.gentoo.org/proj/en/hardened/selinux/"
@@ -24,10 +27,10 @@ src_unpack() {
src_compile() {
cd ${S}
einfo "Compiling selinux.so"
- gcc -fPIC -shared -o selinux.so -I /usr/include/python2.2/ selinux.c -lselinux || die
+ gcc -fPIC -shared -o selinux.so -I /usr/include/python${PYVER}/ selinux.c -lselinux || die
}
src_install() {
- insinto /usr/lib/python2.2/site-packages
+ insinto /usr/lib/python${PYVER}/site-packages
doins selinux.so
}