summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-09-27 18:39:53 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-09-27 18:39:53 +0000
commitcb1515d4f17d52dd37afa9c00627c4a8d14df413 (patch)
tree1a3ff635f1417abb0977c47e347553ebf3c5b75c /dev-python/python-docs
parentppc stable #284835 (diff)
downloadhistorical-cb1515d4f17d52dd37afa9c00627c4a8d14df413.tar.gz
historical-cb1515d4f17d52dd37afa9c00627c4a8d14df413.tar.bz2
historical-cb1515d4f17d52dd37afa9c00627c4a8d14df413.zip
Synchronize code with dev-lang/python.
Package-Manager: portage-14444-svn/cvs/Linux x86_64
Diffstat (limited to 'dev-python/python-docs')
-rw-r--r--dev-python/python-docs/python-docs-2.4.4-r1.ebuild16
-rw-r--r--dev-python/python-docs/python-docs-2.5.4-r1.ebuild16
-rw-r--r--dev-python/python-docs/python-docs-2.6.2-r1.ebuild16
-rw-r--r--dev-python/python-docs/python-docs-3.1.1.ebuild17
4 files changed, 52 insertions, 13 deletions
diff --git a/dev-python/python-docs/python-docs-2.4.4-r1.ebuild b/dev-python/python-docs/python-docs-2.4.4-r1.ebuild
index 304efdd27e92..6055a38d6c5f 100644
--- a/dev-python/python-docs/python-docs-2.4.4-r1.ebuild
+++ b/dev-python/python-docs/python-docs-2.4.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-docs/python-docs-2.4.4-r1.ebuild,v 1.3 2009/08/24 01:54:57 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-docs/python-docs-2.4.4-r1.ebuild,v 1.4 2009/09/27 18:39:53 arfrever Exp $
DESCRIPTION="HTML documentation for Python"
HOMEPAGE="http://www.python.org/doc/"
@@ -36,12 +36,22 @@ src_install() {
doenvd "60python-docs-${SLOT}"
}
+eselect_python_update() {
+ local ignored_python_slots
+ [[ "$(eselect python show)" == "python2."* ]] && ignored_python_slots="--ignore 3.0 --ignore 3.1 --ignore 3.2"
+
+ # Create python2 symlink.
+ eselect python update --ignore 3.0 --ignore 3.1 --ignore 3.2 > /dev/null
+
+ eselect python update ${ignored_python_slots}
+}
+
pkg_postinst() {
- eselect python update --ignore 3.0 --ignore 3.1 --ignore 3.2
+ eselect_python_update
}
pkg_postrm() {
- eselect python update --ignore 3.0 --ignore 3.1 --ignore 3.2
+ eselect_python_update
if ! has_version "<dev-python/python-docs-${SLOT}_alpha" && ! has_version ">=dev-python/python-docs-${SLOT%.*}.$((${SLOT#*.}+1))_alpha"; then
rm -f "${ROOT}etc/env.d/65python-docs"
diff --git a/dev-python/python-docs/python-docs-2.5.4-r1.ebuild b/dev-python/python-docs/python-docs-2.5.4-r1.ebuild
index 4cc00c68692f..de91f6f7b91a 100644
--- a/dev-python/python-docs/python-docs-2.5.4-r1.ebuild
+++ b/dev-python/python-docs/python-docs-2.5.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-docs/python-docs-2.5.4-r1.ebuild,v 1.3 2009/08/24 01:54:57 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-docs/python-docs-2.5.4-r1.ebuild,v 1.4 2009/09/27 18:39:53 arfrever Exp $
DESCRIPTION="HTML documentation for Python"
HOMEPAGE="http://www.python.org/doc/"
@@ -29,12 +29,22 @@ src_install() {
doenvd "60python-docs-${SLOT}"
}
+eselect_python_update() {
+ local ignored_python_slots
+ [[ "$(eselect python show)" == "python2."* ]] && ignored_python_slots="--ignore 3.0 --ignore 3.1 --ignore 3.2"
+
+ # Create python2 symlink.
+ eselect python update --ignore 3.0 --ignore 3.1 --ignore 3.2 > /dev/null
+
+ eselect python update ${ignored_python_slots}
+}
+
pkg_postinst() {
- eselect python update --ignore 3.0 --ignore 3.1 --ignore 3.2
+ eselect_python_update
}
pkg_postrm() {
- eselect python update --ignore 3.0 --ignore 3.1 --ignore 3.2
+ eselect_python_update
if ! has_version "<dev-python/python-docs-${SLOT}_alpha" && ! has_version ">=dev-python/python-docs-${SLOT%.*}.$((${SLOT#*.}+1))_alpha"; then
rm -f "${ROOT}etc/env.d/65python-docs"
diff --git a/dev-python/python-docs/python-docs-2.6.2-r1.ebuild b/dev-python/python-docs/python-docs-2.6.2-r1.ebuild
index be22354ddc86..a76cc0b35841 100644
--- a/dev-python/python-docs/python-docs-2.6.2-r1.ebuild
+++ b/dev-python/python-docs/python-docs-2.6.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-docs/python-docs-2.6.2-r1.ebuild,v 1.10 2009/09/27 14:28:56 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-docs/python-docs-2.6.2-r1.ebuild,v 1.11 2009/09/27 18:39:53 arfrever Exp $
DESCRIPTION="HTML documentation for Python"
HOMEPAGE="http://www.python.org/doc/"
@@ -24,12 +24,22 @@ src_install() {
doenvd "60python-docs-${SLOT}"
}
+eselect_python_update() {
+ local ignored_python_slots
+ [[ "$(eselect python show)" == "python2."* ]] && ignored_python_slots="--ignore 3.0 --ignore 3.1 --ignore 3.2"
+
+ # Create python2 symlink.
+ eselect python update --ignore 3.0 --ignore 3.1 --ignore 3.2 > /dev/null
+
+ eselect python update ${ignored_python_slots}
+}
+
pkg_postinst() {
- eselect python update --ignore 3.0 --ignore 3.1 --ignore 3.2
+ eselect_python_update
}
pkg_postrm() {
- eselect python update --ignore 3.0 --ignore 3.1 --ignore 3.2
+ eselect_python_update
if ! has_version "<dev-python/python-docs-${SLOT}_alpha" && ! has_version ">=dev-python/python-docs-${SLOT%.*}.$((${SLOT#*.}+1))_alpha"; then
rm -f "${ROOT}etc/env.d/65python-docs"
diff --git a/dev-python/python-docs/python-docs-3.1.1.ebuild b/dev-python/python-docs/python-docs-3.1.1.ebuild
index 849e74c11224..4b560a831db7 100644
--- a/dev-python/python-docs/python-docs-3.1.1.ebuild
+++ b/dev-python/python-docs/python-docs-3.1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-docs/python-docs-3.1.1.ebuild,v 1.1 2009/08/24 02:00:05 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-docs/python-docs-3.1.1.ebuild,v 1.2 2009/09/27 18:39:53 arfrever Exp $
DESCRIPTION="HTML documentation for Python"
HOMEPAGE="http://www.python.org/doc/"
@@ -24,13 +24,22 @@ src_install() {
doenvd "60python-docs-${SLOT}"
}
+eselect_python_update() {
+ local ignored_python_slots
+ [[ "$(eselect python show)" == "python2."* ]] && ignored_python_slots="--ignore 3.0 --ignore 3.1 --ignore 3.2"
+
+ # Create python3 symlink.
+ eselect python update > /dev/null
+
+ eselect python update ${ignored_python_slots}
+}
+
pkg_postinst() {
- :
-# eselect python update --ignore 3.0 --ignore 3.1 --ignore 3.2
+ eselect_python_update
}
pkg_postrm() {
-# eselect python update --ignore 3.0 --ignore 3.1 --ignore 3.2
+ eselect_python_update
if ! has_version "<dev-python/python-docs-${SLOT}_alpha" && ! has_version ">=dev-python/python-docs-${SLOT%.*}.$((${SLOT#*.}+1))_alpha"; then
rm -f "${ROOT}etc/env.d/65python-docs"