summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2009-10-11 11:33:04 +0000
committerFabian Groffen <grobian@gentoo.org>2009-10-11 11:33:04 +0000
commita866e32b79808c41e8d1e197f5c13b24312e1664 (patch)
treea8cbf590bd749048a7298e1bf0b1709bffe5a116 /dev-python/python-docs/python-docs-3.1.1.ebuild
parentppc stable #282290 (diff)
downloadhistorical-a866e32b79808c41e8d1e197f5c13b24312e1664.tar.gz
historical-a866e32b79808c41e8d1e197f5c13b24312e1664.tar.bz2
historical-a866e32b79808c41e8d1e197f5c13b24312e1664.zip
Merge from Prefix
Package-Manager: portage-2.2.00.14552-prefix/cvs/Darwin powerpc RepoMan-Options: --force
Diffstat (limited to 'dev-python/python-docs/python-docs-3.1.1.ebuild')
-rw-r--r--dev-python/python-docs/python-docs-3.1.1.ebuild12
1 files changed, 7 insertions, 5 deletions
diff --git a/dev-python/python-docs/python-docs-3.1.1.ebuild b/dev-python/python-docs/python-docs-3.1.1.ebuild
index 4b560a831db7..8ba59bf419d9 100644
--- a/dev-python/python-docs/python-docs-3.1.1.ebuild
+++ b/dev-python/python-docs/python-docs-3.1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-docs/python-docs-3.1.1.ebuild,v 1.2 2009/09/27 18:39:53 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-docs/python-docs-3.1.1.ebuild,v 1.3 2009/10/11 11:22:18 grobian Exp $
DESCRIPTION="HTML documentation for Python"
HOMEPAGE="http://www.python.org/doc/"
@@ -8,7 +8,7 @@ SRC_URI="http://www.python.org/ftp/python/doc/${PV}/python-${PV}-docs-html.tar.b
LICENSE="PSF-2.2"
SLOT="3.1"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
IUSE=""
DEPEND=">=app-admin/eselect-python-20090606"
@@ -17,10 +17,11 @@ RDEPEND="${DEPEND}"
S="${WORKDIR}/python-${PV}-docs-html"
src_install() {
+ [[ -z ${ED} ]] && local ED=${D}
docinto html
- cp -R [a-z]* _static "${D}/usr/share/doc/${PF}/html"
+ cp -R [a-z]* _static "${ED}/usr/share/doc/${PF}/html"
- echo "PYTHONDOCS_${SLOT//./_}=\"/usr/share/doc/${PF}/html/library\"" > "60python-docs-${SLOT}"
+ echo "PYTHONDOCS_${SLOT//./_}=\"${EPREFIX}/usr/share/doc/${PF}/html/library\"" > "60python-docs-${SLOT}"
doenvd "60python-docs-${SLOT}"
}
@@ -39,9 +40,10 @@ pkg_postinst() {
}
pkg_postrm() {
+ [[ -z ${EROOT} ]] && local EROOT=${ROOT}
eselect_python_update
if ! has_version "<dev-python/python-docs-${SLOT}_alpha" && ! has_version ">=dev-python/python-docs-${SLOT%.*}.$((${SLOT#*.}+1))_alpha"; then
- rm -f "${ROOT}etc/env.d/65python-docs"
+ rm -f "${EROOT}etc/env.d/65python-docs"
fi
}